Jump to content
Ultimaker Community of 3D Printing Experts
Marcel2016

e3d Titan Extruder -> Firmware settings?

Recommended Posts

Hi guys,

I need your help.

Just changed the Ultimaker 2 feeder to e3d titan extruder.

This is a geared extruder with a 3:1 gear ratio. It uses MK8-like feeder wheel (diameter 6.7 mm).

So the feeder motor has to do more steps to extrude the right amount of filament. The multiplier has to be 3.58 (original steps x 3 x 8 / 6.7).

I downloaded Arduino IDE and opened Marlin.ino.

But where do I have to change settings?

I tried the following:

Tab configuration.h

#define DEFAULT_AXIS_STEPS_PER_UNIT {80.0,80.0,200,282}

->#define DEFAULT_AXIS_STEPS_PER_UNIT {80.0,80.0,200,1010}

- does not work, steps remain 282

Tab configuration_adv.h

#define STEPS_MM_E 836

-> #define STEPS_MM_E 2508

- does not do anything?

Bowden length is set to 2520 (3.58 x 705 mm) to use the Ultimaker2 filament change function.

Max. Limit set to 3000. It is possible to print, if the flow rate is set to 358%. This covers that the calculation of multiplier 3.58 fits quite well.

But with this compromise, I think many things are set wrong. For example the max. extrusion speed, motor acceleration and so on. So this has to be fixed properly.

Any ideas how to do?

Share this post


Link to post
Share on other sites

Hi,

I may be wrong, but i think you can change the steps with the firmware from TinkerGnome (which has a lot of other cool stuff too)

You can find it here:

https://github.com/TinkerGnome/Ultimaker2Marlin/releases

Can you show us how you mounted that extruder? I'm interested in that mod :)

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites

Ok, thank you for your ideas so far.

I downloaded the newest version of tinkergnome´s firmware.

The number of E steps is set on the UM2 display.

Seems to work, but the extrusion rate is much too high.

During UM2 filament change the extracted length is 7.5 cm longer than the bowden tube. I wonder why?

Extruded 10 cm of filament and recalculated the E steps. Now I´m doing a test print. Looks like it is still a bit too much. But this depends on the feeder tension. If it is tightened, the extruder gear grinds into the filament. And the gear diameter becomes a bit smaller. I think, that´s why e3d calls it "effective diameter":O

Here is a picture of the titan extruder mounted on the machine. The grey thing is a filament cleaner.

e3d-titan-UM2-01.thumb.jpg.1523a90d7ae712e0d29acd4890eb90da.jpg

On the UM2 it has to be mounted upside down. I used the stock feeder motor and a printed 1.5mm Nema17 spacer plate.

e3d-titan-UM2-01.thumb.jpg.1523a90d7ae712e0d29acd4890eb90da.jpg

  • Like 1

Share this post


Link to post
Share on other sites

esteps. Did you check if the esteps e3d gives its for a 200 step rev motor or a 400 revolution step? (1.8 it's 200 rev, 0.9 from um2 it's 400).

Read the part about esteps on this unrelated guide

https://ultimaker.com/en/resources/20556-ultimaker-original-175mm-filament-conversion

Use the reprap calculator and adjust the esteps to your motor/feeder.

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites

Nice link. Thank you.

 

The multiplier has to be 3.58 (original steps x 3 x 8 / 6.7)

For calculating the new E-steps I used the old settings. The number of resolution steps remain the same. Only feeder gear diameter and gear ratio change.

The formula for calculating E-Steps results 912.17.

I set it like this and extracted 200 mm of filament. The measured length was more, so this gives a factor 0.89. So the actual E-steps is 812.45.

But the problem was how to change the E-steps in the printer firmware.

 

I downloaded the newest version of tinkergnome´s firmware.

The number of E steps is set on the UM2 display.

I´m sorry, as the posts have become a bit confusing.

Now it works. Thank you at all for the support.

Share this post


Link to post
Share on other sites

When measuring the filament moved the number changes quite a lot between filament moved, filament moved when the Bowden it's use and filament extruded at X temp. I did my calibration using the printrun/pronterface, setting the desired temp and extruding at the feedrate speed that I use to. Then I did top later tests and adjusted the esters until I got a perfect toplayer.

Share this post


Link to post
Share on other sites

Hey there

I know that this thread is old but I am having an issue with getting the e3d titan extruder kit to work with my UM2 Extended and TinkerGnome

If anyone of you has made a modified version of it please I would like to try it

Tried to compile TinkerGnome with my printer using arduino and given data in the e3d tutorial on what to change

But I got ERROR: Tried printing out of printing area

Please anyone who got this with his e3d and solved it show me how or send me his firmware update

Share this post


Link to post
Share on other sites

Do you get this error randomly, or consistently? At the start or well into the print?

It means there is a gcode that is at a value outside of the limits of the print area. For example if your print bed is 200mm wide but there is a G0 X2000 (2 meters) then you get this error.

Many things can cause this error but if it is intermittent it means there is a problem reading the SD card where it's getting random bits flipped. You will also notice the print head randomly moving to strange locations for no reason WAY outside your part and then continuing where it left off.

But if it's consistently at the start of print or during leveling or something then it's something else.

Share this post


Link to post
Share on other sites

Do you get this error randomly, or consistently?  At the start or well into the print?

It means there is a gcode that is at a value outside of the limits of the print area.  For example if your print bed is 200mm wide but there is a G0 X2000 (2 meters) then you get this error.

Many things can cause this error but if it is intermittent it means there is a problem reading the SD card where it's getting random bits flipped.  You will also notice the print head randomly moving to strange locations for no reason WAY outside your part and then continuing where it left off.

But if it's consistently at the start of print or during leveling or something then it's something else.

 

Unfortunately I get it consistently , and only with TinkerGnome in E3D Titan V6 kit

before getting the e3d one I was using the tinkergnome freely

But then I had to E3d marlin version

So if you have or you know someone who does have the e3d kit with the tinkergnome please link me as the marlin firmware is hard to deal with and hard to calibrate the printer with

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy