Jump to content
Ultimaker Community of 3D Printing Experts
Rflynn

Fan @ extruder not running at all.

Recommended Posts

Up date ;

Got the fan to run by removing the line [fan off] in start-g-code, to [fan on] .  But it runs all the time

In cura 15.04.6 in cool advanced is the option  to choose fan on at height, has never worked.  I am going to try no fan on or off in the start-g-code. To see if it comes on at height .6mm.  Wish me luck, any thoughts?

Update;2. Well at 1mm and fan is not running.

What is the g-code after the M106 to have the fan come on after the base is down say 1 or 2 mm. I looked, and can't find the information anyware.

Edited by Guest

Share this post


Link to post
Share on other sites

It sounds like you are talking about the fan that is in the back of the print head? This fan isn't controllable by the user. Depending on how old your machine is it will either run all the time as long as the printer is turned on, or it will turn on automatically once the head reaches 40C.

Share this post


Link to post
Share on other sites

Here's a good reference for Gcode commands:

http://reprap.org/wiki/G-code#M106:_Fan_On

To turn the fan on fully you would do M106 S255

What printer do you have? I'm guessing an UMO since you say "fan" and not "fans" and you're talking about start and end gcode. Take a look at the advanced tab, at the bottom, is "Enable cooling fan" checked?

Share this post


Link to post
Share on other sites

Yes the cooling fan is checked and I have a Prusa i3 if it is checked why does the fan not come on and why would they have the fan set to off? And when the fan is set to off will the cool feature still turn on the fan? When I first put it together and the fan never came on I emailed HicTop and they said I have to check the box to enable cooling fan but it was?

Share this post


Link to post
Share on other sites

Expert config is 1, 100,100, 20 and box is checked,   and there is no code M106 S255 any where like that I put in M106 only it was M107. thank you for helping me, bob.

Edit 1: do you have a small print (sliced) I could try that works on your printer and may be it would set my straight. A thought.

Edited by Guest
Brain storming.

Share this post


Link to post
Share on other sites

Rflynn,

I have an Aurora A3, which is a Prusa I3 style printer. It should be similar enough to your printer for you to print this gcode I generated using Cura 15.04.4:

http://bitman.org/dahai/MakeRobot.zip

Some settings of my to note that may affect your ability to print my gcode:

Nozzle Size: .4mm

Filament Size: 1.75mm

Print Area: 180x180x180mm

Nozzle Temp: 210

Bed Temp: 60

Layer Height: .2mm

Shell Thickness: .8

Fill Density: 15%

No Support and No Platform Adhesion

I also reset the origin as my print head home position is off the print bed. So you may want to remove these lines from the gcode:

 

G1 X40 Y32              ; Move to print originG92 X0 Y0 Z15.0         ; Set this coordinate to 0,0,15

 

Share this post


Link to post
Share on other sites

Thank you I'll try it.

Post 2: I was so not sure, I stopped the print 3 times (and resumed printing from fresh) and every time the fan came on at .3 when the first layer was done. Now haven't printed through the USB cable since I first got the printer, because can't pause and resume, don't have the Plug in that gives me that option. So I 3d print from a SD cards. In-order to use your G-code Print I had to do this. How do I read your gcode in cura 15.04.6 only find my start and stop gcode not the sliced code? looked every where. Thank you one part of the puzzle solved! now what? I'll print one of my prints through USB.

Edited by Guest

Share this post


Link to post
Share on other sites

Try controlling your printer directly using pronterface/printrun and try the 3 most common fan commands to see how your fan responds. It could be that UM doesn't need the fan on command to be able to control the speed. Or alternatively it could be that something is broken in your firmware or hardware such that setting speed to anything below 255 does nothing. Printrun is a free download here:

http://koti.kapsi.fi/~kliment/printrun/

Share this post


Link to post
Share on other sites

You can use Notepad to view and search through the gcode file.

Basically anything before, and including, the "M117 Printing..." is the header.

Everything after, and including, "M104 S0 ;extruder heater off" is the footer.

It's odd that the extruder fan started as soon as the print head moved off home. The gcode I sent is set to turn the fan off initially in the header:

 

M107       ;start with the fan off

 

And then not turn it on until Layer 1 at a height of .5mm:

 

;LAYER:1M106 S255G1 F2400 E33.35886G0 F7200 X88.790 Y82.536 Z0.500

 

You have just a single fan for the extruder, right? This is your printer?

2015231356190.jpg.87f7cbb9358e24f1f74ab41b8a32c6ca.jpg

In your printer's menu, can you turn that Fan on/off through the Control / Temperature / Fan Speed menu by setting it to 255 for On and 0 for Off?

Is there more than one fan listed?

Also, in any of the gcode you generated, can you find any 'M106' command with any parameters after it?

Sorry, asking lots of questions...

2015231356190.jpg.87f7cbb9358e24f1f74ab41b8a32c6ca.jpg

Share this post


Link to post
Share on other sites

Yes that is my printer and I found the problem, not sure on the fix though. Ok when cura is slicing my print in the ;layer1: found M126 T0 ;value=127

OMG it is trying to open a valve. I edited the code for M106 S255 and saved it and will print next, to see.

Share this post


Link to post
Share on other sites

Running print and fan came on at .4 Wow it is working....... Thank you every one for all the help now how do I fix cura from doing this so I don't have to edit every print or just use Slicer in Repetier any thoughts. or when I installed cura did I do something?

Share this post


Link to post
Share on other sites

Ok, I'm assuming you're running Windows:

Try doing an Uninstall of Cura and then go to:

C:\Users\yourname\.cura\15.04.4

Where yourname is the username you log into Windows with.

Then delete everything in that folder.

Then try reinstalling Cura again.

Share this post


Link to post
Share on other sites

Great! Glad Cura is finally working and turning on the fan for you!

As for the USB cable crashing Windows 10, it sounds like a USB Driver problem. I'd suggest contacting HicTop and see if they have an updated USB driver for their printer that works with Windows 10.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!