Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
mrcdesign

Ulticontroller Motion no Z axis

Recommended Posts

Hello,

I bought an Ulticontroller, but in the menu i cannot control the Z Axis, is this meant to be?

On the manual i read that you should be able to. Especially when you preheat, there should be more then 1 mm between the nozzle and the bed else you get a blob of plastic.

What should i do?

---

Edit

After searching google some more, i seem to be missing more things in the menu, like "autostart" (but that could be the name) "set origin" "extrude"

 

Share this post


Link to post
Share on other sites

Set origin was removed in more recent versions, because it was not desperately useful in most cases. You use prepare -> auto home to find the physical endstops and set the 0,0,0 point.

Moving the z-axis using the Ulticontroller doesn't always seem reliable in my experience. It can sometimes lead to missed steps (the motor makes a chirp sound, instead of moving completely). Usually this isn't critical, if you just want to get the head out of the way.

Another alternative that I find useful is to hand-craft a gcode file to move the head to a standard position- e.g., home x and y, and move the head up 20mm from whereever it currently is. I save that in a 'Utility' folder on my SD card, and then, for instance, if I stop a print due to a problem, I can quickly run the gcode from that folder in order to get the head out of the way.

Finally, I strongly recommend against using the Ulticontroller menu to advance the extruder. It pushes plastic through the nozzle far too quickly, and can cause head blockages. Instead, just turn the big gear by hand (you may need to select Prepare -> Disable Steppers first, or wait a minute for the motors to turn off, otherwise the gear can be hard/impossible to turn by hand). If you turn it by hand, you get a better idea of the rate of feed that the head can handle - you'll start to feel resistance if you turn too fast, and can adjust.

 

Share this post


Link to post
Share on other sites

No, there's a particular gcode that cause the 'heat and wait' behavior. If that isn't there, it won't heat (or wait). I strongly recommend that you take a look at the gcode that your slicer is generating, and compare it to a reference list like this one, in order to get a feel for how it works. Its really very simple. The only thing to remember is that speeds are in mm per minute (i.e., 60mm/s = F3600), and once a speed is set using an F parameter on a move command, it stays set unless changed, even if it isn't given on subsequent lines.

That said, here's the code I'm using these days:

; Move to home and a relative height of 40mm

G28 X0 Y0 F3600 ; home x and y

G91 ; relative position

G1 Z40 F600 ; move up 4cm

M84 ; release steppers

 

It's also included as an attachment, below, that you can copy onto your SD card.

 

Share this post


Link to post
Share on other sites

I also like to move my Z axis by hand whenever possible. It takes about one second. Whereas it takes a whole second just to get my hand to the knob on the UC, let alone push it, rotate to a menu, push it again and maybe a few more times.

Turning the extruder by hand is even more important. In both cases you can feel if the resistance changes (due to something going wrong with your UM).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy