Jump to content
Ultimaker Community of 3D Printing Experts
bob

Ultimaker original Temperature sensor error

Recommended Posts

I made a custom heated bead for my Ultimaker Original, it has worked for about a year with out an issue. Unfortunately the bed Thermistor shorted with the bed power cable today, neither the Thermistor nor the arduino mega was damaged, though I replaced both anyway.

 

Now the issue that I have, is that the bed temperature shows approximately 800°c and thus causes a max temperature error, this is the same temperature that is displayed when no Thermistor is connected as well as if I connect 100k ohm resistor (its a 100k thermistor, so should show 25°c). This leaves the ultimaker controller as the most likely error source. I don't have one lying around, and the next possible replacement is in china, which would take a month to get shipped (I also don't want to change to a different controller since the system is made for a 19v power supply, and no one carries them anymore). Does anyone know what possible components on the board could have fried? or could I just switch to the sensor 2 on the board, and how would I set that up in the firmware?

 

Thanks

Share this post


Link to post
Share on other sites

I would put the old thermistor back in there.  There are probably a dozen differen types of "100K thermister".  They all have very different tables that convert resistance to temperature.

 

Do you still have the 4.7K resistor installed?  Maybe that got burned out.  When everything is hooked up, what is the actual voltage on either side of the 4.7K resistor?  There should be a voltage divider with the 4.7K resistor and the 100K resistor.  So if one is 4.7K and the other is 100K then the 5V should get divided (well multiplied really) by ratio R1/(R1+R2) (not sure which is which and too lazy to check schematic, sorry).

 

That means either 0.22V or 4.77V assuming the thermistor is 100K ohms when you take the measurement.

 

Share this post


Link to post
Share on other sites

I checked the 4.7K resistor, that was what fried, thanks, would never have checked that...

 

Unfortunatelly I seen to have another issue now, the printer pauses between each straight line for about 2 seconds... Any idea what could cause this? I already tried re-replaceing the arduino, that did not help...

Edited by bob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 97 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!