Jump to content

Position of stl file in cura


Recommended Posts

Posted · Position of stl file in cura

 

Is there any possibility that cura places my imported stl file not in the geometric centre of my part but with the same origin/ coordinate system as it has in my cad design (fusion 360)?

Thank you for your help!!

  • Like 1
Link to post
Share on other sites

Posted · Position of stl file in cura

The problem is that I have one body which I spilt into two parts. I print the first part of the body. Then I want the second part printed at a certain place. In my cad design it's on the right position, but when I open it with cura it's centred in the middle of the build plate. 

 

I've already tried to align it manually and measure the distance of the different origins with my cad software but it's never exactly at the point where I want the second part to be printed.

 

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    I am having the same exact problem.

    I use SolidWorks and I have an assembly with multiple parts positioned correctly in the CAD but when I import the files into cura the parts when combine are in a different place.

    Did you manage to find a solution?

    Please help 🙂

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    Unfortunately not. I'm still trying to measure with my cad software. I also tried other slicers to find out if one is capable of measuring or to find the same position like in the orignal draw. But nothing out there 😕

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    Hi Thank you for your reply.

    I have changed my model in SolidWorks so that all the bodies are now connected.

    maybe you can do the same with your model.

    There is a bit of more cad work to do but it seams to work for me.

    See file attached.

    Let me know what you think.

     

    STEVE BIRTHDAY.zip

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    Hey! Thank you for sharing your solution.

    I'm not sure if that will work out for me, as I have a complete part in the beginning and I split it into 2 single pieces on purpose. After the first part is printed I want to rotate the build plate and then continue printing with the second part (to avoid support material).

    But I'm happy to hear that you found a way to print your part! 🙂

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    I’m having the same issue. Too bad the topic hasn’t received more attention. Have you had luck in any other forums?

    It would be great to have an option to turn off auto centering and just allow the data to be located relative to it’s CAD export position. 

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    Maybe you could do it with a trick? Put four tiny dots outside of each corner of your models. So that they form an imaginary rectangle that encloses your design. Or draw a custom skirt around your design; just one layer height is sufficient. Then that surrounding skirt or border should always be placed in the same position on an empty bed. Keep that skirt, or those four dots, in place, and then correctly place the rest of your components in this space, and save as separate files. When slicing, the skirt (or the four dots) should determine the position on the glass. At least, that is what I would expect. Try this with a small test piece first, before wasting too much material on a real big model.

     

  • Link to post
    Share on other sites

    Posted · Position of stl file in cura

    I found a solution. Prusa slicer has an option to split up multiple bodies that come in as one stl file. Bringing them in as a single stl keeps them located relative to the CAD export orientation. After splitting they show up as a sub-assembly on the right information window. At that point you can edit the components you don’t want to print by calling them support blockers. Then switch the settings for the second run.
    It’s a great way to keep components correctly located relative to each other but print separately. 

  • Link to post
    Share on other sites

    Posted (edited) · Position of stl file in cura

    So, I have one unique but dirty solution. I do not see it anywhere else so I will put it here.

    It seems that this issue is brought up by Cura ignoring the origins set in STL and putting the geo center as the origin.

    The solution goes as following:

    1. In your CAD software, mirror your model using the z axis as your axis of symmetry (you can do it simply by rotating it 180 degree). 

    2. Export it as STL.

    3. Import it in Cura, and you will find that the (0,0,0) is the same as the one in your CAD design. It is because the origin in your model is exactly the geo center.

    4. In Cura, use mesh tools -> split models into parts

    5. Delete the unwanted mirrored part. Done!

     

    This is the simplest solution I can think of by far. It has certain limits but with some modification it can be used in most situations.

     

    If you simply want to keep the relative positions of your parts, just use "merge models" as others mentioned. But unlike the method I mentioned above, the origin would change.

    Edited by demianxx
  • Link to post
    Share on other sites

    Posted · Position of stl file in cura
    On 12/16/2019 at 3:36 PM, geert_2 said:

    Maybe you could do it with a trick? Put four tiny dots outside of each corner of your models. So that they form an imaginary rectangle that encloses your design. Or draw a custom skirt around your design; just one layer height is sufficient. Then that surrounding skirt or border should always be placed in the same position on an empty bed. Keep that skirt, or those four dots, in place, and then correctly place the rest of your components in this space, and save as separate files. When slicing, the skirt (or the four dots) should determine the position on the glass. At least, that is what I would expect. Try this with a small test piece first, before wasting too much material on a real big model.

     

    Hey mate just wanted to confirm that the trick you describe is working perfectly well! Thanks for this 3 years ago or anyone that stumbles on this thread

    And the trick below works like a charms as well!
    Just a precision step 4. = go to the marketplace (top right corner of the interface) and download the plugin from there. Once installed go to Extensions.

    On 6/9/2022 at 12:15 AM, demianxx said:

    So, I have one unique but dirty solution. I do not see it anywhere else so I will put it here.

    It seems that this issue is brought up by Cura ignoring the origins set in STL and putting the geo center as the origin.

    The solution goes as following:

    1. In your CAD software, mirror your model using the z axis as your axis of symmetry (you can do it simply by rotating it 180 degree). 

    2. Export it as STL.

    3. Import it in Cura, and you will find that the (0,0,0) is the same as the one in your CAD design. It is because the origin in your model is exactly the geo center.

    4. In Cura, use mesh tools -> split models into parts

    5. Delete the unwanted mirrored part. Done!

     

    This is the simplest solution I can think of by far. It has certain limits but with some modification it can be used in most situations.

     

    If you simply want to keep the relative positions of your parts, just use "merge models" as others mentioned. But unlike the method I mentioned above, the origin would change.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 2 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...