Jump to content
Ultimaker Community of 3D Printing Experts

Preview simulation bar not visible


Andrea22
 Share

Recommended Posts

Posted · Preview simulation bar not visible

Hi,

I have Cura 4.0, why I can't see in preview the simulation bar? The orizontal bar. Moreover I can't select (no present the drop down list) something different respect "color scheme"

 

Thanks,

Andrea

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Hi Andrea,

     

    your question is a bit unclear, perhaps this is the reason noone reacts.

    If I understood you right, you are missing the tool, where one can see how the object will be printed each layer, right?

    At my Cura 4.0, this feature is placed in preview mode, middle of BOTTOM line, direct under the buildplate.

    I hope I understood your question right and could help.

     

    Regards

  • Link to post
    Share on other sites

    Posted (edited) · Preview simulation bar not visible

    Yes the problem is that I can't see the orizontal bar. I see only the vertical one that permit to change layer, BUT NOT the orizontal one that permit to check how is realized the layer with the movment of the hotend. This feature should be activated somewhere? I see it in all youtube videos. My system is Windows 10.

    Practically I don't see the bar in red cirlce below and I can't select nothing a part "Line type" in the right of below picture.

    image.thumb.png.13b08846b9395ee0ae30935837b169e8.png

     

    Below the picture that I have:

    image.thumb.png.1a5f043ed682744db8083dc3d5af4349.png

     

    Thanks for help.

     

    Edited by Andrea22
  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    That's because your layerview is in compatibility mode. This happens because of two reasons; You either selected this in preferences or your graphics card doesn't support opengl 4.1. 

     

    Note that in the first screenshot, the Sidebar GUI plugin is used to rearrange the UI. This made the vertical slider move to the left of the settings.

    • Like 1
    Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    I have 2 Laptops:

    first: whit Intel(R) HD Graphics 4000 and ok ... he should not support Open GL 4.1 but only 4.0 even if the last driver espose some API Open GL 4.1

    second with Intel(R) HD Graphics 4600.... this should support Open GL 4.1 (it should support 4.3)  but in any case I have the same "issue".

     

     

     

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    The gpu in the first laptop does not support the required functionality for the normal layerview, so it falls back to the compatibility mode.

     

    The gpu in the second laptop should support the required functionality. There are two possibilities why it does not work:

    * You may have changed the preference on the General pane of the preference to force the compatibility mode

    * The driver you have installed on the laptop may disable OpenGL 4.1

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Hi Guys, 

     

    I also meet the same problem on my PC (Windows 10, HD Graphics 4000 ) with Cura 4.0.0 and 4.1.0. 

    I reinstalled the graphics driver, reset it to initial state and bunch of strange thinks but all with no result. 

    The curious thing is that I have Ubuntu Linux in the same PC and when I switch to it Cura 4.0.0 does show this preview simulation and also view type as color scheme.

    So I am ready to blame Windows, but still I will need a solution for this issue.  

    Maybe a specific driver should be installed...

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    The HD Graphics 4000 gpu does not support the functionality for the advanced layerview, so Cura uses a simplified version that does not have that slider instead on your computer.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible
    20 hours ago, ahoeben said:

    The HD Graphics 4000 gpu does not support the functionality for the advanced layerview, so Cura uses a simplified version that does not have that slider instead on your computer.

     

    ОK, this seems to be a legit answer/solution but what about the curious moment when on the same PC with Intel HD Graphics 4000 Ubuntu manages to show layer view and all features intransigent? 

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    It could be using a software implementation of OpenGL 4.1 on Ubuntu. How slow is it?

     

    The hardware of the HD Graphics 4000 gpu only supports up to OpenGL 4.0.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    OK, than maybe there is similar software implementation  for Windows 10?
    It is not slow at all under Linux, the speed is the same as the speed by Windows environment.

    Is it possible to solve the issue or I just have to resign with the situation? 

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    I don't think it is possible to solve the issue for mere mortals.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible
    2 minutes ago, ahoeben said:

    I don't think it is possible to solve the issue for mere mortals.

    ...then lets dive into the real troubleshooting :)

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    From some quick Googling, it appears that Linux uses Mesa. It appears Mesa will use hardware rendering where it can, but also falls back to software rendering for things not supported by hardware.

     

    So no troubleshooting to do here. The Linux OpenGL 4.1 support on HD 4000 is not an existence proof of 4.1 features on this GPU.

     

     

    • Thanks 1
    Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Wow, this is a sad story.

    Thank you very much for the detailed explanation. I hope it will help other people in the future. 

    I might migrate my work with Cura to Ubuntu Linux 😉

     

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Hi I have the same problem ,is there anything that can be done to get the horizontal bar back

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible
    7 hours ago, bsdriffield said:

    Hi I have the same problem ,is there anything that can be done to get the horizontal bar back

    Unfortunately the only solution is to use another graphics card or to switch to Ubuntu OS.

  • Link to post
    Share on other sites

    Posted (edited) · Preview simulation bar not visible

    In this thread I read that someone was able to run Cura on a Windows System with HD 4000 graphics. In my case the program refuses to start after installation.
    Can someone confirm that it's impossible to run Cura 4.3.0 under Windows 7-64 with CPU i5-3320, 8 GB RAM, SSD and onboard graphics HD 4000 ?
    On one hand "OpenGL Extensions Viewer" reports that my system supports the core features of OpenGL 3.x and 4.0. So I thought that my system meets Cura's requirement of OpenGL 4.0. On the other hand, Cura reports "OpenGL context is too low: 1.1 No profile".
    Are there other features besides core features that have to be supported? 

    The stdout.log reports
    [MainThread] UM.View.GL.OpenGLContext.detectBestOpenGLVersion [185]: Current OpenGL context is too low: 1.1 No profile
    [MainThread] UM.Qt.QtApplication.initialize [135]: Startup failed because OpenGL version probing has failed: tried to create a 2.0 and 4.1 context. Exiting

    Regards
    Karsten

    Edited by KaosKatte
  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Are you perhaps trying to run Cura in a remote session? That is not supported.

     

    If not, you need to install a (newer) driver for your GPU.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Thanks for your quick reply.
    The driver is the newest available, 10.18.10.5069 dated 27 Dec 2018.
    Sometimes I use VNC and deactivated the VNC mirror graphics driver, but i'm using my notebook locally - no remote session.
    Once I had a problem with the special character "ö" in my user name when I tried to install a differnt software. So this time I installed with another user account that contains no special character in its name. No effect.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    In the meantime I successfully installed Cura and Autodesk Fusion 360 as well. Both programs refused to start at first try.  My 400 GB Samsung SSD showed only about 10 GB free space so I cloned it to a new one with 1 TB. The old one used a RAM disk (Samsung Magician), the new one not. So I think a lack of free space or the use of a RAM disk was responsible for Fusion 360 and Cura not to install and start properly. Because the new SSD is a clone of the old one, there are no other differences between old and new system.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible

    Hello, I created an account in order to get help for a similar problem. I also do not have any kind of simulation preview in Cura 4.4. Is this because I'm running Windows 1`0 and not a Linux-based system? My graphics adapters should be able to handle this (2x AMD RX 480 8Gb). Thank you in advance.

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible
    On 4/1/2019 at 4:24 PM, ahoeben said:

    It could be that your GPU does not support the features needed for the full layer view and reverts back to “compatibility mode”. Then there is no animation slider.

     

    HI there ... it seems i have the solution for that. 

     

    My laptop is using an old nvidia GT 640m , with on old  I7 processsor and windows 7 home premium. 

    since the problem is with GL rendering,  the solution is quite simple. All you have to do is just add cura program files at nvidia control panel as picture below.

     

    image.thumb.png.6a31491140cd625da6c6ed9e00bae67c.png

    and don't forget to choose "high performance NVIDIA processor" . 

     

    Close , and That's it! 

     

    run Cura, and preview bar will show up as usual. 

     

    If you are using AMD driver, use the same technique. It seems the issue comes with laptop with dual graphics card. Some how the windows detects Cura only need default Graphics Card, that doesn't support open GL .

     

    I hope my solution helps 

     

     

    Rafael 

     

     

     

  • Link to post
    Share on other sites

    Posted · Preview simulation bar not visible
    2 hours ago, r4ph said:

    If you are using AMD driver, use the same technique. It seems the issue comes with laptop with dual graphics card. Some how the windows detects Cura only need default Graphics Card, that doesn't support open GL .

    Hi r4ph,

     

    Thanks for the suggestion. I tried to enable the Radeon driver to launch Cura as you have advised, but there is still no simulation preview. I will try again on my laptop (which has a Nvidia GTX 1060) and report back.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...