Jump to content
Ultimaker Community of 3D Printing Experts

Trouble uploading firmware.


spenter
 Share

Recommended Posts

Posted · Trouble uploading firmware.

While updating firmware on my mother bd something went wrong. Now it will not communicate.

 

The motherboard shows up in printers and devices but when trying to reprogram with Cura it instructs me to plug in the printer.

 

I though it was bricked but from researching this it must not be if my computer sees it.

 

Any thoughts sugestions?

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    First of all it would be helpful if you say us, which printer you have and in case of an Ultimaker printer, which firmware you have tried to upload.

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    It is a UM2 I cannot upload the standard firmware now. Was trying to up load custom firmware when things went sideways.

     

    Trying to add a Diamond Hotend. 3 in 1 out.

     

    I have tried Cura 2.4 and 15.4.

     

    Hope this helps.

     

    Thanks for your time

     

     

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    If there is no functional firmware on the printer and Cura does not connect to the printer, Cura cannot currently be used to flash the firmware. A workaround is to find a copy of Cura 15.04 and use that to install firmware.

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    Ok here is my progress.

     

    I have used 2 different usb cables. Successfully programmed an Arduino when I though I need to reload the bootloader.

     

    Have just tried Cura 15.04 with the same results.  The bd still shows up in Device manager when I turn it on and off.

     

    Tried unplugging the usb as suggested; did not help.

     

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    Is this on a PC?  What is the "com" port?  I think there was a bug in most versions (all versions?) of cura where it only uses com ports up to around 10 or 20?

     

    You can use arduino software to load the hex file or other software - I think pronterface might be able to upload hex files onto a UM2.

     

    But easier to keep switching PCs or Macs until you find one that has the com port < 10 (e.g. COM3)

     

    Power cycle the UM2 occasionally also.  Also for some people the USB on their computer just doesn't have the power that a UM2 needs so adding a USB hub could help - or again - just try a different computer.

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    Here is my latest progress.

     

    Managed to program another bd with Arduino. 

     

    Still cannot program my bad bd. The programmable one has a bad Z switch.

     

    Only thing I observe is one bd connects to port 6 the other to port 5 even though I am using the same usb plug on my PC.

     

    Could not program any bd with cura 15.4 but could with 2.4

     

    Pronterface only has port 1 and 3. Waiting for my laptop to charge up to try that.

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.

    Hi

     

    Keep in mind that boards *do* go bad. The flash memory on your typical MCU has a very finite number of rated re-program cycles. If you have been doing a *lot* of firmware updates, you may have hit this limit.  I (unfortunately) have proven this a couple of times in the past ...... 😞

     

    Bob

  • Link to post
    Share on other sites

    Posted · Trouble uploading firmware.
    7 hours ago, uncle_bob said:

    Hi

     

    Keep in mind that boards *do* go bad. The flash memory on your typical MCU has a very finite number of rated re-program cycles. If you have been doing a *lot* of firmware updates, you may have hit this limit.  I (unfortunately) have proven this a couple of times in the past ...... 😞

     

    Bob

    Thanks but it ws a new bd. First time I re-programmed it. I did a build with Arduino. Exported the binary files of which I got 2. One had bootloader in the title. Wrong one to try to program the bd with. Have not been able to communicate with it since.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...