Jump to content
anoxde

Linux PC freezes after cura appimage start (now REALLY solved)

Recommended Posts

Posted (edited) · Linux PC freezes after cura appimage start (now REALLY solved)

Hi Community,

 

I'm using Cura (appimage 4.2.1.) since a couple of months on a Linux PC (with a not-brand-new SuSe 13.1) without any problems.

 

Starting just some hours ago the PC freezes after the appimage start (tried it several times). Means, the little Cura windows with the Ultimaker Tobot appears, like always, then the normal Cura window appears very briefly, then the screen gets black, then back to normal but from this point on there is no reaction at all, no mouse, no keyboard interaction is possible, just a restart with the reset button on the PC (VERY seldom with Linux!)

 

Btw: The newer Cura appimages 4.3.0 and 4.4.1 won't start on my system at all...

 

Except a Firefox update a few hours earlier nothing is changed on the PC.

 

Read in another thread, the attached file may be helping for diagnosis?! I cannot do much with it 😞

 

Perhaps someone has any idea or hint for me? Or do I have to provide some more info? Would appreciate it very much, because I had some plans with my 3D printer the next days 😉

 

Thanks in advance

 

Alex

stderr.log

Edited by anoxde
problem solved by myself

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

A little trying solved the problem:

 

Some time ago I installed the plugin "FreeCAD Integration" but never used it. As I read about problems with it, I simply deleted it by hand from the path (in my case: /.local/share/cura/4.2/plugins/). And now Cura is working again how it should! Great! But WHY, that remains a mystery?!?

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

Good to hear you have a solution.

This plugin is maintained by @thopiekar so I'll tag him in case he can shed any light onto this.

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

Could you please send us your cura.log, too?

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

Yes, I attached it here!

 

Thanks for your interest, hope it helps...

 

@maht: Thanks also for the tag 😉

cura.log

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

I took a look over your log and I don't see any error messages related to my plugin. I see that the last message it somewhat stuck after the OpenGL driver has been initiated, but there is no relation I see to my plugin.

Are there any users around who share the same symptoms with similar GPU or other hardware?

 

Cheers!

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

Hi! Thanks for looking over, obviously you are right that it has nothing to do with the FreeCAD plugin, because after a few times working with cura without any problems, just now it happened again (FreeCAD plugin is still not installed again).

 

So it was probably just a coincidence. Good for you, bad for me 😉

 

I have again attached the two logs, perhaps someone has another idea?!

 

And again just before weekend with lots to do 😞

 

 

stderr.log cura.log

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

Hi @anoxde, from your log files it appears to stop immediately after loading some Open GL shader files. It is not clear whether it hangs loading the last shader file or whether it managed that and then failed to report anything else.

 

Assuming that the problem is related to the graphics system, it may be worth trying a reboot and seeing if that helps. Also, looking at some system log files (/var/log/syslog, /var/log/kernlog, etc.) may provide some hint.

 

Hope this helps.

 

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

Tried a lot of things now, but didn't help 😡... Think this will be left unsolved, because before I get too frustrated 🙄 I decided to switch my whole system to new kubuntu (which I already planned for some time) and then go with the newest version of cura... So thank you all for the tips and wish me luck 😎

 

Cheers!

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

i am having similar problem... Cura runs but hangs at the screen as shown in attached screenshot... i will look at the recent updates for Linux Mint 19.1 to see if it is a kernel or gui issue

Cuar blank screen 2020-03-16 12-40-15.png

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

while trying to fix this, i came across 

and PRISMA3D's solution SOLVED it... although i just renamed the 'qtshadercache' folder to 'REMOVED-qtshadercache' so i could go back to original name if the problem wasn't fixed

Share this post


Link to post
Share on other sites
Posted · Linux PC freezes after cura appimage start (now REALLY solved)

@getglenn:

Hi, read your last post... I don't have a qtshadercache-folder, at least not in ./cache, but there is a cura-folder there with a /qmlcache sub-folder. I simply renamed the cura-folder, started the appimage and... it worked! Cura created a new /cache/cura folder, after one use nearly empty, while the old cura-cache was nearly 700 MB (!) something went wrong there... So, now its REALLY solved (i hope)... the second problem - see my separate post:

is now also solved, there were some (very little) updates for Kubuntu in the last days and now its running!

 

Thanks all for help!

Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Survey: Understanding your workflow
      Interact with future concepts and aim to collect your feedback and opinion. In particular, if this would/could be a welcome addition to your 3D printing workflow. Interested?
      • 0 replies
    • Coronavirus: Let's do our part
      Through this post I would like to further explain what we are doing, and what you could be doing. 
      Our efforts consist of 2 layers. First; connect medical institutions and hospitals to (local) 3D Printing hubs to help them print parts of which a 3D model already exists. And second, contribute to design the necessary part and then have it printed via a (local) 3D printing hub. Experts are available from within Ultimaker and from within our network of 3D printing experts.
        • Like
      • 49 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!