Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Y axis tilted in steps

I built my printer and have been adjusting it so far.  I do have a little knowledge of printers due to making prototype parts for a printer company (DeltaMaker) on cnc lathes and mills.  

Now for the problem. I was using Prusa slicer and it was printing ok just didn't quite like the slicer so I am trying Cura.  The first print was of a piece that was already printed with Prusa.  This time with Cura it was printing and the y axis was leaning to the rear in steps. Including pics. 

Now before you say its losing steps or slipping, I canceled the print and immediately moved the x and y axis back to 0 position and they were still exactly at the 0,0 homing points.  I haven't looked thru th G code yet but am going to.

Does anyone have any experience with this  problem. It only changed when I switched to Cura.

I think I would like Cura better as long as I can get this stopped.

Thanks for any help.

20200814_114235.thumb.jpg.029d40c47bdab97091c9596cebbe0d1c.jpg20200814_114248.thumb.jpg.eb2c81d9d6724a5ea3d82b94f30ad58b.jpg

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    It's losing steps or slipping.  Oops I said it, lol.  So when you go back to 0,0 it's homing and using the limit switches (or if it's not homing it still stops when it tries to go past the limit switch it just stops when it hits the switch).

     

    I believe the entire bed moves on a Prusa when you move Y so this is a common axis to slip or lose steps.

     

    The problem could be many things - the first things to check are jerk and acceleration.  Make sure jerk and acceleration control are disabled in cura (one checkbox for each feature).

     

    Then there are other possibilities.  Marlin (the firmware on Prusa and on Ultimaker printers) has a lot to be desired.  You can exceed the steppers ability if you give it the right gcodes.  So basically I'd set the speed to what you are used to on Prusa and then search for "speed" in settings and make all the printing speeds the same (by default Cura does 200% speed I think for infill for example).

     

    Most importantly lower travel speed by 50% as a separate experiment.  Or just try everything and then undo each feature to see which one was the cause.

     

    Also just tighten any pulley that might be slipping - particularly the one on the stepper.  Tighten the set screw - tighter than you think is enough.  If you use an L shaped allen wrench and grip the short end of the L it should hurt your fingers.  So tight that that wrench twists a bit.  Scary tight.

     

    There are other settings that are different from prusa slicer that you don't need and might be contributing so:

    disable coasting

    disable "retract before outer wall"

    disable "avoid printed parts when traveling" (I doubt it's this one)

     

     

     

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    Thinking some more, it seems tightening pulleys but also "travel speed" are the top 2 things to mess with.  Let us know what it was.  You are not the first to post about this issue for a prusa-like printer and most people fix the problem without sharing the solution.

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    The reason I said it wasn't slipping or loosing steps was because I moved it back to 0,0 with G1 command without rehoming it. and it was right on the limit switch and M114 says it is exactly x0 y0. I am printing it again with the old gcode to make sure right now.

    It doesn't look like the gcode positions are off because stepping thu it in octoprint it does not look like the walls are shifting.

    I'll try some settings and try again when this on goes far enough to see how straight it is.

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    It may have hit the limit switch when you used the G1 command.  Meaning if not for the limit switch it may have tried to go beyond 0,0.

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    I guess a better test at the end would be to do:

    G1 Y2

    G1 Y1.5

    G1 Y0.5

     

    to see if it hits the limit switch before it gets to Y=0.

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    Beside of loosing steps (is as well my first impression), maybe a slipping build plate/sheet?

    What motor current did you set up?

  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    Yes exactly what I'm checking now. I'm still in the building stage and printing the adjustable bed supports.  Only have 4 made and on the X sides, none yet on the Y ends, so I just secured the glass and trying again. It wasn't moving with the other slicer but I think the acceleration settings were way up on this one. I'll see how this comes out this time.

  • Link to post
    Share on other sites
    Posted (edited) · Y axis tilted in steps

    Ok figured it out. There's something in the gcode that happens every so many layers at the end of the layer that moves only a small move but very fast and it shakes the whole machine on the table. With the glass not totally anchored, still printing the bed supports, it was sliding the glass. The glass is 25" x 30". Will have to figure out what move is doing it.

    It's strange it does it for a few layers then stops for a number and then does it again. You can see from the picture how it happens in groups.

    Have to find it and slow it down.

     

    Edited by DeanS
  • Link to post
    Share on other sites
    Posted · Y axis tilted in steps

    Glad you found it. Check your speed and acceleration settings for Cura and your firmware. Cura's default settings are in general fare away from everything you want for successful prints. In your case I would look for travel speed and acceleration in general first.

     

    For Cura it is maybe a good idea to limit all the different speeds to one slow speed for first tests, e.g. 40mm/s. An other useful setup parameter can be Equalize Filament Flow in combination with Maximum Speed for Flow Equalization.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...