Jump to content
Ultimaker Community of 3D Printing Experts

4.7 is now auto bed leveling on every print?


Recommended Posts

Posted · 4.7 is now auto bed leveling on every print?

I installed the 4.7 update last week and now my Creality CR10S Pro does an auto bed level now at the start of each print.  How do I disable that?
note that in my attached images, my Gcode shows that G29 auto level command, but my machine settings do not have that setup.

 

This action never occurred prior to 4.7 and I have poured over the settings unable to find where this new line in the GCODE is being set.

 

 

bedlevel2.jpg

BedLevel1.jpg

  • Link to post
    Share on other sites
    Posted (edited) · 4.7 is now auto bed leveling on every print?

    One change I noticed in version 4.7 was the line you have highlighted. Previously bed leveling was done with M420 and it's related parameters. There's some discussion going on among CR10 users prior to 4.7 release in a couple of threads where some were having issues with a triangular extrusion pattern between the bed leveling process and initial purge print, possibly resulting in the change from M420 to G29 in the 4.7 release. We would have to have someone from Ultimaker confirm that to be certain though. 

     

    Best thing i can suggest is go have a read of marlin's g-code on their site,  it elaborates on the differences between G29 and M420. 

     

    G29 info here - https://marlinfw.org/docs/gcode/G029.html

    M420 info here - https://marlinfw.org/docs/gcode/M420.html

     

    You may need to double check what functions are enabled in your firmware version too. If you're using firmware 1.70 from Creality, M420 is bugged thus you need to use G29.  

    Edited by Longtoke
    addition info
  • Link to post
    Share on other sites
    Posted (edited) · 4.7 is now auto bed leveling on every print?

    I'm big on work-arounds.  Hopefully somebody will drop by and explain how to keep the G29 from being added.  In the mean time...

     

    In Cura go to Extensions / Post-Processing / Modify Gcode and in the dialog box select "Add a Script".  From the list select "Search and Replace".  In the "Search" box put G29 and in the "Replace" box put ;G29 .

    All G29's in the file will be commented out.

    Edited by GregValiant
  • Link to post
    Share on other sites
    Posted · 4.7 is now auto bed leveling on every print?
    13 hours ago, GregValiant said:

    I'm big on work-arounds.  Hopefully somebody will drop by and explain how to keep the G29 from being added.  In the mean time...

     

    In Cura go to Extensions / Post-Processing / Modify Gcode and in the dialog box select "Add a Script".  From the list select "Search and Replace".  In the "Search" box put G29 and in the "Replace" box put ;G29 .

    All G29's in the file will be commented out.

     

    This worked PERFECTLY!  Thank you so much for the help!!!!

  • Link to post
    Share on other sites
    Posted · 4.7 is now auto bed leveling on every print?

    It looks like it gets added to the Start-Up Gcode box in Cura as a default for your printer.  You can either delete the line from your Start-Up Gcode, or put a semi-colon in front of the G92 so the printer will ignore it.  Either way would allow you to get rid of the Search and Replace plugin.

  • Link to post
    Share on other sites
    Posted · 4.7 is now auto bed leveling on every print?

    Hi.  I am new to 3D printing.  I have update Cura to the latest version and my CR10S Pro is auto-leveling before each print too.  Will this cause problems with the printer? Should I disable it ?  Thanks.

  • Link to post
    Share on other sites
    Posted · 4.7 is now auto bed leveling on every print?

    It was causing issues where I would level the bed and then the auto level was reading differently when the printer did it before each print

    See above comment on how I disabled it

    • Like 1
    Link to post
    Share on other sites
    Posted · 4.7 is now auto bed leveling on every print?

    Thanks for your input. Worked perfectly well !

  • Link to post
    Share on other sites
    Posted · 4.7 is now auto bed leveling on every print?

    I am having a similar issue, however it started at 4.6 for me.  I was using 4.5 and updated to 4.6.  I downgraded back to 4.5 and all was fine.  Thought maybe it was just a 4.6 issue so I updated to 4.7 the other day and it is still occurring.  However, I am seeing more than just the G92.  My printer is an Ender 3 Pro, and I do have an TH3D EZABL Pro so I have start g-code for generating the mesh.  This is my start G-code:

     

    ;*** Start Dual Nozzle/Bed Preheating ***
    M140 S{material_bed_temperature_layer_0} ; start preheating the bed
    M104 S{material_print_temperature_layer_0} T0 ; start preheating hotend
    G28 ; home
    M190 S{material_bed_temperature_layer_0} ; heat to Cura Bed setting
    M109 S{material_print_temperature_layer_0} T0 ; heat to Cura Hotend
    ;*** End Preheating ***
    
    M117 Print Starting...
    M75 ; Start Print Timer and Engage Fil Sensor if USB Printing
    M84 E ; Disable E Motor for probe accuracy on direct drive systems
    M117 Antiblob retract...
    G92 E0 ; Reset Extruder distance to 0
    G1 E-2 ; Retracts filament to prevent blobs during probing
    G92 E0 ; Reset Extruder distance to 0
    M117 Homing All...
    G28 ; home all axes
    M117 Homing Z Probe...
    G28 Z ; home z again
    M117 Generating mesh...
    G29; auto bed leveling
    M117 Heaters Recovering...
    G4 S30; wait for heaters to recover
    M420 Z0; Z fade
    M900 K0; LA
    
    M117 Purging extruder...
    ;*** Draw a Nozzle Cleaning line on the Left Side of Bed
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
    
    M117 Printing.....

     

    And then this is the beginning of the g-code that is output by Cura:

     

    ;FLAVOR:Marlin
    ;TIME:9087
    ;Filament used: 7.62933m
    ;Layer height: 0.2
    ;MINX:79
    ;MINY:92.423
    ;MINZ:0.2
    ;MAXX:141
    ;MAXY:165.577
    ;MAXZ:33.8
    ;POSTPROCESSED
    ;Generated with Cura_SteamEngine 4.7.1
    M82 ;absolute extrusion mode
    ;*** Start Dual Nozzle/Bed Preheating ***
    M140 S60 ; start preheating the bed
    M104 S200 T0 ; start preheating hotend
    G28 ; home
    M190 S60 ; heat to Cura Bed setting
    M109 S200 T0 ; heat to Cura Hotend
    ;*** End Preheating ***
    
    M117 Print Starting...
    M75 ; Start Print Timer and Engage Fil Sensor if USB Printing
    M84 E ; Disable E Motor for probe accuracy on direct drive systems
    M117 Antiblob retract...
    G92 E0 ; Reset Extruder distance to 0
    G1 E-2 ; Retracts filament to prevent blobs during probing
    G92 E0 ; Reset Extruder distance to 0
    M117 Homing All...
    G28 ; home all axes
    M117 Homing Z Probe...
    G28 Z ; home z again
    M117 Generating mesh...
    G29; auto bed leveling
    M117 Heaters Recovering...
    G4 S30; wait for heaters to recover
    M420 Z0; Z fade
    M900 K0; LA
    
    M117 Purging extruder...
    ;*** Draw a Nozzle Cleaning line on the Left Side of Bed
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish
    
    M117 Printing.....
    G92 E0
    M117 Auto Home First...
    G28 ; Go to origin on all axes
    M117 Print Starting...
    M75 ; Start Print Timer and Engage Fil Sensor if USB Printing
    M84 E ; Disable E Motor for probe accuracy on direct drive systems
    M117 Antiblob retract...
    G92 E0 ; Reset Extruder distance to 0
    G1 E-2 ; Retracts filament to prevent blobs during probing
    G92 E0 ; Reset Extruder distance to 0
    M117 Homing All...
    G28 ; home all axes
    M117 Homing Z Probe...
    G28 Z ; home z again
    M117 Generating mesh...
    G29; auto bed leveling
    M117 Heaters Recovering...
    G4 S30; wait for heaters to recover
    M420 Z0; Z fade
    M900 K0; LA
    
    M117 Purging extruder...
    G92 E0     ; reset extruder
    G1 Z1.0 F3000    ; move z up little to prevent scratching of surface
    G1 X0.1 Y20 Z0.3 F5000.0  ; move to start-line position
    G1 X0.1 Y100.0 Z0.3 F500.0 E15  ; draw 1st line
    G1 X0.4 Y100.0 Z0.3 F5000.0  ; move to side a little
    G1 X0.4 Y20 Z0.3 F500.0 E30  ; draw 2nd line
    G92 E0     ; reset extruder
    G1 Z1.0 F3000    ; move z up little to prevent scratching of surface
    

     

    My print still came out fine but there is something definitely odd going on.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...