Jump to content
UltiMaker Community of 3D Printing Experts

Firmware 6.5.1 for S-line printers


SandervG
 Share

Recommended Posts

Posted · Firmware 6.5.1 for S-line printers

Hi everyone, we released a performance and stability update for the Ultimaker S-line printers and products; firmware 6.5.1.

In this firmware update you will find a few things. Among others: 

 

  • One at a time mode - We fixed the possibility of your print head colliding with a printed object when encountering an End of Filament while using one at a time mode.
  • Pause at height - When resuming a print that was paused automatically by the Pause at Height plugin, it was possible the extrusion was delayed. Resulting in a failed print. We fixed this. 
  • Display print result after reboot - After rebooting your 3D printer after a failed print (usually prompted by an error message), it was possible the display did not display the correct status. We implemented several changed to ensure that after a reboot, the screen will display the correct status like 'Finished', 'Aborted', or 'Failed'. 
  • ER65 false positives - ER65 is the flow sensor on the Ultimaker S5 Pro Bundle which sometimes gave a false positive due to a certain command in the code. We implemented a change to reduce the amount of false positives. 
  • Stuck in preparing - For some users, their printer could get stuck in 'Preparing to print' state. This is now fixed.
  • Digital Factory connection - We made further improvements to make a more stable connection between your printer and the Digital Factory. 

 

Official release notes can be found here

Download instructions can be found here by selecting your S-line printer

 

That was it, we hope you enjoy the new firmware!

 

  • Like 2
Link to post
Share on other sites

  • SandervG pinned this topic
  • 4 weeks later...
Posted (edited) · Firmware 6.5.1 for S-line printers

I updated, now have a failed print, saying excursion failed whilst in print! There should be an option to change spools manually if filamant is running low, the flow sensor did not detect filament was low and was forced to abort now i have height.sensor indifference error when trying 2nd print??

EDIT:-

I have tried the 2nd print and at the same time, to finished roughly I got same error..I am pretty sure this is an update firmware issue causing this, as the machine never did this b4..?

 

I am now scared to use the printer because 8 hrs into a print job i get these errors..

Edited by Navin2020
  • Link to post
    Share on other sites

    Posted (edited) · Firmware 6.5.1 for S-line printers
    On 8/30/2021 at 9:40 AM, Navin2020 said:

    There should be an option to change spools manually if filamant is running low

    You always been able to change filament mid print if the spool is getting low. 

     

    To do this:

    1. Press the printer icon on the touch screen.
    2. Press the button the filament you want to change.
    3. Press the "Change" button.
    4. The printer will than Pause the print for you and you can then change the spool as normal, when done the printer will then start to carry on printing.

     

    Also you can tune the print settings mid print also via the 3 dots button, where you can also pause the print if needed also.

    Edited by Carla_Birch
  • Link to post
    Share on other sites

    Posted · Firmware 6.5.1 for S-line printers

    @SandervG

     

    I keep getting an error with my printer: print head offset.

     

    Previously when I got this issue, it just asked if I wanted to re-try.

     

    After the firmware update:

    1. I get a failed message.

    2. The printer locks out while it cools down.

    3. It asks if part was removed (even through it did not extrude anything).

     

    Now it takes 20-30 minutes to clear this error.

     

    Can you change it back to the way it was previously implemented?

    Thanks,


    Tim

  • Link to post
    Share on other sites

    Posted · Firmware 6.5.1 for S-line printers

    Hi @Tim_Cochrane thank you for your message. Which printer do you run? Is the message referring to X/Y being offset or while probing during the active levelling? Did you perform a new calibration after getting the error message, and does it keep coming back?

     

    20 hours ago, Tim_Cochrane said:

    Can you change it back to the way it was previously implemented?

     

    Do you mean change this firmware? If there is a crucial bug that needs to be fixed we will look into it. Or do you mean that you want to revert back to the previous firmware version? Thanks,

  • Link to post
    Share on other sites

    Posted · Firmware 6.5.1 for S-line printers

    Hi Tim, thank you for your response. Before we would be able to make such a call we would need to review your log files and collect more data from other users. So at this point, that would be too soon to tell. I am also still not sure what exactly your issue was, some questions in my previous post are still unanswered that would help me understand. If you still need any help, it would be helpful if you could describe your issue more specifically and if it has happened once or every time you try to start a print. Thank you for your time, 

  • Link to post
    Share on other sites

    Posted (edited) · Firmware 6.5.1 for S-line printers
    On 8/31/2021 at 12:54 PM, Carla_Birch said:

    You always been able to change filament mid print if the spool is getting low. 

     

    To do this:

    1. Press the printer icon on the touch screen.
    2. Press the button the filament you want to change.
    3. Press the "Change" button.
    4. The printer will than Pause the print for you and you can then change the spool as normal, when done the printer will then start to carry on printing.

     

    Also you can tune the print settings mid print also via the 3 dots button, where you can also pause the print if needed also.

    I have a material station and the option to change filament is greyed out..not selectable

    Edited by Navin2020
    spelling
  • Link to post
    Share on other sites

    Posted · Firmware 6.5.1 for S-line printers

    Hi,

     

    My S5 pro keeps hanging at random points in the print process, sometimes it starts heating up and hangs there, sometimes it prints and hangs after removal, sometimes if I abort a job it hangs, sometimes it works flawlessly. It hangs more often than it works however. I have attached the logs.

    ultimakersystem-0030d623dde0.6.5.1.boot-1.log.zip

  • Link to post
    Share on other sites

    Posted · Firmware 6.5.1 for S-line printers

    I stopped using the printer because i scared of getting failed prints, it is costing me a fortune

  • Link to post
    Share on other sites

    Posted · Firmware 6.5.1 for S-line printers
    On 9/30/2021 at 6:47 PM, dboito said:

    Hi,

     

    My S5 pro keeps hanging at random points in the print process, sometimes it starts heating up and hangs there, sometimes it prints and hangs after removal, sometimes if I abort a job it hangs, sometimes it works flawlessly. It hangs more often than it works however. I have attached the logs.

    ultimakersystem-0030d623dde0.6.5.1.boot-1.log.zip 330.73 kB · 4 downloads

    I've had a look at your logs, and the material profile you use is not made for the "Material Station"

    You can see that the printer is missing several bit of information:

    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: 2021-09-30 16:08:14,642 ERROR    deprimeManager  Not all parameters present in material profile (3D4Makers Facilan C8 Generic).
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |{
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "break preparation temperature": "value to be replaced",
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "break preparation position": "value to be replaced",
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "break preparation speed": "value to be replaced",
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "break temperature": "value to be replaced",
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "break position": "value to be replaced",
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "break speed": "value to be replaced",
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "park_temperature": 125,
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "park_position": -120.0,
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "park_speed": 10.0,
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |    "maximum park duration": "value to be replaced"
    Sep 30 16:08:14 ultimakersystem-0030d623dde0 PrinterService[1261]: |}

    Unfortunately we initially only tested on the presence of a few values making the behavior rather random since the behavior depends on when it needs a missing value.

    While we have added a pop up error for this in 7.0.0, that release is taking a bit longer to finish then we'd like.

    I'm fairly confident that if you print with a more complete material profile, so try and replace your "3D4Makers Facilan C8 Generic" profile with a comparable Ultimaker or generic one or update that profile.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...