Jump to content

S5 and Buildtak magnetic build plate leveling problems


Recommended Posts

Posted · S5 and Buildtak magnetic build plate leveling problems

I’m having trouble trying to use the Buildtak flexplate system on the Ultimaker S5.


Google Photos album of this issue


I can no longer print as nozzle #2 is hitting the new build surface during the initial auto leveling with the Buildtak magnetic flexplate in place.


I applied the magnet to the new glass, I applied the PEI to the steel sheet, I inserted the glass/magnet sheet/steel sheet/PEI sheet assembly into the Ultimaker S5.


Firmware is up to date at 6.5.1


Using the Ultimaker S5 control panel I performed manual leveling following the instructions in the prompts. I set the 1mm gap using a tie wrap and the on screen buttons. I used the Ultimaker calibration card and the knobs on the bed to set a little friction when the system prompted me to do so.


I tried to print a PLA calibration cube and got this error: "Nozzle offset probe failed. Please check the nozzles and bed and try again."


Also the nozzle scratched my new surface:


There was a tiny amount of PVA hanging off nozzle 2 so I heated up nozzle 2 and cleaned it off with a brass brush.


I restarted the printer.


I followed online instructions to calibrate the nozzle switch position.


I checked the capacitive sensor wires and they look fine.


I tried to print the calibration cube again and got this error message: "Difference between detected height of both print cores exceeds realistic values."


And the 2nd nozzle scratched the plate again.


At this point I am not sure what to do. It seems the printer does not recognize the new print bed that is taller than before and the 2nd nozzle is hitting it; preventing auto bed leveling.


I put the original glass back in, re-leveled and now I am able to print again like before.


How can I calibrate the printer so that I can use the new bed flexplate?

  • Link to post
    Share on other sites

    Posted · S5 and Buildtak magnetic build plate leveling problems

    The log file on the S5 contains the exact measurements.  It has been about a year so I forget them at this moment but it's something like this (but my numbers may be wrong - this is my best memory):

    The right nozzle should be 1.5mm lower than the left when it's down.  If this value (the difference between the 2 nozzle heights) is not exactly 1.5mm it's okay but must be within +/- 0.5mm.


    1) I would just disable active leveling.  More on this later in next post.


    2) I would look at these numbers to see if it's off by a tiny tiny bit (say 0.1mm) and in which direction.  It could be your nozzles are 0.45mm different in height and you are triggering this error somewhat randomly.  Or it could be that the flex plate is somehow causing a huge difference (say 5mm instead 1.5mm).  Seeing the value in the log file can be helpful.  This value is stored for many many print hours (days) so even a few days later you should be able to get this out of the log files on the printer.


    3) One thing (only one) you need to understand about active leveling is that it measures the capacitance between the metal plate in the bottom of the print head and the metal plate under the glass.  The farther this distance is, the less accurate active leveling gets.  Adding a second metal plate between these two can affect the capacitance also.  Not sure if this matters.  Watching the active leveling process is revealing.  It should move the bed up slowly and stop just after the nozzle touches (the process likes to go beyond touching a bit and that way it can more accurately find the moment things touched (capacitance stopped changing).  If you've watched it many times you can see when there is a failure (caused by example by a loose wire or electromagnetic noise): it will either stop moving down long before it touches the bed or long after it has started touching the bed.


    4) Active leveling is performed with the nozzles hot because otherwise some bit of hard plastic on the tip of the nozzle will confuse it.  This means you should really be using it only on a surface that can handle 250C and many cant.




  • Link to post
    Share on other sites

    Posted · S5 and Buildtak magnetic build plate leveling problems

    Disabling Active leveling  (auto leveling)


    Okay - if you screw this up you can "brick" your machine and have to restore it using the uSD process (or using an olimex serial F cable) so make sure you have purchased a uSD card preferably 4GB but up to 32GB should work (no larger - unconfirmed rumors say no larger than 32GB).  But it sounds like you are the type of person who can handle the disabling of active levelling.  Also note every time you upgrade the firmware you will have to do this again to disable active leveling:


    Quick answer:


    Edit the file alignZAxisProcedure.py
    In line 49 there is the magic:
    self.__probing_mode = ProbeMode.DETAILED
    Changed to:
    self.__probing_mode = ProbeMode.NEVER
    #self.__probing_mode = ProbeMode.DETAILED



    But to edit that file you have to telnet into the machine. 


    First put your S5 into developer mode - it's in the menus on the printer. Your machine needs to be on your network (wifi or ethernet) if it isn't already. Once it's on the network it will show the IP address at the top of the main screen.
    Next you need ssh which is built into linux and Macintosh terminal but not windows. For windows I recommend putty:

    In putty you don't type the "ssh" part but just put the ultimaker@111.222.333.444 part and click "open".

    ssh ultimaker@ (don't enter - enter the ip address listed on your UM3)


    use "cd" command to get to the right folder (mentioned above).  If you aren't familiar with cd you really should not be doing this as you can brick your printer.


    I forget which editor the printer has but I think it has the nano editor:

    cd /usr/share/griffin/griffin/printer/procedures/pre_and_post_print/auto_bed_level_adjust
    nano alignZAxisProcedure.py


    After editing, do CTRL+x   to exit the editor and save.  Follow the directions (Y to save or N to cancel then just hit return to accept the accepted file name).


    Check your edits using "more" or "less" command.  Hopefully you know how to use those.  If not google one of them (how to use "more" in linux).


    Restart your printer - you can do that from command prompt:


    shutdown -r now


    Or just power it off and on again which is slightly more jarring for the printer but hey we do it every day, right?

  • Link to post
    Share on other sites

    Posted · S5 and Buildtak magnetic build plate leveling problems

    gr5 - thank you for writing back to me. 


    I think I have solved the problem. 


    When I got the Buildtak flexplate system it says on the instruction card "Attach FlexPlate to magnetic mounting base. Re-level your printbed and ensure that the nozzle height is properly set."


    That all seemed logical enough to me since I just added approximately 3 mm in height to the glass. 


    So I ran the manual leveling program on the printer. This required me to push on screen buttons to change the bed height and also turn the 3 screws under the bed to further adjust the bed level.


    After manually leveling the bed I tried to print a calibration cube and that is when I ran into problems. 


    I decided to remove the Flexplate system from the printer and replace it with just the original glass the printer came with. Then I re-did the manual leveling and was able to print again on bare glass.


    It was suggested by Matterhackers that I just try the Flexplate system again WITHOUT manually releveling the bed. I tried it and it worked! 


    Upon further inspection of the Buildtak Flexplate instruction card there are further notes that say "If your printer has an auto-leveling function and your probe is a pressure sensor, level as you normally would with the BuildTak sheet installed."


    In other words it seems I didn't need to do anything special to get it to work. I just needed to put the new build plate in there and the machine would figure it out.


    I have run a few prints on the Buildtak PEI surface and it seems to work just like my Prusa smooth sheet. The print finishes and you just pop the spring steel/PEI sheet off it's magnets and flex the part off. Print quality and leveling seem to be working normally.

    • Like 1
    Link to post
    Share on other sites

    Posted (edited) · S5 and Buildtak magnetic build plate leveling problems

    I bought the buildtak flexplate  system  for the s5. but I"m pretty confused. The parts I received do not look like BuildTak's instructions.


    I got the black magnetic sheet that has the logo on it and the pull tab. 

    and a pale yellow colored pei sheet and two bare metal plates. 


    Are the metal plates what BuildTak calls FlexPlates?


    Is the proper installation order the following?

       1. remove glass bed

       2. stick the magnetic with adhesive right on the metal bed of the S5

       3. carefully peel and stick the pei sheet to the metal sheet (flexplate)

       4. place the stickered metal sheet onto the magnetic black base that is stuck on the bed


    I want to be sure before I ruin something

    Edited by kayakbabe
  • Link to post
    Share on other sites

    Posted · S5 and Buildtak magnetic build plate leveling problems

    or do I put the magnetic with adhesive on another glass bed. so i can switch it out? I have a second one. 

    But I'm afraid it will be too thick with all that stuff on top of it.


  • Link to post
    Share on other sites

    Posted · S5 and Buildtak magnetic build plate leveling problems

    I know this is an older post... But in case someone find this thread with the same question I had.


    I put the magnetic adhesive side on a glass bed (I dedicated a glass bed for this purpose). 

    I use the metal flex plate with whatever film you want on it. The films will last quite a while especially if you move the objects you are printing to different areas to maximize the use of the film (I do not print every part in the very center).

    You do NOT have to do anything as the S5 autoleveling will just work even though the glass plate + magnetic base + metal flexplate +film are thicker than the Ultimaker glass bed.


    So far I have used the BuildTak system and it works and also the WhamBam. Both just work, no adjustments to any kind of configs or anything.


    And I REALLY like using the flexible plates. It makes life so much easier that I bought a second flex plate. I can print faster now that I can quickly take one out and let it cool while the next object is printing (objects pop off much better when they have cooled down).


    Did I mention I REALLY LIKE using the flexible plate!


    • Like 1
    Link to post
    Share on other sites

    Posted · S5 and Buildtak magnetic build plate leveling problems

    For what its worth,  I have an Ultimaker 3 and the BuildTak system.   I found that the auto levelling simply did not work and I disabled it and just do manual levelling


    For ASA that needs a very hot bed, I found the BuildTak black surface did not survive so I now use PEI on the removable metal plate



  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...