Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker 3 Bricked?


Warbowhunter
 Share

Recommended Posts

Posted · Ultimaker 3 Bricked?

3 weeks ago I installed a new firmware update on my Ultimaker 3. 

I recently did a long print of 9 hours that I left overnight. Print had some trouble on the final layer with extrusion (did some grinding) but nothing too weird. Removed the print like normal and turned the printer off. Now I try to turn on the printer and it does nothing. Checked the cable and power but these all work (the fan turns on and gets power) but no lights/display is not working. Attached the printer to a monitor (removed the bottom part so I can access the board) and it only shows a linux pinguin with "U-boot 2016.05-ultimaker-some number and a date from 2018". I found some threats here on using SD cards for a recovery.img but most recovery.img links are broken. And those issues were during failed firmware updates, but it printed fine for weeks. So any idea what it might be??

 

 

  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Bricked?

    Did you check if this one worked:


    If not; it's best to contact your reseller directly, they can help you with the latest version of the recovery image (or find out if something else went wrong!)

    • Like 2
    Link to post
    Share on other sites

    Posted (edited) · Ultimaker 3 Bricked?
    On 9/27/2021 at 11:59 AM, nallath said:

    Did you check if this one worked:


    If not; it's best to contact your reseller directly, they can help you with the latest version of the recovery image (or find out if something else went wrong!)

    Yes I contacted Makerpoint (my reseller) and got a recovery.img and followed their instructions (same instructions as in the thread). It showed the ultimaker logo and then it started installing new firmware. But it is stuck on the installing firmware 2 minutes left. I cut the power after 45 minutes and tried again, then with another SD card but still goes straight to the 2 minutes left installing screen without any progress. 

     

    In the instructions is also something on the LED's. But my ultimaker has LED Q and R on. and T off. But T should be slowly blinking or when it is finished Q should be blinking. So that might be a clue to what component is not working? 

     

    edit: also many thanks for the help! 

    Edited by Warbowhunter
  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Bricked?

    I would try it one more time (power it up again with the uSD card in there) however there may be errors on your flash drive.  I recommend reading this detailed article I wrote about how to figure out why it isn't booting and how to repartition your flash drive to avoid the "bad spots".  This has worked for quite a few people and I have updated this document dozens of times from feedback from various people.

     

    http://gr5.org/unbricking

    • Like 2
    Link to post
    Share on other sites

    Posted (edited) · Ultimaker 3 Bricked?
    On 9/28/2021 at 6:23 PM, gr5 said:

    I would try it one more time (power it up again with the uSD card in there) however there may be errors on your flash drive.  I recommend reading this detailed article I wrote about how to figure out why it isn't booting and how to repartition your flash drive to avoid the "bad spots".  This has worked for quite a few people and I have updated this document dozens of times from feedback from various people.

     

    http://gr5.org/unbricking

    Thank you! I used a 16gb SD card so I ordered a 4gb class 10 card just to be sure. I also ordered a Serial F cable from olimex. 

     

    The images that are fixed under problem #1 only work for an S5 and not for an 3 correct?

     

    If I get the cable and software working then read what it says and hope I then understand what the issue is? 

     

    To be honest I have used raspberry pi's and arduino's but most of this goes over my head. 

     

     

    Edited by Warbowhunter
    Changed S3 to 3
  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Bricked?
    28 minutes ago, Smithy said:

    Be careful, Ultimaker 3 and Ultimaker S3 are different printers. 

    Your profile says you have an UM3, so this would be the recovery image https://software.ultimaker.com/releases/firmware/9066/stable/5.3.0.20211003/um-restore-5.3.0.20211003.img

     

    Yes, mistyped that on my recent comment. Thank you! That is a different image then the one makerpoint sent me. That was a 5.2 while this is a 5.3. Will give this a try.

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker 3 Bricked?
    On 9/28/2021 at 6:23 PM, gr5 said:

    I would try it one more time (power it up again with the uSD card in there) however there may be errors on your flash drive.  I recommend reading this detailed article I wrote about how to figure out why it isn't booting and how to repartition your flash drive to avoid the "bad spots".  This has worked for quite a few people and I have updated this document dozens of times from feedback from various people.

     

    http://gr5.org/unbricking

    Where does the cable go on a ultimaker 3? It has the double red boards and not the white one like in the pictures (which I assume is a s5). I can't actually find the 3 pins on the board? Or is it the white board on the other side?

     

    Edit: found it and the cables works. It looks like it is issue 2 with mounting errors. Very excited to see if we can fix it. Thanks a lot!!!

    Edited by Warbowhunter
  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Bricked?

    I'm glad you are making progress.  Sorry I didn't check for replies until just now.  For a UM3 things will be slightly different (by the way maybe send me a photo of how you hooked up the serial cable and I'll add that).

     

    UM3 needs different disk image than S5, yes.  I'll add smithy's link to the instructions.

    UM3 doesn't have dangerous voltages (fortunately). 

    UM3 does use the same Olimex board (but with a number switched in the eeprom - instructions near the end of the unbricking page).

    UM3 partitions may be differently sized although I doubt it.  Anyway check to see partition sizes before creating new ones and write down the old values.  You can always make the partitions bigger (well the user partition will have to shrink but it's much bigger than necessary anyway).

  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Bricked?
    On 10/6/2021 at 5:17 PM, gr5 said:

    I'm glad you are making progress.  Sorry I didn't check for replies until just now.  For a UM3 things will be slightly different (by the way maybe send me a photo of how you hooked up the serial cable and I'll add that).

     

    UM3 needs different disk image than S5, yes.  I'll add smithy's link to the instructions.

    UM3 doesn't have dangerous voltages (fortunately). 

    UM3 does use the same Olimex board (but with a number switched in the eeprom - instructions near the end of the unbricking page).

    UM3 partitions may be differently sized although I doubt it.  Anyway check to see partition sizes before creating new ones and write down the old values.  You can always make the partitions bigger (well the user partition will have to shrink but it's much bigger than necessary anyway).

    For the sake of this thread an update.

     

    The guide by gr5 worked. I had to repartition and reflash, after that the recovery SD worked. 

    UM3 Partition sizes were exactly the same as in the guide. I used the eMMC version (the zip file, not the 7z) which worked and booted fine (maybe I have the eMMC version or the eMMC version work also for NAND? No clue, it worked).

    The front board made an annoying beeping sound while running jessie, so I disconnected that. Watch a tutorial on how to replace the display and unplug the same cable to get rid of that while repartitioning (it gets really annoying) 

     

    Other then that it worked amazing and was a really doable procedure. 

     

    Many thanks to gr5 and everyone here on the forum, you are amazing.

     

     

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 12 replies
    ×
    ×
    • Create New...