Jump to content
Ultimaker Community of 3D Printing Experts

cura fills in open objects!


conradshawcross
 Share

Recommended Posts

Posted · cura fills in open objects!

Hi there everyone,

I'm getting a repeated problem with cura filling in some pipe shaped objects that I'm printing.

It starts off perfectly then at some point its starts to make a spiders web type surface across the face of the pipe (which is oriented along the z axis, pointing up)

I can see these layers in the layer view of cura but can't see how to stop it from creating them, I'm having to cut the layers out by hand but this is not ideal.

Has anyone seen this error before, is there a work around or a way to fix it in the expert settings?

I've tried to attach some pics but not sure how to, does this forum not support pictures?.

Thanks

 

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    You can add pics to your gallery, and then reference them in your posts using the 'My media' button in the formatting bar. However you may need to get through the 5 post initial minimum before you can do that.

    I think this is a bug in Cura, perhaps related to the 'combine everything (type A)' setting. Check in Cura's expert settings to make sure that is off. Also, make sure you have the latest version of Cura.

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    I've seen this a few times. Uncheck everything in "fix horrible" settings in expert settings. Daid is aware of the problem and recently changed the code but I don't know if he released that fix yet.

     

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    Go into full settings. Don't use the Quickprint modes, they will only hinder you in the long run.

    Again it's probably the fix horrible settings combined with the fact that your model is probably not properly formed. You do have complete control over what gets filled in - the inside of your model gets filled, the outside doesn't (apart from the odd layer that you saw, which is a known bug). The problem comes if your STL file isn't properly closed or contains intersecting surfaces - then Cura (or any slicer) has to guess what counts as the inside.

    Note that the 'expert settings' where the 'fix horrible' settings live is a separate control panel (accessed under the expert menu) and is distinct from being in 'full settings' mode.

    Perhaps you could post some example STL files and gcodes for us to better see what is going on?

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    Thanks illuminarti,

    I guess I'm going to have to get better acquainted with the expert settings. What looked like infill doesn't appear on the print so maybe I'm just miss-reading the layers colouring system also my computer gets super slow when I try to scroll through the layers which doesn't help. I'm pretty sure the .stl is sound as I've checked it in rhino for dodgy surfaces etc. and it looks good. I'm afraid I can't post the files the moment but I'll try and get into the expert settings instead!

    Again, thanks for your help!

    david

     

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    I'm pretty sure the .stl is sound

     

    You can check in cura "xray view". Any red areas are places where you have internal walls that will mess up Cura. Cura doesn't show "holes" in your walls though so xray view won't show you everything but it's still helpful.

     

    also my computer gets super slow when I try to scroll through the layers

     

    Usually it's super slow while it loads the layers into some kind of 3d viewing thing and you can see the number at the top of the scroll bar increase occasionally but at some point it should suddenly stop being slow. Consider walking away for a minute and coming back and see if it's now very fast.

     

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    I'm having the same issue Cura 4.10 and it is happening with all my "tubular" files... this is a Mando helmet that I paid for. multiple people before me have printed it without issue and the creator assures me the file is not corrupt. So I tried another file with the same result. I looked in "expert settings" and can't find "fix horrible?' please help 

    20210822_131918.jpg

    20210822_131933.jpg

    20210822_131946.jpg

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    Hi @34Jimmy34

     

    Welcome in here.

     

    Looks like top and (bottom?) layers is selected, try to deselect bottom first, if selected.

    If this does not help also deselect top layer and use preview mode for inspection.

    Cura may assume there is a "high" floor inside your helmet by some reason.

    In such object, the top often has a wider distance between outside-inside of the helmet.

     

    But it will be easier if you save your project file and paste it in here so someone can have a look at it.

     

    Thanks

    Torgeir

     

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    I am having this same problem. The only thing I have changed in this profile over the last couple days was disabling z-hop when retracted. Additionally prior to finding this issue I was running a retract tower with extensions>post processing>modify Gcode>RetractTower script from Calibration Shapes from the market I have removed the script before running into this issue. I have attached some photos of a benchy where the slicer is filling in the Chimney, Deck Box and Deck. 

     

    From the printed models the red one is one printed with this G-code the green one was a prior model. g-code for the one with the fill issue included.

    benchy pre slice.PNG

    benchy filled.PNG

    inside benchy box.PNG

    weird benchy.PNG

    PXL_20210823_142837105.jpg

    CE5_3DBenchy_filled in floors.gcode

  • Link to post
    Share on other sites

    Posted · cura fills in open objects!
    1 hour ago, HOTTPISS said:

     The only thing I have changed in this profile over the last couple days was disabling z-hop when retracted.

     

    AND Remove All Holes, check this parameter.

     

    image.thumb.png.62168f833a0add680ffa412a2e50d4bf.png

    • Thanks 1
    Link to post
    Share on other sites

    Posted (edited) · cura fills in open objects!

    @CuqThank you, That worked. I don't remember ever touching or seeing that option before. The Mesh Fixes drop down on my quick menu wasn't even active.

     

    Thank you.

    Edited by HOTTPISS
  • Link to post
    Share on other sites

    Posted · cura fills in open objects!

    unchecking remove all holes, worked for me, THANKS!!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...