Jump to content

Cura spaces 0.6 nozzle lines too far apart


Mlogue9

Recommended Posts

Posted · Cura spaces 0.6 nozzle lines too far apart

I'm using Cura 4.13.1 and I only get this issue with a 0.6 nozzle. I frequently do not use a 0.4mm nozzle.

 

I am using octoprint and an ender 3 with a btt mini e3 board. The prints have a lattice-work look to them even after 6 or so layers you can see through them. I use a 0.5mm nozzle and the prints turn out fine. Haven't had issues with the 0.8mm nozzles either. The problem is worse with certain filaments, not well mitigated by jacking up the flow % to over 200% or dropping the nozzle 50um. 

  • Link to post
    Share on other sites

    Posted · Cura spaces 0.6 nozzle lines too far apart

    Use the File/Save Project command and post the 3mf file here.

    When I slice with a .6 everything looks good.  I was using .3 layer height, .6 line width, 100% Initial Layer Line Width, and all flows at 100%.  There are a couple of other settings that affect the E numbers (amount of overlap, wipe distance, etc.) but the ones I adjusted are the main ones.

     

  • Link to post
    Share on other sites

    • 9 months later...
    Posted · Cura spaces 0.6 nozzle lines too far apart

    I am having the same problem with Cura 5.2.1, an Ultimaker 2+, and the Ultimaker-supplied 0.6mm nozzle.

     

    Layer adhesion seems fine, but the line width is clearly too narrow – I get the same kind of waffle effect described above.

     

    I do seem to be able to mitigate it by cranking up the flow rate in Cura (> 150%), but I feel like that's going to cause other problems (?), and without knowing what's going on, I don't know exactly what the nominal value should be.

     

    Looking at the G code, lines are correctly spaced (0.55mm apart) in both the top and bottom skins.

     

    image.thumb.jpeg.2933da2f99c16c5a2d0c26f4b08a4471.jpeg

     

    hgs.3mf

  • Link to post
    Share on other sites

    Posted · Cura spaces 0.6 nozzle lines too far apart

    That's very bad underextrusion.  It can have many possible causes.  Is your line width set to 0.6?  I have to go now but I'll look at your 3mf file later.

  • Link to post
    Share on other sites

    Posted · Cura spaces 0.6 nozzle lines too far apart

    So you are printing a bit fast.  0.28mm layer height 0.55mm line width and printing speeds at 30,40,55 mm/sec.  If you mulitply the speed by the other two you get 4.6mm^3/sec for the 30mm/sec and 8.5mm^3/sec for the faster speeds.

     

    I mean a UM2+ should be able to do that.  Not a UM2.  That's too fast for a UM2.  And your temp is pretty good.

     

    Are you absolutely certain you have a 0.6mm nozzle on there and not a 0.4mm nozzle?  If it's a 0.4mm nozzle that would explain everything perfectly.

     

    That "top" (not really the top but the topmost flat area) layer is about 50% underextruded.  And is printed at 30mm/sec.

     

    I mean the quick fix, since it is underextruding by about 50%, is to print at about half speed.  I mean change *only* layer height from 0.28mm to 0.14mm will drop the volume in half.  It will give you a nicer looking print as well.  But will take twice as long to print (twice as many layers.

     

    I would do some cold pulls on the nozzle.  Google "atomic pull" or "cold pull" and read about it or watch one of many many videos explaining it.  That will clean out the tip of the nozzle in case you have some caramelized grunge on the inside surface of the nozzle.

     

    You could also test the feeder.  Go into the MOVE command and back the filament out so you see it in the bowden.  Then move it forward and fight it with your other hand just below the feeder.  You should be able to barely get the feeder to skip backwards at your full strength.  About 10 pounds or 5kg force should be required before the feeder skips where the only resistance is you (filament not in the print head but merely in the bowden).  You can grip a weigth in one hand against the filament to use the weight as the pull amount.  Or you can lift a weight and then in your mind apply a similar force.

     

    Finally if the feeder seems fine and the nozzle seems fine the next most likely thing is the teflon part.  Have you change the teflon part lately?  It needs to be switched out every 500 hours of printing or so.  It's a "consumable" just like filament (but much cheaper).

     

    One more thing - never print with flow > 110%.  You risk grinding the filament to dust and you don't get any extra extrusion after around 110 or 120%.  In fact if it's underextruding as bad as you showed us, you might even be better at 90% as you won't grind the filament as much.

     

    Here is the complete list of things that can cause underextrusion on the UM2 (or UM2+):

     

    CAUSES FOR UNDEREXTRUSION UM2 AND HOW TO TEST FOR THEM AND REMEDY THEM

    One can quickly check the feeder (it takes seconds) so I would always do that first.  The feeder on UM2+ and UM2 can push with 10 pounds (5kg) force easily so first thing is to lift that lever (if um2+, if um2 regular do move material) and insert filament so it is only part way into the bowden (e.g. half way).  Then move the filament with "move material" command in menu so the feeder is energized and then pull down on the filament under the feeder.  You should be able to pull with 5 to 10 pounds force without it slipping.  Then have it move the material up while you pull down.  5 pounds force (2kg) is enough to make decent prints at moderate speeds listed below but you need 10 pounds (5kg) to print fast (e.g. 0.2mm layers and 60mm/sec)

    As far as underextrusion causes - there's just so damn many.  none of the issues seem to cause more than 20% of problems so you need to know the top 5 issues to cover 75% of the possibilities and 1/4 people still won't have the right issue.  Some of the top issues:
    1) Print slower and hotter!  Here are top recommended speeds for .2mm layers (twice as fast for .1mm layers) and .4mm nozzle:
    20mm/sec at 200C
    30mm/sec at 210C
    40mm/sec at 225C
    50mm/sec at 240C
    The printer can do double these speeds but with huge difficulty and usually with a loss in part quality due to underextrusion.  Different colors print best at quite different temperatures and due to imperfect temp sensors, some printers print 10C cool so use these values as an initial starting guideline and if you are still underextruding try raising the temp.  But don't go over 240C with PLA.

    2) Shell width confusion.  Shell width must be a multiple of nozzle size (in cura 15.X.  In cura 2.X it doesn't matter as much but still makes a difference).  For example if nozzle size is .4mm and shell width is 1mm cura will make the printer do 2 passes with .5mm line width which is possible but requires you to slow down much more to make a .5mm line out of a .4mm nozzle.  If you really want this then set nozzle size to .5mm so it's clear what you are asking Cura to do for you.

    3) Isolator - this is most common if you've printed extra hot (>240C) for a few hours or regular temps (220C) for 500 hours.  It gets soft and compresses the filament under pressure.  It's the white part touching the heater block.  It's very hard to test when not under full pressure (spring and bowden) so sometimes it's best to just replace it.  Also if you notice parts of it are very soft (the blacker end where it touches higher heat) then it's too old and needs replacing.

    4) Curved filament at end of spool - if you are past half way on spool, try a fresh spool as a test.

    5) curved angle feeding into feeder - put the filament on the floor -makes a MASSIVE difference.

    6) UM2 only: Head too tight?  Bizarrely MANY people loosen the 4 screws on the head by just a bit maybe 1/2 mm and suddenly they can print just fine!  Has to do with pressure on the white teflon isolator.
    6b) UM2 only: Bowden pushing too hard - for the same reason you don't want the bowden pushing too hard on the isolator.
    6c) Um2 only: Spring pushing too hard.  Although you want a gap you want as small as possible a gap between teflon isolator and steel isolator nut such that the spring is compressed as little as possible.

    7) clogged nozzle - the number one problem of course - even if it seems clear.  There can be build up on the inside of the nozzle that only burning with a flame can turn to ash and remove.  Sometimes a grain of sand gets in there but that's more obvious (it just won't print).  Atomic method (cold pull) helps but occasionally you need to remove the entire heater block/nozzle assembly and use flame.  I found soaking with acetone does not help with caramelized pla. Even overnight.  Maybe it works on ABS though. Simpler cold pull: https://www.youtube.com/watch?v=u07m3HTNyEg

    😎 Temp Sensor bad - even the good ones vary by +/- 5C and bad ones can be any amount off - they usually read high and a working sensor can (rarely) fail high slowly over time.  Meaning the sensor thinks you are at 220C but actually you are at 170C.  At 170C the plastic is so viscous it can barely get out of the nozzle.  You can verify your temp sensor using this simple video at youtube - on you tube search for this: mrZbX-SfftU

    9) feeder spring issues - too tight, too loose.  On the black UM2 feeder you want the tension such that you can clearly see the diamond pattern biting into the filament.  You want to see at least 2 columns of diamonds.  4 columns is too much.  On the white UM2 plus and UM3 feeders you usually want the tension set in the center.

    10) Other feeder issues, one of the nuts holding UM2 and UM3 together often interferes with the feeder motor tilting it enough so that it still works but not very well.  Other things that tilt the feeder motor, sleeve misaligned so it doesn't get a good grip.  Gunk clogging the mechanism in there.

    11) Filament diameter too big - 3mm is too much.  3mm filament is usually 2.85mm nominal or sometimes 2.9mm +/- .05.  But some manufacturers (especially in china) make true 3.0mm filament with a tolerance of .1mm which is useless in an Ultimaker.  It will print for a few meters and then clog so tight in the bowden you will have to remove the bowden from both ends to get the filament out.  Throw that filament in the trash!  It will save you weeks of pain

    11b) Something wedged in with the filament.  I was setting up 5 printers at once and ran filament change on all of them.  One was slowly moving the filament through the tube and was almost to the head when I pushed the button and it sped up and ground the filament badly.  I didn't think it was a problem and went ahead and printed something but there was a ground up spot followed by a flap of filament that  got jammed in the bowden tube.  Having the "plus" upgrade or using the IRobertI feeder helps you feel this with your hand by sliding the filament through the bowden a bit to see if it is stuck.

    12) Hot weather.  If air is above 30C or even possibly 25C, the air temperature combined with the extruder temperature can soften the filament inside the feeder such that it is getting squeezed flat as it passes through the feeder - this is obvious as you can see the problem in the bowden.  The fix is to add a desk fan blowing on the back of the printer.  Not an issue on the UM3 or UM2 "plus" series.

    13) Crimped bowden.  At least one person had an issue where the bowden was crimped a bit too much at the feeder end although the printer worked fine when new it eventually got worse and had underextrusion on random layers.  it's easy to pull the bowden out of the feeder end and examine it.

    14) Worn Bowden.  After a lot of printing (or a little printing with abrasive filaments) the bowden resistance can be significant. It's easy to test by removing it completely from the machine and inserting some filament through it while one person holds it in the U shape.  Preferably i nsert filament that has the pattern from the feeder.

    15) Small nozzle.  Rumor has it some of the .4mm nozzles are closer to .35mm.  Not sure if this is actually true.  I'm a bit skeptical but try a .6mm nozzle maybe.

    16) CF filament.  The knurled sleeve in the extruder can get ground down smooth - particularly from carbon fill.  4 spools of CF will destroy not just nozzles but the knurled sleeve also.  Look at it visually where the filament touches the "pyramids".  Make sure the pyramids are sharp.

    17) Hot feeder driver.  I've seen a more recent problem in the forums (>=2015) where people's stepper drivers get too hot - this is mostly a problem with the Z axis but also with the feeder.  The high temps means the driver appears to shut down for a well under a second - maybe there is a temp sensor built into the driver chip?  The solution from Ultimaker is that they lowered all the currents to their stepper drivers in the newer firmware.  Another solution is to remove the cover and use desk fan to get a tiny bit of air movement under there.  TinkerMarlin lets you set the currents from the menu system or you can send a gcode  to lower the current.  Ultimaker lowered the default currents in July of 2015 from 1300ma to 1200ma for X,Y,Z but left extruder at 1250. Other people (I think the support team of a major reseller but I forget) recommend X,Y,Z go down to 1000mA.

    M907 E1250

    Above sets the extruder max current to the default - 1250mA.  So try 900mA.  This will only change until next power cycle so if you like your new value and want to save it use M500.  You can just put these into an otherwise empty gcode file and "print" this and it will change.  Or get tinkergnome marlin!  You will wonder how you lived without it: https://github.com/TinkerGnome/Ultimaker2Marlin/releases

    M907 E900
    M500

    18) third fan broken.  This tends to cause complete non-extrusion part way through a print.  In the rear of the head for UM2 and the front of the head for UM3.  Without this fan several things can go wrong.  It can take a while as usually you also need several retractions to carry the heat upwards.  There are a few failure mechanisms and I don't understand them all.  One of them is probably that the molten PLA spreads out above the teflon and sticks to the metal in a core or fills the gap at the base of the bowden in UM2.  Later it cools enough to keep the filament from moving up or down.

    19) Spiralize/vase mode.  This is a rarely used feature of Cura but you might have left it on by accident?  In this mode the wall of your part is printed in a single pass.  So if you have a .4mm nozzle and the wall is .8mm thick it will try to over extrude by 2X.  This is difficult to do and may instead lead to underextrusion.

    20) non-standard or bent fan shroud.  Sometimes people print some fan shroud off of thingiverse or youmagine out of PLA or ABS.  Some of these are great but most of them are crap.  One needs to do good air flow modeling.  Also if it's PLA it will slump and direct air differently.  Air directed at the block or nozzle can cause severe underextrusion and also sometimes HEATER ERROR.  Put the original shroud back on or just turn off the fan to prove that the fan is the problem.

    21) Firmware settings - for example UM2+ firmware on UM2 or vice versa will cause 2X over extrusion or 2X underextrusion.  Downgrading or changing firmware can mess up steps/mm and other settings - so if you updated firmware and then problems started then do a "reset to factory settigns" which corrects all the steps/mm values.

    22) too many retractions (this causes complete failure) - if you have too many retractions on the same piece of filament you can grind it to dust.  10 is usually safe.  20 is in the danger zone.  50 should guarantee failure.  You can tell cura to limit retractions to 10 per a given spot of filament.  Do this by setting "maximum retration count" to 10 and "minimum extrusion distance" to your retraction distance (4.5mm for UM2 and 6.5 for UM3 and 8mm for S5).

    23) Brittle filament.  Espciallty with older PLA but even brand new pla can do this.  If you unspool some (for example if it's in the bowden) for many hours (e.g. 10 hours) it can get extremely brittle and it can snap off into multiple pieces in the bowden.  It's not obvious if you don't look for this.  Then it starts printing just fine and at some point one of those pieces reaches the print head and gets hung up somewhere and the printer suddenly stops extruding for now apparent reason.  This usually happens within the first meter of filament - once you get to printing the filament that was recently on the spool it should be fine from then on.

    24) The "plus" feeder can have an issue where the filament doesn't sit properly for one print and it permanently damages the arm inside the feeder as shown by this photo - the hole is ground down asymetrically: http://gr5.org/plus_feeder_issue.jpg

    25) Other feeder issues.  You can test the feeder by putting the filament only part way down the bowden and with the feeder electrically turned on (or moving) pull very hard on the filament until it slips.  You should be able to pull with about 5kg or 10 pounds of force before it slips.  4kg is acceptable.  2kg is a problem.  If the stepper motor isn't engaged you can try going into the move menu.  After a minute or so power is removed again from the feeder stepper.
     

  • Link to post
    Share on other sites

    Posted · Cura spaces 0.6 nozzle lines too far apart

    Thanks for the extensive reply!

     

    It is a 0.6mm nozzle, yes – it's the one supplied with the printer, and had never been used.  In fact I thought it might have some kind of debris from the factory, so an "atomic pull" was the first thing I tried.  The filament came out with the same shape as usual, but it didn't help.

     

    I also tried a known-good spool of a different PLA material, with the same outcome.

     

    The feeder is definitely pulling hard enough, and I opened it up to make sure it's not worn or full of debris.  All the fans are running, and the Bowden tube is in OK-ish condition.

     

     

    Printing at half speed mostly fixes the problem, but makes the 0.6mm nozzle pointless.  225% flow rate works even better, and the filament isn't noticeably chewed afterwards, but that doesn't fill me with confidence.

     

    It's confusing either way.  Why would Ultimaker put a 0.6mm (and 0.8mm!) nozzle in the box, if the printer can't use it and their default settings are wrong anyway?  Obviously something is not working the way it's supposed to.

     

    I don't mind ordering a new isolator, as that's probably overdue, but I'm skeptical that will magically fix the problem.  Right now I'm thinking the answer is to switch back to 0.4mm...

  • Link to post
    Share on other sites

    Posted · Cura spaces 0.6 nozzle lines too far apart

    The 0.6 can definitely print double the flow and the 0.8 4X the total flow (not speed - flow - so thicker layers and thicker lines are the typical way to get there) and yes your printer should be fine at the speeds you had in your 3mf file that you posted above.  I'm just trying to get a handle on things.

     

    I'd replace the teflon part next.

     

    There is a test you can do and it might teach you something important but it may still "pass" even though you need a new teflon part.  Here's the test:

     

    Do a cold pull possibly before you start to get the hot end cleaned out.

     

    Remove the filament and separate bowden from test head.  Remove the nozzle.  Let things cool to below 50C in the hot end.  now cut some filament off the spool and pass it through the print head, feeling the resistance.  Sometimes this can be enlightening.  I think it's mentioned in the list above but one person realized that if they loosened the 4 long screwd through the head just a half turn suddenly the friction dropped by a pound or two.

     

    Sometimes when you have it like this with the teflon compressed, you can feel the high resistance of the filament through the teflon and know that it's time to change the teflon.

     

    The failure mode is that the teflon - after being above 200C for 500-1000 hours gets quite soft like rubber.  But only the part of the teflon that is touching the heater block so only the bottom 1mm or so.  With no pressure it works fine but when you push down on it from above (from the hot end mechanics and/or the bowden can push pretty hard as well) that soft teflon compresses inward and squeezes the filament.  Hard.  See 6a, 6b, 6c above.

     

    There's certainly something wrong with the printer and this is probably the most likely at this point as you read through the list once and you eliminated a few possibilities.

     

    Did you look at the photo that #24 points to?  That's a surprisingly common issue.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...