Jump to content
Ultimaker Community of 3D Printing Experts

[SOLVED] Pause at height fail


Recommended Posts

Posted (edited) · [SOLVED] Pause at height fail

Hi everyone,

 

I have an Ender 3V2 with which I've just started 3d printing like a month ago. Now I want to try to create harder things and I need the pause at height script for this, because I want to insert magnets in my prints.

Problem is, everytime I try to do this, the print pauses as expected, but when I resume it, it just doesn't print at the correct height: it's too high. I also noticed that when I pause the print manually and resume it later, the problem is the same.

I tried everything I could find on the web: modify the gcode, sink the remaining part in the plate in Cura, etc. nothing works and now I'm left with no solution and feel very limited.

 

Can you guys help me ? 

Edited by Hekusen
  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    Sounds like a hardware issue where the Z movement is going too fast for the stepper to keep up?  Do you know how to play with different Z speeds and determine what is the max speed (test both up and down) before the printer can't move fast enough?  Once you know that speed tell the printer to use half that speed as maximum Z speed.  Z speed isn't all that critical for printing quickly since the Z only moves a tiny amount between layers normally.

     

    @GregValiant what do you think?

  • Link to post
    Share on other sites

    Posted (edited) · [SOLVED] Pause at height fail

    Hello.

    @Hekusen are you using Pause At Height with "By Height" or "By Layer Number"?  There is a known glitch when using "By Height" and there are Z-hops in the file (or if you are using Adaptive Layers).

    Cura reacts to the last Z it sees before the pause and if that was a Z-hop (or an odd adaptive layer height) then the resume height can be wrong by the Z-hop height.

    Have you opened a gcode file to check what's going on with the Z around the pause?  If you search for "M0" (or whatever pause command you are using) it should jump right there.

    From the point of the pause - search for " Z" (space Z).  Each Z value should be near the print height, and then finally it should drop to the print height and the extrusions will start again.  That's the plan anyway.

    You could post a gcode file that exhibited the problem as well.  I have an Ender 3 Pro and PauseAtHeight is one of my most used plugins.  I've never had a problem with the resume height.  As a rule - the printer goes where it's told.

     

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    Hello, thanks for your answers!

     

    @gr5 I don't know how to do this unfortunately. I know about travel speed, infill speed and such, but I didn't know you could edit the z speed.

     

    @GregValiant I use Pause At Height with "By Layer Number". Among the fixes I found, some made me open and edit the gcode, but it was rather to resume a failed print by removing every line from the resuming layer up to "Ender 3 Custom Code". It didn't work: the extruder started too high anyway. Only thing that I tried then was to go to "Prepare" and move Z from 5 to 0 (because somehow everytime I canceled the print the value became 5), but too high again...

    Here is the gcode for a print that failed to resume after a Pause At Height.

    I looked for " Z" after the M0 I use to pause the print. It is near the next layer to be printed, but I can't tell if it's right or not, I'm just starting with gcode.

     

    Thanks for your help!

    CE3PRO_Resource_Box_Top_8x3.gcode

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    "...go to "Prepare" and move Z from 5 to 0 (because somehow everytime I canceled the print the value became 5)"

     

    When you Auto-Home the printer what does the LCD show for the X, Y, and Z locations?

     

    Looking through that gcode I see differences between what you have there and what I normally see in the pause area of a gcode file.  The printer moves to Z4.36 which is the correct print height for layer 26.  The final location before the pause is "G0 X187.989 Y174.8" at a Z of 4.36.  That is the location of the nozzle when the print pauses and there are no further movements until extrusion resumes and goes to "G1 F2400 X32.011 Y174.8 E1549.92737" with the Z still at 4.36.  That looks correct.

     

    In my pause code I always see a Z movement, then a move to a Park Position.  After the pause there is a movement to the "resume position" and then the Z drops to the resume height, there may be an un-retraction, and then extrusion resumes.  Your gcode file is missing all of that.

     

     

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    I just looked at the gcode.  The Z should not move during the whole pause and resume operation according to the gcode.  So if you are seeing any z movement then there is a hardware issue.  Or firmware issue.  It's possible that when the firmware sees the M0 gcode it also changes the Z on purpose.  I don't know.  But it's not Cura's fault as cura is not doing anything with Z value.

     

    Is it possible the printer cuts power to the steppers?  This is a common feature - sometimes the steppers cut out after a minute or so to save power.  But if that happens with the Z then gravity can take over and cause problems.

     

    I would test with a tiny part.  Something that prints in 2 to 5 minutes.  Maybe a 10mm cube (you can take any part and scale it down in cura until it's a 5 minute part).  Then I would add the pause at layer on the second layer and experiment.  Maybe video what is going on exactly so you can review it.

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    I did a "Home All" (I use the Jyers firmware) and here are the numbers shown for X, Y, Z :

    X: 154

    Y: 117

    Z: 14.28

     

    In Cura I unticked the "Park Print" option, maybe that's why there's no mention of that. Still when the pause occurs, the extruder moves to park position automatically. I joined a screenshot of my script settings. 

     

    I'm quite sure the Z moves when the extruder parks for the pause, but can't say for sure. I should add that I have a BLTouch so I had to plug it to the motherboard. Is it possible that I messed something up doing this? Pause At Height is the only thing I have issues with though, otherwise my prints – even quite long ones – are fine.

    I checked if there's a new version of Jyers but no, so... should I go back to Creality's official firmware ?

     

    I did a test on a small print and paused at the second layer. It resumed just fine.

     

    I don't think gravity's the problem, because on this particular file, the print resumed with the Z being, like, 4 cm too high. It's pretty random for each print. Another one with 111 layers and a pause at layer 96 had the Z too high, but not that much, maybe a few millimeters.

    Cura_atQKueqk3m.png

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail
    Quote

     

    It's pretty random for each print. Another one with 111 layers and a pause at layer 96 had the Z too high, but not that much, maybe a few millimeters.


     

    Okay I still like my original theory.   You are losing steps on the Z somehow.  For some reason either the speed, the jerk, or the acceleration on the Z axis is too high.  Or friction - maybe you need to oil the Z screw and rods.  But I think you are losing steps on the Z axis at some point.

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    Another thing...With the "Disarm Timeout" set to "0" then the printer will fall back to the firmware setting.  I'm not familiar with the Jyers firmware but the stock Ender is 120 seconds until the steppers disable.  If it is taking you longer than 2 minutes to insert the magnets then that could be a definite problem.  The maximum you can put in the box is 1800.  That is in seconds and so you would have 30 minutes to complete your task.

     

    On what may be another topic - your "Home All" numbers seem odd to me.  When I use the Auto-Home (stock Ender 3 Pro firmware) and the print head is up against the X, Y, and Z end-stop switches then the location of the nozzle is displayed as X0 Y-5 Z0.  Those are exactly my Home Offset numbers.  The Auto-Home location is measured from the Home Offset 0,0,0.

     

    So maybe @gr5 has it right that you are having issues with the Z, or possibly the steppers are disabling, losing position, and resuming incorrectly.  That gcode certainly is not telling the print head to move up from what should be the printing height of the next layer (4.36).

     

     

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    Hey, ok so I did the same print today and waited by the printer to be able to insert the magnets right when the pause began. Managed to do it in 30 sec or so, then hit "resume".

     

    Clearly the Z was way too high, like I said the other time, something like 3-4 cm. The only explanation I have is that when the pause occurs, the Z moves up either when the print head parks or when it comes back (I couldn't figure it out exactly on the moment).

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    There are no "Z" moves within the area of the pause in that gcode file you posted.  None.  I think there should be some but there aren't any.  There is no "park" move either.

    It's possible that using M25 for the pause is causing a problem within the printer firmware.  The fact that you also have M0 in there may be a problem and the double commands are causing a glitch in the firmware.

    The problem is not within that gcode.

    Here is a gcode file with an M25 pause at layer 5.  There are no bottom skins so it should print quickly.

     

     

    X-Y Ref Block.gcode

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    Ok problem solved. Guess the problem was that I used BQ M25 when M0 is actually perfectly fine. So if anyone has the same problem as me : regarding the Ender 3 V2, there are a lot of tutorials telling you to use BQ M25 for Pause at Height. This seems to be out of date. Use M0.

     

    Thanks for your help guys, now I'm stuck with another problme : layer shifting... guess I have more work to do.

  • Link to post
    Share on other sites

    Posted · [SOLVED] Pause at height fail

    Is the layer shifting only on the Y axis?  The Y axis has the most trouble as it is heaviest.  shifting is usually caused by loose set screws on the pulley on the stepper.  You need those extremely tight.  But could also be caused by too much friction (add some oil?) or just that your acceleration and jerk settings for the Y axis are too high and need to be lowered on the printer settings.  On the printer (not in cura).

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...