Jump to content
Ultimaker Community of 3D Printing Experts

UM3 - Camera not working (even after factory reset)


Recommended Posts

Posted · UM3 - Camera not working (even after factory reset)

Hello,

 

I've use in the past UMS3 and had no problem see webcam feedback on local network and Digital Factory.

Now on my UM3 i'm unable to see any image on local or Digital Factory.

I've tested directly Cura + on different web browser but i only have a loading screen.

I've followed few topic on this same problem but nothing resolve my problem.

 

- I have a local IP, can connect to local webpage but no image stream

- Keep showing loading with a blue circle moving.

- Firmware 5.3.0

- Factory reset change nothing

- Digital Factory reset, nothing change

- Not working on iPhone app

- Tested on Firefox, Chrome and Edge

- Unplugged printer electrically

 

Thank you!

  • Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    Have you tried going directly to the stream? That would show you if the camera is still alive and there's something else going on preventing you from seeing the output.

    http://IP_OF_PRINTER:8080/?action=stream

  • Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    Something is wrong with the camera electronics. In the dmesg.log file you posted there should be a few lines for the camera being detected on the USB bus. Something like:

    Quote

    [    6.699785] usb 2-1: New USB device found, idVendor=28c7, idProduct=3841
    [    6.706554] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [    6.713891] usb 2-1: Product: USB 2.0 Camera
    [    6.718304] usb 2-1: Manufacturer: Ultimaker B.V.

     

    These lines are missing.
    Check the usb cable to the camera. Check both sides, i.e. at the camera and the connection to the cpu board.

  • Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    Sorry for late response, i was away from my printer.

    I've check cable on both end and it change nothing, can I plug the camera module on my PC to test it?

  • Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    The camera used to be a standard usb webcam, but then they didn't have enough usb connectors on the cpu-board, and the connector type was changed.
    I'm looking at the schematics and it doesn't make sense anymore.

    • Like 1
    Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    It seems to be a micro usb to mini usb cable:

    - micro usb for webcam interface

    - mini usb for board interface

     

    I tried to plug the webcam with a micro usb to usb cable and my PC don't detect it.

  • Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    When your camera has a (micro) usb connector, then it can be connected to your PC. In my printer it has a different connector, but my printer is an early protoptype.

    How to show the image on your pc is another thing which I didn't look into.

  • Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    I've successfully link the camera module to my PC. I've just plug with another micro usb to usb cable, open Camera app in Windows 10 and switch to it.

     

    I've replug it in my printer, restart it and it worked perfectly now!


    To conclusion for this topic: I think that plug it directly in my PC reset my camera module. I've tried plug/unplug camera module few times, factory reset my printer but it doesn't do anything. It has worked only after i plug into my computer and replug it in my printer.

     

    Thanks for helping me 😇

    • Like 1
    Link to post
    Share on other sites

    Posted · UM3 - Camera not working (even after factory reset)

    Great to hear your problem is fixed, and thanks for sharing the solution here for others to learn from.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 13 replies
    ×
    ×
    • Create New...