Jump to content
UltiMaker Community of 3D Printing Experts

Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck


BigLebowski
 Share

Recommended Posts

Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

Hallo,

ich habe seit Kurzem das Problem, dass der UM2+ bei Drucken, bei denen ich mit "Pause at Height" zwischendrin das Filament wechsle, mir ganz zum Schluss des Drucks

noch einen ordentlichen Klecks Filament auf das Bauteil presst, was in aller Regel die Druckarbeit von mehreren Stunden zunichte macht.

Ich habe keine Ahnung woran das liegen könnte, weil ich mit derselben Cura-Version (4.13.1) auch schon Farbwechsel-Drucke generiert habe, bei denen der Druck ganz

normal endet.

Ich kann auch im Gcode am Ende absolut nichts Verdächtiges finden, auch wenn ich das Ende der Datei mit einer Datei vergleiche, bei der das nicht passiert.

Ich habe einen Gcode mal attached, vielleicht kann ja jemand mal drüberschauen oder jemand hat sonstwie einen Tipp.

Grüße

Herbert

LotF TBL Sign (o.Balken).gcode

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Entschuldigung, dass es nicht auf Deutsch ist, aber das könnte helfen.

     

    Do you have a picture of the blob that your are talking about?

     

    A project file would help more in this case. It contains the printer and settings we need for troubleshooting. 
    Could you share your project file with us? To save a project file go to File -> Save project.

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    a better pic of a small test print that I created, the blob is in the upper left

     

     

    IMG_9252.jpg

    Edited by BigLebowski
  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Hast du eventuell Tinkergnome Firmware drauf?

    Das ist mir immer passiert am Schluss bei einem Farbwechsel, originale Firmware wieder drauf gemacht und dann wars weg.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Hmm, ich hab noch nie selber Firmware aufgespielt, beim Start erscheint irgendwas mit Tinker_19.03.1 oder so.

    Der Drucker läuft schon seit ein paar Jahren, alles was ich geändert habe, ist ab und zu die Cura-Version upgedated.

     

    Ich hab irgendwo im US-Forum gelesen, dass es mit irgendwelchen korumpierten Profilen zu tun haben könnte. Hab mal alle meine Profile gelöscht (waren eh' nur 3), aber das hat nix gebracht.

     

    Interessanterweise passiert das mit dem Blob nur dann, wenn man auch wirklich das Filament wechselt. Wenn ich beim Pausieren einfach nur auf Resume drücke, dann macht er den Druck wunderbar fertig - ohne Kleks.

    Das hilft mir nur leider nix......

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Hallo,

     

    Also für mich scheint es auch ein Firmware Probleme zu Sein, wahrscheinlich auch in Verbindung mit FLAVOR: UltiGCode

    Ich kann keine Fehler in gcode finden

     

    Beim eigentliche Filament Wechsel Plugin in Cura muss man ja auch bei UltiGCode irgendwas berechnen

    Wird vielleicht auch was mit den "End of print length Retract" zusammenhängen, glaub bei der Tinker konnte man dies Einstellen.

     

    Vielleicht hilft dir das Weiter:

     

     

    Das hatte ich mir mal notiert

     

    Gruß

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Irgendwie kann ich nicht glauben, dass es an der Firmware liegt, ich habe hier noch einige Gcode-Dateien mit Pause-at-Height und Filamentwechsel, die einwandfrei funktionieren. Grad ist eine im Drucker - hoffentlich straft die mich nicht Lügen.  🙂

     

    Nur bei Dateien, die ich in jüngerer Zeit mit Pause-at-Height erstellt habe, tritt dieses Problem auf.

     

    Das mit dem Retract braucht man doch beim Filamentwechsel nicht, weil man das Filament beim Wechsel ja sowieso komplett rauszieht.

     

    Was meinst du mit End-of-Print-Length-Retract? Ist das eine Einstellung in Cura?

    Edited by BigLebowski
  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck
    3 minutes ago, BigLebowski said:

    Pause-at-Height und Filamentwechsel, die einwandfrei funktionieren.

     

    Das hat sich aber oben anders gelesen bzw. habe ich anders Verstanden.

    Dachte immer wenn Pause + Filament Wechsel macht er diese Klecks

     

    Teile doch mal ein gcode wo das Pausieren + Filiament Wechsel funktioniert!

     

    7 minutes ago, BigLebowski said:

    Was meinst du mit End-of-Print-Length-Retract?

     

    Das sollte eine Einstellung an der Tinker Firmware am Drucker sein.

    Weiß aber nicht mehr ob bzw. ab welcher Version übers Menü sichtbar war.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck
    3 minutes ago, zerspaner_gerd said:

     

    Das hat sich aber oben anders gelesen bzw. habe ich anders Verstanden.

    Dachte immer wenn Pause + Filament Wechsel macht er diese Klecks

     

    Teile doch mal ein gcode wo das Pausieren + Filiament Wechsel funktioniert!

     

    Mach ich sobald der Drucker mich nicht widerlegt hat.  🙂

    Dauert aber ein paar Stunden.

     

    Firmware-Einstellungen habe ich noch nie angefasst, wüsste nicht mal wie das geht

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Das alte gcode-File druckt er ohne Blob am Ende.

     

    Ich hab das gcode mal attached.

    InOutLogo Pause50 sup redpla.gcode

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Kannst du mal ein Foto machen wie das Display aussieht während des Drucks?

    Dann können wir genau sagen ob du Tinker oder originale Firmware drauf hast.

     

    Hast du den Drucker gebraucht gekauft? Dann ist es nämlich sehr gut möglich dass Tinkergnome drauf ist.

    Es ist eine sehr gute Firmware, hat aber leider hier und da Bugs, wie eben der Filament-Blob am Ende wenn man Farbwechsel durchführt.

     

    Benutzt du noch Cura 4 oder auch 5? Denn die 5er produziert selber genug Probleme und ich habe deswegen wieder zu 4.13.1 gewechselt, für die UM2er Serie braucht man CURA 5 eigentlich gar nicht.

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Er hat doch schon geschrieben dass Tinker drauf ist, bzw. beim start angezeigt wird.

     

    Ich hatte aber auch mal das Problem, war aber nicht die Firmware (Tinker). Sobald mir einfällt was es war, komm ich drauf zurück.

     

    edit: Kann sein dass es die Glättungsfunktion ist. Würde ich sowieso abschalten, die macht im Grunde das Gegenteil von dem was sie soll wenn die Düse nicht perfekt sauber ist.

    Edited by Falko
  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Ich nutze Cura 4.13.1.

     

    Leider passiert es ohne Glättungsfunktion auch 😞 Die hab ich nur getestet, um zu sehen, ob es damit weg ist.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Stell mal bei den Geräteeinstellungen die Gcode Variante von Ultimaker auf Marlin. dann hast du mehr Optionen. Vieleicht liegt es daran. Ich hab mit grad deshalb meine Einstellungen mit deinen zerschossen.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    ich musste erstmal suchen, wo man das umstellen könnte, von daher kann ich ausschließen, dass ich das jemals verändert hätte. Darum würde es mich wundern, wenn das was helfen würde, weil ich ja durchaus Gcodes habe, die mit dieser Cura-Version erzeugt wurden und einwandfrei funktionieren.

    Und was bedeutet "mehr Optionen"?

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck
    4 hours ago, BigLebowski said:

    Und was bedeutet "mehr Optionen"?

     

    Wennst du auf Marlin umstellst hast du mehr Optionen die du in Cura einstellen musst.

    Bei deiner jetzigen Einstellung stellst du ja Temperatur Retract etc. am Drucker ein.

    Wennst du umstellst stellst du alles in Cura ein (und überschreibst die Werte wo im Drucker hinterlegt sind), und da Cura mehr Funktionen hat gibt es da mehr einzustellen z.B. Temperatur für die Erste Layer, mehr Retract Einstellungen bzw. auch unterschiedliche etc. etc.

     

    On 10/24/2022 at 9:15 PM, BigLebowski said:

    Irgendwie kann ich nicht glauben, dass es an der Firmware liegt, ich habe hier noch einige Gcode-Dateien mit Pause-at-Height und Filamentwechsel, die einwandfrei funktionieren. Grad ist eine im Drucker - hoffentlich straft die mich nicht Lügen.  🙂

     

    Nur bei Dateien, die ich in jüngerer Zeit mit Pause-at-Height erstellt habe, tritt dieses Problem auf.

     

    Also es sind da auf jedenfalls starke unterschiede vorhanden:

    image.thumb.png.6b52843519b6d08efedd0039782bee5b.png

     

    Deine Funktionierende Datei ist Links, die schaut mir recht komisch aus da G10/G11 mehrmals drin stehen.

    Ich weiß nicht ob das Sinn gemacht hat/hatte (und nicht notiert wurde warum das so gemacht wurde und leider nach Jahren vergessen (oder anderer Programmiere etc.) und dann geändert weil gedacht wurde es ist ein Fehler), oder ob das nur zufällig so ausgegeben wurde und damit einen möglichen Firmware Fehler eliminiert hatte.

    🤷‍♀️😵

    Kann ich nicht sagen aber scheinbar funktioniert die linke Ausgabe ja

    Du hast da ja auch ein Material Wechsel übers Drucker Menü gemacht bei den M0, nicht das wir uns falsch verstehen?

     

    Was du Testen könntest, du könntest die Plugin Datei aus den Installation Ordner von Cura 4.8, nach deiner aktuellen Cura Version kopieren.

    Der Pfad liegt unter:

    C:\Program Files\Ultimaker Cura ####Version#####\plugins\PostProcessingPlugin\scripts

     

    Kann aber auch sein das dass Plugin aktualisiert wurde weil es Änderungen bei Cura gab etc. oder das Plugin hatte andere Bugs, das musst du testen.

     

    Gruß

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck

    Oder der Fehler ist das dass G10/G11 außerhalb von M83/M82 steht.

     

    Man könnte bzw. Ich würde so vorgehen um den Fehler einzugrenzen:

     

    1. Ich würde eine kleine Datei in Cura (NEU) erstellen mit Pause, wo halt nicht allzu lange Druckzeit und Material Verbrauch hat, zum Testen.
    2. Dan würde ich manuell nach und nach den gcode von Hand anpassen und schauen wann halt der Blob am Druckende weg ist.
      Allso erst vielleicht die Reihenfolge ändern (erst M83 dann G10)
      Wenn erfolglos würde ich halt 3x G10/G11 übernehmen usw.

    Gruß

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck
    On 10/25/2022 at 10:05 PM, zerspaner_gerd said:

     

    Wennst du auf Marlin umstellst hast du mehr Optionen die du in Cura einstellen musst.

    Bei deiner jetzigen Einstellung stellst du ja Temperatur Retract etc. am Drucker ein.

    Wennst du umstellst stellst du alles in Cura ein (und überschreibst die Werte wo im Drucker hinterlegt sind), und da Cura mehr Funktionen hat gibt es da mehr einzustellen z.B. Temperatur für die Erste Layer, mehr Retract Einstellungen bzw. auch unterschiedliche etc. etc.

     

     

    Also es sind da auf jedenfalls starke unterschiede vorhanden:

    image.thumb.png.6b52843519b6d08efedd0039782bee5b.png

     

    Deine Funktionierende Datei ist Links, die schaut mir recht komisch aus da G10/G11 mehrmals drin stehen.

    Ich weiß nicht ob das Sinn gemacht hat/hatte (und nicht notiert wurde warum das so gemacht wurde und leider nach Jahren vergessen (oder anderer Programmiere etc.) und dann geändert weil gedacht wurde es ist ein Fehler), oder ob das nur zufällig so ausgegeben wurde und damit einen möglichen Firmware Fehler eliminiert hatte.

    🤷‍♀️😵

    Kann ich nicht sagen aber scheinbar funktioniert die linke Ausgabe ja

    Du hast da ja auch ein Material Wechsel übers Drucker Menü gemacht bei den M0, nicht das wir uns falsch verstehen?

     

    Was du Testen könntest, du könntest die Plugin Datei aus den Installation Ordner von Cura 4.8, nach deiner aktuellen Cura Version kopieren.

    Der Pfad liegt unter:

    C:\Program Files\Ultimaker Cura ####Version#####\plugins\PostProcessingPlugin\scripts

     

    Kann aber auch sein das dass Plugin aktualisiert wurde weil es Änderungen bei Cura gab etc. oder das Plugin hatte andere Bugs, das musst du testen.

     

    Gruß

     

    Sorry, war auf Dienstreise, darum so lange keine Antwort:

    Ja, ich mach den Filamentwechsel über das Druckermenü

     

    Das seh ich auch gerade, dass das funktionierende Gcode mit der Cura 4.8 erstellt wurde. Der Update auf die 4.13.1 ist vermutlich auf meinen Rechnerwechsel zurückzuführen - war mir gar nicht mehr so transparent.

    Ich installiere mal parallel die 4.8 - hoffe das geht. Und dann versuch ich´s mit dem 4.8er-Skript nochmal, mal sehen was da für ein Gcode produziert wird.

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ macht einen Filament-Blob auf den fertigen Druck
    On 10/25/2022 at 10:20 PM, zerspaner_gerd said:

    Oder der Fehler ist das dass G10/G11 außerhalb von M83/M82 steht.

     

    Man könnte bzw. Ich würde so vorgehen um den Fehler einzugrenzen:

     

    1. Ich würde eine kleine Datei in Cura (NEU) erstellen mit Pause, wo halt nicht allzu lange Druckzeit und Material Verbrauch hat, zum Testen.
    2. Dan würde ich manuell nach und nach den gcode von Hand anpassen und schauen wann halt der Blob am Druckende weg ist.
      Allso erst vielleicht die Reihenfolge ändern (erst M83 dann G10)
      Wenn erfolglos würde ich halt 3x G10/G11 übernehmen usw.

    Gruß

     

    Das werde ich auch so versuchen.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...