Jump to content

Installing Ultimaker S5 R2 Motherboard into an Ultimaker S3


othermod
Go to solution Solved by IRobertI,

Recommended Posts

Posted · Installing Ultimaker S5 R2 Motherboard into an Ultimaker S3

Good afternoon, 
I am attempting to use an Ultimaker S5 R2 motherboard in a Ultimaker S3, and I am experiencing an issue.

 

My problem is that after flashing the S3 firmware, printer still configures itself as an S5. 

I investigated a bit, and I believe the problem is that the S3 firmware file hosted on the site is not actually the S3 firmware.

I checked files for the S5 and the S3, and it appears that they are identical, and I believe this is source of the problem. I did an MD5 check, and they both give a result of d96f18de0945f32facdff7a07afd4306.

 

I used this firmware recovery process to flash the S3 firmware onto the S5 board.
https://support.makerbot.com/s/article/1877434822572

 

Does anyone have the actual S3 recovery image?

 

Alternatively, maybe I'm entirely wrong and there is some other mechanism that's used to tell the Linux board that it is in an S5 vs an S3. If that's the case, please let me know. Any help is appreciated.

 

Thanks

  • Link to post
    Share on other sites

    Posted · Installing Ultimaker S5 R2 Motherboard into an Ultimaker S3
    13 minutes ago, IRobertI said:

    The boards are the same, but they need to be "provisioned" so that they know which type of printer they are installed in. Instructions for that can be found here:
    https://support.makerbot.com/s/article/1667410987665

    That worked perfectly. Thank you so much for helping with this.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...