Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
Nicolinux

Bed leveling trouble - UM2

Recommended Posts

Hey guys,

I am loosing my cool over something that should be a no-brainer. Lately prints started to feature bad top surfaces where the filament strands wouldn't touch each other:

Bad Top surface

 

So I thought maybe the bed leveling is off and the nozzle is too far away from the bed. Now regardless of what I am doing, it seems the nozzle is always too close to the bed. I've leveled the bed on the UM1 countless times before and a few times on the UM2. This shouldn't be such a problem for me.

When I level the bed now, even if I use a fairly thick sheet of paper (more than 90g/mm^2 anyway) and there is no resistance when moving it between nozzle and bed, the nozzle is still to close. I have also tried to level the bed by eye, beeing very generous regarding the gap between nozzle and bed. To my eye the gap looks like 0.5mm and then I still get this:

leveling01

leveling02

leveling03

Initial layer thickness is set to default (0.3mm).

WTF? I mean I could level it again by eye and make the gap bigger, but then the "use a sheet of paper" advice would be pointless. And I don't remember this beeing such a problem before. When leveling the bed a few weeks ago I leveled it in such a way where I felt a ver very very slight resistance (because I took into account that the bed and nozzle expand when they get hot).

Is there something I haven't thought of?

Help!

 

Share this post


Link to post
Share on other sites

Hey Nico

I get the same thing happen sometimes too. It`s annoying but I often leave mine if I am not bothered about the bottom surface, because I find the next layer turns out OK which is weird. Do you find that? This also suggests to me that it is not the bed levelling causing this. If the level is out, then surely other layers would do the same thing. So.. its something to do with first contact to the build plate i think.

Try running the first layer at a lower temp...200, and the bed at 60.

I also check my nozzle now before each print, and when its hot.. I press TUNE and then run my fingers over the nozzle to clean off any old pla.

 

Share this post


Link to post
Share on other sites

Bed leveling only affects the first layer (well slightly the second layer but by 3rd layer all is good). This should be so obvious I'm not sure how to explain it. There's something about the machine you don't understand if you don't get this, but I'm not sure what you are missing. I'm not trying to insult you - it's just that usually I can take someone else's perspective and see what they don't get. But you guys have been using the machine for a while and understand about the Z screw and all by now, right?

 

Share this post


Link to post
Share on other sites

Nico - something is wrong. I don't know what - but something is wrong. I'd check the Z switch and also that screw that goes down into the Z switch and see if either is loose.

Are you using ulticode? Or reprap code? If reprap code try ultigcode as the reprap method could (possibly but it should be fine) have something bad that messes up the home position.

 

Share this post


Link to post
Share on other sites

Hi Nicolinux, is it happening with just the top layer or with intermediate layers also, which of course get covered up. If your 1st and 2nd layer (different depth potentially) are OK then personally I am not convinced it has anything to do with bed levelling or nozzle to bed distance. But if it is only happening on last layer then I am stumped as to what it might be.

I assume your top layer solid infill distance covers multiple layers not just the last one and that those last few layers are OK?

Did you forget to give your printer porridge for breakfast?

 

Share this post


Link to post
Share on other sites

Hi,

I admit having the very same issue as Herr Nicolinux. It doesn't bother me that much as there is even more severe issue I'm facing now:

http://umforum.ultimaker.com/index.php?/topic/4620-problem-printing-colorfabb-pla/?p=46025

:sad:

For the bottom - my theory is that it is the matter of leveling and temperature vs. the speed. Anyways, the problem goes away after a couple of layers.

For the top - speed and temperature again perhaps? Can you try to raise the temperature to see the effect it produces?

No other productive thoughts at the moment...

 

Share this post


Link to post
Share on other sites

@Dim3nsioneer: I'll check the switch, thx.

@Skint: Well it does bother me because if you try to print small models like the http://www.thingiverse.com/thing:53451 at 0.5 scale, a messed up first layer means that the gears will stick and the model is broken.

@gr5: Don't know if you meant me but I think the gap between nozzle and bed could very well be problematic for the the last layer. True, filament expands after it has been extruded, but if the bed leveling gets worse over time and the gap widens, then a thinner filament strand could be due to the large gap because filement strands will get thinner if streched. The z-stage of my replacement UM2 felt a bit filmsy from day one. The range where I can adjust the height (with the bottom thumb screws) is fairly narrow because the front right screw starts to turn with the thumb screw if I turn it a tiny bit too far out.

I'll check the switch and the screw that holds it in place.

Also, I am using UltiGCode (one reason I don't use OctoPrint to its full potential right now is because it still doesn't speak UltiGCode).

@yellowshark: Lately it happens with all layers. During printing I am able to see the layers beneath between the actual layers. Top/bottom thickness is set to 1.2mm. But now that I think of it - the models where this effect is visible most, are those that are not printed at the center. This is another hint that there is something wrong with the bed leveling. The whale was placed on the far left side on the bed. I printed several objects at the same time (one after another - I don't dig printing everything at once because of excessive stringing) and the wale looked worst. There was another effect, again only on the whale model:

broken whale02

broken whale01

The shell looks filmsy and irregular on curved areas. Straight, flat areas are fine. I haven't seen this before.

@Shurik: Well I am printing most models at 230°.

Also, I have responded to your thread. Check the filament diamenter and if the nozzle is clean/free.

@all: By the way, the bed leveling was necessary because I performed a factory reset on the UM2. And I did this because I tried to print the octopus model (at 0.5 scale) and it looked bad. I thought that I might have messed up the motion settings in firmware and wanted to start with a clean slate. The model features some ugly bumps that coincide with retraction moves. Also printed this at 205° and 20 speed (and there is slight underextrusoin with 0.1 layers).

octopus Bad

 

But I printed this model before (don't know how, lost the gcode file) and it came out without those bumps:

octopus best

 

However, with the actual bad bed leveling, I let the print finish and it looks like this:

octopus worst

 

This time I disabled combing and reduced the minimum travel for retraction to 1mm. The bumps are still there and the quality is sh*t :/ And there is always always (even if very faint) underextrusion. Most of the time (and visible on all three octopussies) an entire layer is either missing or receding inwards.

 

I should go back to printing calibration cubes, then I can pretend to have a perfect printer...

 

Share this post


Link to post
Share on other sites

Hi Nicolinux,

 

Ok that is much better :) I thought it was just the top layer

You should check the stuff George talked about. Then you might want to proceed as follows.

 

First, let’s get the bed level stuff dealt with. I agree with George but let’s make sure you are happy too.

Load a standard 20cm cube into Cura. Reduce the z height by 50%(just to reduce print time)

Take 2 copies. Place one in the centre, another on the centre line horizontally but a ¼ in from the left, the other a ¼ in from the right

You should be able to run 100 microns at 20m/s at 205 but if you are one of those suffering extrusion issues then I guess going hotter is necessary. Use 300 microns at 30m/s and I would suggest 220max.? I run 300 at 60m/s with 220 degrees. Set bed temp to 60

Set 20m/s for 1st layer

You have been using different filaments so unlikely to be that but let’s take out that variable. Is it easy enough to take of the Bowden tube? Assuming it is, unfurl 2 mtrs of filament from your reel and feed it through the tube to make sure it is smooth and easy and not sticking. Put it all back together

Set the Multiple print to print all at the same time.

Select one loop.

On this I do not think it makes a huge difference but set 70%fan by 0.9mm or 1.2 mm

Retraction on. Get bed up to temp. Get extruder up to temp; wait a few minutes for it to stabilise.

Print and watch.

Report back.

 

 

2nd lets try and address the nozzle to bed distance

Same as above but just use one cube.

I don’t know if you are using a glass bed or something or printing straight on to the bed but you will want to code a z-offset into your Cura start code.

I assume your z minimum end stop is 0 i.e. right at the bottom of the z axis and that is where your bed is located before you start your print. If that is not the case we need to stop right here and take some advice.

Assuming that is the case then you need your z-clearance - distance from bed at the 0 position to nozzle tip. If you are using a plate of some sort then you must already have a z-offset in the cura start code methinks.

If you do then reduce the number by 0.05

If not then take your z-clearance, say 210.0 and reduce that by 0.05. which is your new z-offset

These actions will move the bed 0.05 away from the nozzle.

Do check to make sure there is nothing else in the start code affecting the z positioning.

Enter G92 znnn eg G92 z209.95 being your z-offset

 

Run the print. Is the result better or worse than your first test.

If better or no different , reduce your z-offset number by another 0.05 (repeat as necessary)

Eg G92 z209.90

If worse increase your z-offset number by 0.025

Your are sort of doing a binary chop here if that means anything

If worse and you get back to your z-clearance number, then whether you want to try and get closer by adding 0.01 or 0.02 to your z-offset I will leave to your discretion.

Report back

 

Share this post


Link to post
Share on other sites

I've seen those bumps before. Usually they are fixed if I just print slower. Try 30mm/sec.

Also sometimes they are caused by inner infill sticking out through the side a bit so having a shell of .8mm can fix some of the bumps. You can verify if the bumps line up with infill by looking at layer view in gcode and see if they line up or watch while it is printing (before it's covered up) and see if the bumps line up with the infill pattern.

 

Share this post


Link to post
Share on other sites

@yellowshark: Thanks for the long advice. It is too early in the morning for me to comprehend all this. I'll read it after the tea has kicked it :)

@gr5: The two bad octopussies where both printed with 0.8mm shells and at 20mm/s... And the bumps line up with retraction movements (infill is set to 0). I wouldn't ask if it were easy to solve :)

 

Share this post


Link to post
Share on other sites

And the bumps line up with retraction

Oh! Okay - it's because it stops and pauses during retraction and during that pause extra filament leaks out.

So what's the fix? If you are printing at 20mm/sec then you can probably cool it down to 200C or 190C maybe? There should be less leaking at lower temperature and nice slow print speeds like 20mm/sec.

 

Share this post


Link to post
Share on other sites

Even at 20mm/sec? .1mm layers?

UM has some really exciting simple improvements that may help your underextrusion. You should contact Ian as he might have something for you to try out. Although you might have to wait for him to get back home.

 

Share this post


Link to post
Share on other sites

Hi guys,

Just a little update. I thought I've gone made because the problem sorta fixed itself. Leveled the bed again (felt a little resistance between nozzle and paper) and then the leveling was perfect. I tought - wtf? Nothing was different. Printed like this for a few days and then had to re-level (solved a backlash issue with the y-axis and thought it might be a good idea to level the bed). Now after leveling, the first layer looked like the second image in my first post - way too close. I aborted the print and started another. Then the first layer was just perfect...

perfect first layer

And here is a closeup of that perfect first layer:

perfect first layer close

 

I have the suspicion my z-stage is a bit loose and after the bed moves up/down a few times, the leveling changes. Does this make sense? If yes, oh well, that's bad. Don't know how to fix it. Never took the z-stage off on the UM2 (and not very keen to do...).

 

@yellowshark: Sorry for not following your advice. I admit that I was too lazy and after the issue fixed itself, I wasn't motivated to perform the test you indicated.

 

Share this post


Link to post
Share on other sites

You mentioned that there isn't much room to adjust one of the leveling screws? I'm not sure if that's because the screws are all the way in, or about to pop out, but I'd recommend that you adjust all three screws until they're in a middle position - the gap between the base plate and the underside of the heater should be about 11 or 12 mm all round. Then relevel the bed. This way, you'll have plenty of adjustment room on all the screws.

 

Share this post


Link to post
Share on other sites

I have the suspicion my z-stage is a bit loose and after the bed moves up/down a few times, the leveling changes. Does this make sense? If yes, oh well, that's bad. Don't know how to fix it. Never the z-stage off on the UM2 (and not very keen to do...).

I don't know if it makes sense but if it does it answers a behavior on my UM2 i can't explain.

Some prints i have very smooth first layer, some prints not.

Sometimes i finish a print, do another print and the brim and first layer isn't good at all, looks like the nozzle is way too close to the buildplate and nothing is extruded or very little.

I got this yesterday, i left the print to finish because i didn't care about the first layer being not perfect. After the print was finished i did another one and the brim lines were very thick and consistent (without changing anything).

I often thought that the little force i applied on the buildplate to take the object off could have some sort of influence on bed levelling.

How can i check if my Z screw is ok?

All the prints i do come out very good

 

Share this post


Link to post
Share on other sites

I have wacked the bed hard enough to slide my UM2 50mm across the table with a hard smack using the heel of one hand against a putty knife in the other hand where the other end of the putty knife is pushing against a difficult-to-remove part. I keep thinking this will mess up my leveling but I can go weeks without re-leveling even with this abuse.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!