Jump to content
Ultimaker Community of 3D Printing Experts
DaHai8

Cura 2.3 Beta Awesomeness and Some Issues

Recommended Posts

So I installed Cura 2.3 (beta) and have run into a couple minor issues and questions at the start (as well as some really Awesome things)

I know it's beta, and this are pretty minor, but I wanted to note them, plus a couple I do need help on:

1. Cura 2.3 and 2.1.3 are not compatible. You can't run both on your Windows PC. They knock heads and will undo the other's settings. Just something to watch out for.

2. Loading 'Machines' on start up takes a really long time - about 20 seconds. Not sure why, but it was lickity-split fast in 2.1.3

3. Doesn't understand Cura 2.1.3 machine .json files. Not a big deal since 2.3 now has a built in Custom Machine creator! VERY NICE.

4. Where are the Custom Machines kept? I want to review mine and put my .stl bed plate back on so I can tell where 0,0,0 is :)

5. "G28 ;Home" in the Start gCode is a bad idea for many I3 style printers. This can run the print head into the bed adjustment knobs as the home position is outside the print bed. I much prefer the original:

 

G28 X0 Y0 ;move X/Y to min endstopsG28 Z0 ;move Z to min endstops

 

 

6. The Extensions / Post Processing / Modify G-Code menu only allow you to add the "Pause at Height (BQ Printers) script, even though there are two others in that Cura folder (along with three of my custom ones from 2.1.3)

7. "Unable to Slice" - was playing around with French Bulldog from thingiverse and it sliced initially, but now it says "Unable to Slice". I will try to reproduce reliably and report back.

Now, for the stuff that's AWESOME!!!

1. Layers View IS SCREAMING FAST! Almost instantaneous.

2. Printer Profile creator is great! I don't need to edit json files anymore!

3. Dual Extrusion! I don't have a dual extruder, yet, but it's great its in there!

4. Combing Mode: No Skin. This is wonderful! It should really improve the top/bottom layer quality

5. The Per-Model settings are just INSANE (in a good way). WOW!

6. Scaling is Fixed! Yeah!

7. Absolute Positioning on Model Moves! Happy happy happy!

8. Meters and Gram estimates! :)

9. Jerk and Acceleration Control!! Cura slicing time estimates have always been off by a factor of 1.5 (at least) and this is probably due to Cura not knowing my Jerk/Acceleration settings on my printer. This should really help!!

10. Equalize Filament Flow! Wow! Print thinner than Nozzle size lines?! Am I reading this right? Cool!

I'm sure I've missed a lot of new stuff, but those just jumped out an me.

And I haven't even tried printing yet!

Cura 2.x is a wonderful, well defined and constructed app. It adheres to many of the OS's design guidelines making its learning curve very small while still provide a butt-load of options to get the best possible prints from your objects.

Thank you!

Share this post


Link to post
Share on other sites

Issue 6. The Extensions / Post Processing / Modify G-Code

Turns out this was sorta my bad: The internal code structure and functions changed between 2.1.3 and 2.3, as I discovered. So my Plugins were no longer compatible.

However, when Cura runs into a bad Plugin, it just stops looking for any other and exits that routine. Once I fixed my plugins, the others "Pause at Height" and Tweak at Z" automatically showed up as well.

Share this post


Link to post
Share on other sites

I was excited to see the features of 2.3 and downloaded it.  Loved the custom machine setting.  Used it to set it up for my delta and checked the setting "machine center is zero".  Then when I loaded a model, the slicing would just hang part way.  When I tried unchecking the "machine center is zero" and tried slicing, it worked.  So, it looks like slicing fails when the "machine center is zero" is checked.

Thanks,

Balaji

Share this post


Link to post
Share on other sites

I had made a bunch of changes in my Printer Setup and while it would remember MOST them, it always put a 'undo' arrow next to them. When I clicked on the undo, the value wouldn't change but the arrow went away - that is until I restarted Cura, and then they all the arrows came back and some of the settings didn't save.

So I decided to update my Profile with the current settings:

On the main screen on the "Profile:" drop down select "Update Profile with current settings"

Exit Cura. Reload and 'blah' printer is gone and it asks for your to select a printer again.

From that point on, things just got worse.

I built the new Prusa I3 profile for my Aurora A3 and tried setting the Printer Setup properties again. Re-enabled all the setting visibilities. Then Exited Cura and restarted it.

Yipes!

Now it prompted for a Disk in my SD Card Slot and would not take 'Cancel' for an answer.

So I unplugged the SD Card Reader and restarted Cura again.

Even Worse!

Now Cura wouldn't even start. Just locked up at "Loading Interface..." and had to kill it with Windows Task Manager.

So, I thought "I've had 3 versions of Cura 2.x on my PC and the AppData/Cura folder is full of "old" folders and other such crap. So I blew it all away!

sorry - no log file now

BUT: Cura 2.3 is MUCH happier now! The Profile updates properly and the 'undo' arrows on settings go away and all the changes stick!

So I guess, if someone runs into a similar issue, have them delete their "C:\Users\username\AppData\Local\cura" folder and start fresh.

Share this post


Link to post
Share on other sites

A lot has changed with the configuration files. We try to automatically upgrade all of the configuration files in AppData, but apparently we still have some work to do.

Emptying the appdata folder is a good thing to try if you encounter issues, but please keep a backup so we can check out what might have gone wrong.

Note: Cura should be quicker to start after the first time (because it does not need to parse all machine definitions again).

Share this post


Link to post
Share on other sites

Display Overhang not working.

Not seeing any red on a model that I know Cura has complained about before:

TreeFrog from thingyverse

I have "Viewport Behavior" / "Display Overhang" checked.

Toggling it and restarting Cura does not fix it.

Even the undersides of its feet are not showing up in Red

I'll keep trying things and post if I find the solution...

  • Like 1

Share this post


Link to post
Share on other sites

From Issue #7: "Unable to Slice"

Reproducible Bug: "Unable to Slice" when Retraction Speed set to 26 or above

Retraction speed defaults to 25 on my setup. Setting it to anything above 25 with a model loaded results in "Unable to Slice".

Setting it back to 25 and slicing works.

OR: Restarting Cura with the higher value also allows it to slice.

Edited by Guest

Share this post


Link to post
Share on other sites

Hi all!

So, my first reaction was YAY. And it remians so - soo many settings and innovative ones at that.

I have quite a few printers and my expectations flew high when I saw Multi Material Support.

But - this is only enabled for Original+? No way of adding a custom dual head printer?

In cura 2.1 there was a .json for dual_extrusion_printer - in 2.3 there's nothing like this.

Am I missing something obvious?

I tried editing fdmprinter.json by adding another extruder_train but after that it just ditches all the definitions upon launching Cura. I also added two files for the extruders folder that corresponded with those defined in the fdmprinter.json. No results.

So, am I missing something or that just isn't an option for now?

Thanks a bunch!

Share this post


Link to post
Share on other sites

In cura 2.1 there was a .json for dual_extrusion_printer - in 2.3 there's nothing like this.

Am I missing something obvious?

 

You shouldn't edit fdmprinter.json, but instead make a new file that inherits from it. Have a look at how the UMO_dual handles this. You are right on account of having to also add two extruders in the extruders folder.

Share this post


Link to post
Share on other sites

Pasting the relevant portions of the log:

2016-09-02 17:25:14,671 - INFO - UM/Backend/Backend.pyc (startEngine [55]): Started engine process: /Applications/Cura.app/Contents/MacOS/CuraEngine

2016-09-02 17:25:14,672 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] Calling engine with: ['/Applications/Cura.app/Contents/MacOS/CuraEngine', 'connect', '127.0.0.1:49674', '-j', '/Applications/Cura.app/Contents/Resources/cura/resources/definitions/fdmprinter.def.json', '']

2016-09-02 17:25:14,672 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend]

2016-09-02 17:25:14,673 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] Cura_SteamEngine version DEV

2016-09-02 17:25:14,673 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] Copyright © 2014 David Braam

2016-09-02 17:25:14,673 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend]

2016-09-02 17:25:14,673 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] This program is free software: you can redistribute it and/or modify

2016-09-02 17:25:14,673 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] it under the terms of the GNU Affero General Public License as published by

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] the Free Software Foundation, either version 3 of the License, or

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] (at your option) any later version.

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend]

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] This program is distributed in the hope that it will be useful,

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] but WITHOUT ANY WARRANTY; without even the implied warranty of

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the

2016-09-02 17:25:14,674 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] GNU Affero General Public License for more details.

2016-09-02 17:25:14,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend]

2016-09-02 17:25:14,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] You should have received a copy of the GNU Affero General Public License

2016-09-02 17:25:14,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] along with this program. If not, see .

2016-09-02 17:25:14,682 - DEBUG - UM/Backend/Backend.pyc (_logSocketState [165]): Socket state changed to Connected

2016-09-02 17:25:14,683 - DEBUG - UM/Backend/Backend.pyc (_onSocketStateChanged [155]): Backend connected on port 49674

2016-09-02 17:25:15,201 - DEBUG - .../cura/plugins/CuraEngineBackend/CuraEngineBackend.py (_onStartSliceCompleted [222]): Sending slice message took 0.04148578643798828 seconds

2016-09-02 17:25:15,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] [ERROR] Unregistered setting mesh_position_x

2016-09-02 17:25:15,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] [ERROR] Unregistered setting mesh_position_y

2016-09-02 17:25:15,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] [ERROR] Unregistered setting mesh_position_z

2016-09-02 17:25:15,676 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] [ERROR] Unregistered setting center_object

2016-09-02 17:25:15,677 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] [WARNING] -s support_interface_height="1" -s shell="0" -s retraction_speed="25" -s support_infill_rate="15" -s speed_print="60" -s jerk_layer_0="20" -s wall_thickness="0.8" -s jerk_support="20" -s experimental="0" -s switch_extruder_retraction_speeds="20" -s support_extruder_nr="0" -s cool_fan_full_at_height="0.3" -s cooling="0" -s wall_line_width="0.4" -s material="0" -s platform_adhesion="0" -s dual="0" -s travel="0" -s travel_compensate_overlapping_walls_enabled="True" -s support="0" -s jerk_wall="20" -s speed_support="60" -s resolution="0" -s acceleration_support="3000" -s infill_overlap="10" -s jerk_print="20" -s meshfix="0" -s speed_wall="30.0" -s blackmagic="0" -s speed="0" -s machine_settings="0" -s wireframe_flow="100" -s wireframe_roof_outer_delay="0.2" -s wireframe_roof_drag_along="0.8" -s wireframe_roof_fall_down="2" -s wireframe_strategy="compensate" -s wireframe_drag_along="0.6" -s wireframe_top_jump="0.6" -s wireframe_flat_delay="0.1" -s wireframe_bottom_delay="0" -s wireframe_top_delay="0" -s wireframe_flow_flat="100" -s wireframe_flow_connection="100" -s wireframe_printspeed_flat="5" -s acceleration_wall="3000" -s wireframe_printspeed_down="5" -s wireframe_printspeed_bottom="5" -s wireframe_roof_inset="3" -s wireframe_height="3" -s wireframe_printspeed_up="5" -s magic_fuzzy_skin_thickness="0.3" -s support_conical_min_width="5.0" -s support_conical_enabled="False" -s skin_alternate_rotation="False" -s skin_outline_count="0" -s support_interface_density="100" -s coasting_enable="False" -s draft_shield_height="10" -s draft_shield_height_limitation="full" -s draft_shield_dist="10" -s draft_shield_enabled="False" -s magic_spiralize="False" -s raft_fan_speed="0" -s magic_mesh_surface_mode="normal" -s raft_speed="30.0" -s infill_mesh="False" -s print_sequence="all_at_once" -s meshfix_keep_open_polygons="False" -s ooze_shield_dist="2" -s ooze_shield_angle="60" -s ooze_shield_enabled="False" -s multiple_mesh_overlap="0.15" -s prime_tower_wipe_enabled="False" -s prime_tower_flow="100" -s prime_tower_position_y="200" -s wireframe_nozzle_clearance="1" -s prime_tower_position_x="200" -s prime_tower_size="0" -s support_extruder_nr_layer_0="0" -s adhesion_extruder_nr="0" -s raft_base_fan_speed="0" -s bottom_thickness="0.8" -s machine_max_jerk_e="5.0" -s skin_overlap_mm="0.02" -s raft_interface_jerk="20" -s wireframe_up_half_speed="0.3" -s raft_surface_acceleration="3000" -s support_interface_extruder_nr="0" -s support_line_distance="2.6666666666666665" -s raft_interface_speed="22.5" -s material_print_temperature="200" -s raft_base_line_spacing="1.6" -s raft_surface_line_spacing="0.4" -s raft_surface_line_width="0.4" -s cool_fan_speed="100.0" -s coasting_min_volume="0.8" -s prime_tower_enable="False" -s raft_surface_thickness="0.1" -s raft_interface_line_width="0.8" -s machine_disallowed_areas="[]" -s infill_sparse_density="20" -s jerk_support_interface="20" -s support_bottom_distance="0.1" -s raft_surface_layers="2" -s raft_airgap="0.3" -s raft_margin="15" -s brim_line_count="20" -s extruder_prime_pos_z="0" -s acceleration_prime_tower="3000" -s skirt_gap="3" -s extruder_prime_pos_y="0" -s conical_overhang_angle="50" -s retraction_retract_speed="25" -s extruder_prime_pos_x="0" -s support_tower_diameter="3.0" -s retraction_enable="True" -s support_interface_line_distance="0.4" -s raft_acceleration="3000" -s support_bottom_height="1" -s support_interface_enable="False" -s support_join_distance="2.0" -s material_standby_temperature="175" -s support_bottom_stair_step_height="0.3" -s support_xy_distance_overhang="0.2" -s support_xy_distance="0.7" -s wall_line_width_x="0.4" -s raft_base_thickness="0.36" -s support_top_distance="0.1" -s machine_nozzle_tip_outer_diameter="1" -s support_pattern="zigzag" -s support_offset="0.2" -s jerk_travel_layer_0="30.0" -s support_type="everywhere" -s cool_lift_head="False" -s cool_fan_speed_min="100.0" -s retraction_prime_speed="25" -s cool_min_speed="10" -s cool_fan_enabled="True" -s travel_avoid_distance="0.625" -s jerk_print_layer_0="20" -s jerk_support_infill="20" -s raft_interface_fan_speed="0" -s jerk_topbottom="20" -s jerk_wall_x="20" -s acceleration_enabled="False" -s jerk_wall_0="20" -s magic_fuzzy_skin_enabled="False" -s jerk_enabled="False" -s infill_mesh_order="0" -s raft_base_speed="22.5" -s speed_travel="120" -s layer_0_z_overlap="0.15" -s machine_max_acceleration_y="9000" -s acceleration_skirt_brim="3000" -s acceleration_travel_layer_0="5000.0" -s travel_avoid_other_parts="True" -s acceleration_print_layer_0="3000" -s jerk_infill="20" -s acceleration_support_interface="3000" -s raft_surface_jerk="20" -s acceleration_support_infill="3000" -s acceleration_wall_0="3000" -s machine_head_with_fans_polygon="[[-20, 10], [10, 10], [10, -10], [-20, -10]]" -s retraction_combing="all" -s acceleration_infill="3000" -s wireframe_fall_down="0.5" -s speed_equalize_flow_max="150" -s speed_equalize_flow_enabled="False" -s top_bottom_pattern="lines" -s skirt_brim_line_width="0.4" -s cool_fan_full_layer="0" -s cool_min_layer_time_fan_speed_max="10" -s speed_slowdown_layers="2" -s skirt_brim_speed="30" -s support_enable="False" -s conical_overhang_enabled="False" -s speed_travel_layer_0="60.0" -s raft_jerk="20" -s speed_print_layer_0="30" -s raft_interface_thickness="0.15000000000000002" -s infill="0" -s magic_fuzzy_skin_point_dist="0.8" -s coasting_speed="90" -s support_infill_extruder_nr="0" -s speed_prime_tower="60" -s speed_support_infill="60" -s raft_base_jerk="20" -s speed_wall_x="60.0" -s machine_max_jerk_xy="20.0" -s extruder_prime_pos_abs="False" -s gradual_infill_step_height="5.0" -s speed_wall_0="30.0" -s switch_extruder_retraction_speed="20" -s retraction_hop="1" -s retraction_hop_only_when_collides="False" -s retraction_hop_enabled="False" -s acceleration_wall_x="3000" -s coasting_volume="0.064" -s machine_min_cool_heat_time_window="50.0" -s retraction_amount="6.5" -s skirt_line_count="1" -s retraction_count_max="90" -s prime_tower_line_width="0.4" -s machine_max_feedrate_e="25" -s material_flow="100" -s machine_height="300" -s raft_base_acceleration="3000" -s switch_extruder_retraction_amount="16" -s material_bed_temperature="60.0" -s jerk_skirt_brim="20" -s machine_heat_zone_length="16" -s infill_wipe_dist="0.1" -s travel_compensate_overlapping_walls_x_enabled="True" -s infill_overlap_mm="0.04" -s machine_max_acceleration_e="10000" -s infill_pattern="cubic" -s alternate_extra_perimeter="False" -s material_print_temp_wait="True" -s retraction_hop_after_extruder_switch="True" -s speed_layer_0="30" -s raft_surface_speed="30.0" -s skirt_brim_minimal_length="250" -s layer_height="0.1" -s infill_line_distance="6.0" -s machine_name="FDM Printer Base Description" -s z_seam_type="shortest" -s retraction_extrusion_window="6.5" -s xy_offset="0" -s infill_sparse_thickness="0.1" -s speed_topbottom="30.0" -s retraction_extra_prime_amount="0" -s support_area_smoothing="0.6" -s travel_compensate_overlapping_walls_0_enabled="True" -s raft_base_line_width="0.8" -s wireframe_straight_before_down="20" -s support_line_width="0.4" -s acceleration_layer_0="3000" -s retraction_min_travel="0.8" -s machine_start_gcode="G28 ;Home

2016-09-02 17:25:15,677 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G1 Z15.0 F6000 ;Move the platform down 15mm

2016-09-02 17:25:15,677 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] ;Prime the extruder

2016-09-02 17:25:15,678 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G92 E0

2016-09-02 17:25:15,678 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G1 F200 E3

2016-09-02 17:25:15,678 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G92 E0" -s brim_width="8.0" -s wall_0_inset="0" -s raft_surface_fan_speed="0" -s raft_interface_acceleration="3000" -s support_minimal_diameter="3.0" -s machine_max_acceleration_x="9000" -s speed_support_interface="40.0" -s material_print_temp_prepend="True" -s machine_max_feedrate_z="5" -s magic_fuzzy_skin_point_density="1.25" -s wall_line_count="2" -s meshfix_union_all_remove_holes="False" -s material_diameter="2.85" -s top_layers="8" -s support_interface_line_width="0.4" -s wireframe_printspeed="5" -s machine_acceleration="4000" -s support_roof_height="1" -s infill_line_width="0.4" -s machine_max_feedrate_x="500" -s machine_width="200" -s gradual_infill_steps="0" -s machine_show_variants="False" -s skin_line_width="0.4" -s support_z_distance="0.1" -s layer_height_0="0.3" -s wall_line_width_0="0.4" -s acceleration_print="3000" -s machine_heated_bed="True" -s line_width="0.4" -s machine_minimum_feedrate="0.0" -s material_extrusion_cool_down_speed="0.5" -s machine_nozzle_head_distance="3" -s machine_max_acceleration_z="100" -s raft_interface_line_spacing="1.0" -s cool_min_layer_time="5" -s machine_max_jerk_z="0.4" -s machine_use_extruder_offset_to_offset_coords="True" -s machine_nozzle_size="0.4" -s jerk_travel="30" -s jerk_prime_tower="20" -s acceleration_topbottom="3000" -s machine_max_feedrate_y="500" -s meshfix_extensive_stitching="False" -s bottom_layers="8" -s gantry_height="99999999999" -s material_bed_temp_wait="True" -s material_bed_temp_prepend="True" -s machine_depth="200" -s machine_nozzle_cool_down_speed="2.0" -s max_feedrate_z_override="0" -s machine_nozzle_heat_up_speed="2.0" -s support_conical_angle="30" -s brim_outside_only="True" -s meshfix_union_all="True" -s infill_before_walls="True" -s material_flow_dependent_temperature="False" -s adhesion_type="brim" -s support_tower_roof_angle="65" -s cool_fan_speed_max="100.0" -s acceleration_travel="5000" -s machine_nozzle_expansion_angle="45" -s support_use_towers="True" -s support_connect_zigzags="True" -s machine_extruder_count="1" -s machine_head_polygon="[[-1, 1], [-1, -1], [1, -1], [1, 1]]" -s machine_center_is_zero="True" -s wireframe_enabled="False" -s support_interface_pattern="concentric" -s material_flow_temp_graph="[[3.5,200],[7.0,240]]" -s support_xy_overrides_z="z_overrides_xy" -s top_bottom_thickness="0.8" -s support_angle="50" -s machine_gcode_flavor="RepRap" -s switch_extruder_prime_speed="20" -s top_thickness="0.8" -s machine_end_gcode="M104 S0

2016-09-02 17:25:15,678 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] M140 S0

2016-09-02 17:25:15,678 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] ;Retract the filament

2016-09-02 17:25:15,679 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G92 E1

2016-09-02 17:25:15,679 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G1 E-1 F300

2016-09-02 17:25:15,679 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] G28 X0 Y0

2016-09-02 17:25:15,679 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] M84" -s skin_overlap="5" -s speed_infill="60" -s skin_no_small_gaps_heuristic="True" -g -e0 -s extruder_prime_pos_x="0" -s machine_extruder_end_pos_y="0" -s machine_nozzle_offset_y="0" -s machine_extruder_end_pos_x="0" -s machine_extruder_end_pos_abs="false" -s machine_nozzle_offset_x="0" -s machine_extruder_start_pos_y="0" -s extruder_prime_pos_z="0" -s machine_extruder_start_pos_x="0" -s machine_extruder_start_pos_abs="false" -s extruder_prime_pos_y="0" -s machine_name="Extruder" -s extruder_nr="0" -e0 -l "0"

2016-09-02 17:25:17,773 - DEBUG - UM/Backend/Backend.pyc (_backendLog [88]): [backend] Assertion failed: (false && "We should have returned already before here!"), function insert, file /Users/Ultimaker/build/2.3/build/CuraEngine-prefix/src/CuraEngine/src/utils/SparseLineGrid.h, line 112.

2016-09-02 17:25:17,773 - DEBUG - .../cura/plugins/CuraEngineBackend/CuraEngineBackend.py (_onBackendQuit [412]): Backend quit with return code -6. Resetting process and socket.

 

 

 So, it looks like slicing fails when the "machine center is zero" is checked.

 

I just tried this from source and I couldn't reproduce it. Could mean that someone already fixed it. Could you also give me the logs? That way I can verify if your issue is actually solved.

 

Share this post


Link to post
Share on other sites

On the AWESOME side of Cura 2.3:

The Print Time Estimates are rockin!!

After setting my Jerk and Acceleration values in Cura, the time estimates are now within 10% whereas before they were more like 60% :)

E.G: Cura 2.1.x estimated a print time at 50 mins, but would actually take ~80 mins

Now a 50 min estimate takes 55 minutes (sweet!)

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

Reading through the logs I noticed these two (there the same logged twice) are logged every time cura 2.3 beta opens.

 

2016-09-02 22:08:00,062 - WARNING - D:\2.3\build\inst\lib\python3.4\site-packages\cura\Settings\ExtruderManager.py (getMachineExtruders [280]): Tried to get the extruder trains for machine Ultimaker 2+, which doesn't exist.2016-09-02 22:08:00,062 - WARNING - D:\2.3\build\inst\lib\python3.4\site-packages\cura\Settings\ExtruderManager.py (getMachineExtruders [280]): Tried to get the extruder trains for machine Ultimaker 2+, which doesn't exist.

 

Are these entries normal? (printer is not connected to the computer)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy