Jump to content
Ultimaker Community of 3D Printing Experts

dual extrusion Marlin build


Recommended Posts

Posted · dual extrusion Marlin build

Hi,

I have almost finished installing the required mechanics and electronics to

enable dual extrusion on my Ultimaker, which leaves updating the Marlin firmware

as the last hurdle to cross.

Since the marlin-builder server is down, and my knowledge of firmware is fairly limited when it comes to messing with code, can anyone help me to sort out a build of Marlin which will enable the 2nd extruder, thermocouple and heater ?

Thanks in advance

C.

 

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Hi snowygrouch,

    really good question and since i am up to a dual extruder aswell, i am rerally intersted in everything concerning it.

    thought that cura 13.03 has a updated firmware ready for dual extrusion. i just selected "dual extrusion" while running the first-start-wizard. i ended up with an option for a second nozzle in my ulticontroller.

    regards ji

    p.s. how did you level your hotends?!

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Hi,

    Ok I will try the Cura 13.03 firmware as you suggest.

    I didnt install the nozzle yet, when I do - I will add details to the post I already started in the "hacks and modifications" section of the forum. It would be a bit off-topic here.

    Regards

    C.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Cool looking forward!

    Please let me know if cura did the job!

    would be great if we could keep contact via pm on the dual-extrusion.As far as i can remember you have been using kisslicer ever since. I would really love to give it a try on a two color print and someone to discuss the results or upcoming problems migth be a good thing to have!

    Regards

    ji

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Don't be afraid of building your own marlin. It's not that hard. You only have to edit Configuration.h which is 90% comments. Most of the settings are quite simple to understand and are either on/off or have values (e.g. steps_per_mm).

    If you find the dual extruder marlin that comes with cura to need tweaking, just go for it. Then ask specific questions about settings in configuration.h if you get stuck.

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    So unless I am missing something, the beta release of Cura 13.03 is only usable in Linux and not Windows so far ?

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Which beta? 13.03 is available from http://software.ultimaker.com/

    (The version that has a big ass BETA on top is something else)

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Oppps was being retarded and missed that....

    ahaha thanks Daid.

    C.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    So I updated the firmware for 2nd extruder using the Cura 13.03 wizard.

    This now shows up the 2 hotend temps, which I can sucessfully control manually with the UController.

    However not having any luck with either CURA or Kisslicer getting them to USE the 2nd extruder. Both

    are printing support AND main model using only Nozzle #1.

    No idea if this is firmware or software config issue.

    130413 223609

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Just to add the following bugs for the bugslist.

    1) Ulticontroller "cooldown" button only cools down the primary #1 hotend.

    2) Ulticontroller display seems to be a bit wierd since updating the firmware for 2nd extruder...(EDIT ** was due to having USB connected to PC because I was just

    done uploading firmware. Is fine without USB connection)

    3) Fan stays on even after stopping the print.

    4) Display says "printing" even after stopping the print

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    UPDATE.

    Tested 2nd extruder with Kisslicer by selecting extruder 2 to print everything. So the 2nd extruder and

    2nd stepper driver is all "working".

    Dont really know if this is firmware, hardware or software issue now...are there any jumpers to set on the

    UMaker board to enable both extruders at once or something ?

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    I am also getting strange behaviour from Netfabb and KS code since updating the dual extruder firmware from Cura 13.03

    printhead speed is wayyyyyy to fast. I have no idea at all how that can happen. I have to now run KS code at 50% speed from the ulticontroller to make it manageable.

    C.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Ok, so possibly there are also Software issues, BUT I am leaning towards there also being some Firmware issues from that uploaded automatically by Cura 13.03

    Netfabb when USB connected to the Ultimaker, cannot "see" the 2nd extruder. Even though the temperature shows

    in the ulticontroller, and even though I have manually tested that the 2nd extruder "works".

     

    130413 223609

    So you can see here the 2 thermocouples are reading on the display

     

    Netfab No Dual

    Even though both hotends are about 90 degrees, Netfabb when connected cannot read the temp of the 2nd hotend.

    Anyway, Daid can you offer any help here because basically im now at the point where short of building my own Marlin

    I have tried everything. 3 different slicers, and several evenings of messing with the settings of all 3.

    Can you give a link to download windows versions of older Cura versions ? I couldnt see anything on your website or this one....

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Older releases can be found at http://software.ultimaker.com/?show=all at the bottom.

    I'm not sure about dual-extrusion support material. I recommend starting out with dual color just to test things. It's easier to test alignment and retraction settings with dual-color. That should work in 13.03 as I tested it last week. You will have to tweak the nozzle offsets, as I've had multiple dual-extrusion machines to test on, and all needed slightly different offsets.

    As for NetFabb, I do not think they properly support dual-extruders yet. (But all my netfabb knowledge is hearsay)

    As for KISSlicer, no idea here. Most likely works once you have the correct settings and switchover procedures.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Ok,

    Well I am going to have a go at building a firmware myself. Just a question about the config for multiple temps.

    #define TEMP_SENSOR_0 -1

    #define TEMP_SENSOR_1 -1

    #define TEMP_SENSOR_2 0

    #define TEMP_SENSOR_BED 0

    So I am guessing that "TEMP_SENSOR_0" is what I would refer to as the "old" primary extruder....and that

    the new 2nd extruder temp will be "TEMP_SENSOR-1"

    ? Just confused becuase there are 3, and because one starts at Zero which is pretty non-intuitive.

    Anyway just wanting to check.

    Thanks !

    C.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Hi Calum

     

    So I am guessing that "TEMP_SENSOR_0" is what I would refer to as the "old" primary extruder....and that

    the new 2nd extruder temp will be "TEMP_SENSOR-1"

     

    Correct

     

    one starts at Zero

     

    Quite common in computer stuff

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    We silly programmers start at zero (for good reasons, but it looks silly to normal people)

    You need to set the "EXTRUDERS" define to 2 in Configuration_adv.h, else it won't work.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Ah HA !

    Ok, that would certainly be one issue....haha

    Will change the firmware tonight as you suggest and see if anything good happens.

    Thanks !

    C.

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    All working now, built my own firmware and switched to CURA 12.12A

    However next problem is how to set the "steps per e" for extruder 1 and 2 independantly...

    1st Sucess Dual Extrusion - side view (strings removed)

     

    1st Sucess Dual Extrusion - part removed from bed, strings removed

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    Looking at Marlin... I don't think there's a way to define the steps-per-e separately for each extruder. I may be missing something... but it looks like the steps-per-e and the 'flow multiplier' settings in the firmware are just single values, not per extruder.

    So If you really have different steps-per-e, I think you'd need to use some sort of 'per material' extrusion multiplier/packing density adjustment, so that the gcode is already asking for different amounts of material, rather than having the firmware compensate. I suspect Kisslicer can do this - but not sure about Cura.

    Finally, it looks like in Marlin, the current E position isn't tracked separately for each nozzle. So when changing between nozzles the slicer will need to take care of resetting the E position to zero and/or dealing with any retraction and de-retraction issues (assuming that you're using absolute E coordinates). Otherwise, the slicer may end up specifying filament moves based on the position of the 'other' filament.

     

    All working now, built my own firmware and switched to CURA 12.12A

    However next problem is how to set the "steps per e" for extruder 1 and 2 independantly...

     

  • Link to post
    Share on other sites
    Posted · dual extrusion Marlin build

    All working now, built my own firmware and switched to CURA 12.12A

     

    Any luck with netfabb too? If no, I'd appreciate a ticket submission to nf. nf isn't the most responsive software house when it comes to squashing bug but, with your help, they might get it done before I'm ready to go dual! :)

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...