Jump to content
Ultimaker Community of 3D Printing Experts
hermusrudy

What's the problem?

Recommended Posts

Hi,

Since a while my prints look like this. I always used the standard Cura settings (all versions). Coupler, hotend and belts have already been replaced. My printer is the ultimaker 2+. Does anyone have an idea what the problem is here?

Thanks in advance.

.3.thumb.jpg.62fc65fc85ac9cf6987e2a3eba2329ea.jpg2.thumb.jpg.613c1a8fd4ff072bf11803f87cde92d4.jpg1.thumb.jpg.ffd21459d35573df6389338b5670ac34.jpg

3.thumb.jpg.62fc65fc85ac9cf6987e2a3eba2329ea.jpg

2.thumb.jpg.613c1a8fd4ff072bf11803f87cde92d4.jpg

1.thumb.jpg.ffd21459d35573df6389338b5670ac34.jpg

Share this post


Link to post
Share on other sites

It looks like under extrusion but it could be you don't have enough top layers. It's about 50% underextrusion if that's the problem. How many top layers do you have?

If it's doing ugly walls also - with some holes - then it's an underextrusion issue and I'll give you my complete list of possible causes.

  • Like 1

Share this post


Link to post
Share on other sites

It looks like under extrusion but it could be you don't have enough top layers.  It's about 50% underextrusion if that's the problem.  How many top layers do you have?  

If it's doing ugly walls also - with some holes - then it's an underextrusion issue and I'll give you my complete list of possible causes.

 

Thanks for your response.

I use 5 top layers for this print. The walls are not perfect but not as bad as clear underextrusion problems that I can find on this forum.

I have already done some things to counter underextrusion. Changing print settings does help, but my prints are still less qualitative than before.

I would love to hear from you, kind regards.

Share this post


Link to post
Share on other sites

Hi,

wich nozzle do you use?

I would check the line width of top/bottom. 0,35 ? Try a print with increased width.

Also check the Top / bottom thickness. 0,8 ? Also try to increase.

I use a 0.4mm nozzle. The line width stood at 0.35 mm the bottom / top layer at 0.75 mm.

This print (see photo) shows the line width at 0.4 and the bottom / top layer at 1mm.

There is some improvement but it is still not as it should be.

Thank you for the reply.

4.thumb.jpg.4c94ba440b118f498f95c4db36ea47ca.jpg

Share this post


Link to post
Share on other sites

Okay. Well underextrusion is not so obvious on walls. It still looks like underextrusion so here's my list. Look through it. If your printer worked fine for a while but then started doing this then it's probably #3.

CAUSES FOR UNDEREXTRUSION AND HOW TO TEST FOR THEM AND REMEDY THEM

As far as underextrusion causes - there's just so damn many. none of the issues seem to cause more than 20% of problems so you need to know the top 5 issues to cover 75% of the possibilities and 1/4 people still won't have the right issue. Some of the top issues:

1) Print slower and hotter! Here are top recommended speeds for .2mm layers (twice as fast for .1mm layers) and .4mm nozzle:

20mm/sec at 200C

30mm/sec at 210C

40mm/sec at 225C

50mm/sec at 240C

The printer can do double these speeds but with huge difficulty and usually with a loss in part quality due to underextrusion. Different colors print best at quite different temperatures and due to imperfect temp sensors, some printers print 10C cool so use these values as an initial starting guideline and if you are still underextruding try raising the temp. But don't go over 240C with PLA.

2) Shell width confusion. Shell width must be a multiple of nozzle size (in cura 15.X. In cura 2.X it doesn't matter as much but still makes a difference). For example if nozzle size is .4mm and shell width is 1mm cura will make the printer do 2 passes with .5mm line width which is possible but requires you to slow down much more to make a .5mm line out of a .4mm nozzle. If you really want this then set nozzle size to .5mm so it's clear what you are asking Cura to do for you.

3) Isolator - this is most common if you've printed extra hot (>240C) for a few hours or regular temps (220C) for 500 hours. It gets soft and compresses the filament under pressure. It's the white part touching the heater block. It's very hard to test when not under full pressure (spring and bowden) so sometimes it's best to just replace it. Also if you notice parts of it are very soft (the blacker end where it touches higher heat) then it's too old and needs replacing.

4) Curved filament at end of spool - if you are past half way on spool, try a fresh spool as a test.

5) curved angle feeding into feeder - put the filament on the floor -makes a MASSIVE difference.

6) UM2 only: Head too tight? Bizarrely MANY people loosen the 4 screws on the head by just a bit maybe 1/2 mm and suddenly they can print just fine! Has to do with pressure on the white teflon isolator.

6b) UM2 only: Bowden pushing too hard - for the same reason you don't want the bowden pushing too hard on the isolator.

6c) Um2 only: Spring pushing too hard. Although you want a gap you want as small as possible a gap between teflon isolator and steel isolator nut such that the spring is compressed as little as possible.

7) clogged nozzle - the number one problem of course - even if it seems clear. There can be build up on the inside of the nozzle that only burning with a flame can turn to ash and remove. Sometimes a grain of sand gets in there but that's more obvious (it just won't print). Atomic method (cold pull) helps but occasionally you need to remove the entire heater block/nozzle assembly and use flame. I found soaking with acetone does not help with caramelized pla. Even overnight. Maybe it works on ABS though.

8) Temp Sensor bad - even the good ones vary by +/- 5C and bad ones can be any amount off - they usually read high and a working sensor can (rarely) fail high slowly over time. Meaning the sensor thinks you are at 220C but actually you are at 170C. At 170C the plastic is so viscous it can barely get out of the nozzle. You can verify your temp sensor using this simple video at youtube - on you tube search for this: mrZbX-SfftU

9) feeder spring issues - too tight, too loose. On the black UM2 feeder you want the tension such that you can clearly see the diamond pattern biting into the filament. You want to see at least 2 columns of diamonds. 4 columns is too much. On the white UM2 plus and UM3 feeders you usually want the tension set in the center.

10) Other feeder issues, one of the nuts holding UM2 and UM3 together often interferes with the feeder motor tilting it enough so that it still works but not very well. Other things that tilt the feeder motor, sleeve misaligned so it doesn't get a good grip. Gunk clogging the mechanism in there.

11) Filament diameter too big - 3mm is too much. 3mm filament is usually 2.85mm nominal or sometimes 2.9mm +/- .05. But some manufacturers (especially in china) make true 3.0mm filament with a tolerance of .1mm which is useless in an Ultimaker. It will print for a few meters and then clog so tight in the bowden you will have to remove the bowden from both ends to get the filament out. Throw that filament in the trash! It will save you weeks of pain

11b) Something wedged in with the filament. I was setting up 5 printers at once and ran filament change on all of them. One was slowly moving the filament through the tube and was almost to the head when I pushed the button and it sped up and ground the filament badly. I didn't think it was a problem and went ahead and printed something but there was a ground up spot followed by a flap of filament that got jammed in the bowden tube. Having the "plus" upgrade or using the IRobertI feeder helps you feel this with your hand by sliding the filament through the bowden a bit to see if it is stuck.

12) Hot weather. If air is above 30C or even possibly 25C, the air temperature combined with the extruder temperature can soften the filament inside the feeder such that it is getting squeezed flat as it passes through the feeder - this is obvious as you can see the problem in the bowden. The fix is to add a desk fan blowing on the back of the printer. Not an issue on the UM3 or UM2 "plus" series.

13) Crimped bowden. At least one person had an issue where the bowden was crimped a bit too much at the feeder end although the printer worked fine when new it eventually got worse and had underextrusion on random layers. it's easy to pull the bowden out of the feeder end and examine it.

14) Worn Bowden. After a lot of printing (or a little printing with abrasive filaments) the bowden resistance can be significant. It's easy to test by removing it completely from the machine and inserting some filament through it while one person holds it in the U shape. Preferably i nsert filament that has the pattern from the feeder.

15) Small nozzle. Rumor has it some of the .4mm nozzles are closer to .35mm. Not sure if this is actually true. I'm a bit skeptical but try a .6mm nozzle maybe.

16) CF filament. The knurled sleeve in the extruder can get ground down smooth - particularly from carbon fill. 4 spools of CF will destroy not just nozzles but the knurled sleeve also. Look at it visually where the filament touches the "pyramids". Make sure the pyramids are sharp.

17) Hot feeder driver. I've seen a more recent problem in the forums (>=2015) where people's stepper drivers get too hot - this is mostly a problem with the Z axis but also with the feeder. The high temps means the driver appears to shut down for a well under a second - maybe there is a temp sensor built into the driver chip? The solution from Ultimaker is that they lowered all the currents to their stepper drivers in the newer firmware. Another solution is to remove the cover and use desk fan to get a tiny bit of air movement under there. TinkerMarlin lets you set the currents from the menu system or you can send a gcode to lower the current. Ultimaker lowered the default currents in July of 2015 from 1300ma to 1200ma for X,Y,Z but left extruder at 1250. Other people (I think the support team of a major reseller but I forget) recommend X,Y,Z go down to 1000mA.

M907 E1250

Above sets the extruder max current to the default - 1250mA. So try 900mA. This will only change until next power cycle so if you like your new value and want to save it use M500. You can just put these into an otherwise empty gcode file and "print" this and it will change. Or get tinkergnome marlin! You will wonder how you lived without it: https://github.com/TinkerGnome/Ultimaker2Marlin/releases

M907 E900

M500

18) third fan broken. This tends to cause complete non-extrusion part way through a print. In the rear of the head for UM2 and the front of the head for UM3. Without this fan several things can go wrong. It can take a while as usually you also need several retractions to carry the heat upwards. There are a few failure mechanisms and I don't understand them all. One of them is probably that the molten PLA spreads out above the teflon and sticks to the metal in a core or fills the gap at the base of the bowden in UM2. Later it cools enough to keep the filament from moving up or down.

19) Spiralize/vase mode. This is a rarely used feature of Cura but you might have left it on by accident? In this mode the wall of your part is printed in a single pass. So if you have a .4mm nozzle and the wall is .8mm thick it will try to over extrude by 2X. This is difficult to do and may instead lead to underextrusion.

20) non-standard or bent fan shroud. Sometimes people print some fan shroud off of thingiverse or youmagine out of PLA or ABS. Some of these are great but most of them are crap. One needs to do good air flow modeling. Also if it's PLA it will slump and direct air differently. Air directed at the block or nozzle can cause severe underextrusion and also sometimes HEATER ERROR. Put the original shroud back on or just turn off the fan to prove that the fan is the problem.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!