Jump to content
Ultimaker Community of 3D Printing Experts

Printcore not recognized

Recommended Posts

My printer was working fine yesterday. The BB core got jammed, so I took it out, cleaned it up, and was going to put it back in, when I noticed that the spring that pushes the printcore down had sprung out of place. So, I took the entire print head off of the rails and disassembled it so I could get the spring back into place. I also took out the AA core at this time to clean it up. I put it all back together again, and there seemed to be no problems until I tried to load the printcores back into place. Right now, for both printcores, the screen on the printer says "empty slot", which it should, since there aren't any print cores in there. 


The problem arises when I tell it to "Load" either printcore. When I press this button, the machine will home itself out, then ask me to lower the fan bracket (the blue light turns on as well). I press confirm, and the screen prompts me to press the core in place. When I do this, the printer must recognize it, because the light turns orange and it asks me to close the bracket again. The printer then homes itself out again and all seems fine until it still says "empty slot" when I look at the printcore/material selections on the screen. 


The exact same thing happens to both printcores. I have cleaned the connections in back of the print cores with isopropyl alcohol, tried restarting the machine, and repeating the printcore installation process a few times. 

Share this post

Link to post
Share on other sites

Yeah, I think the cable would be my first suspect as well. And by cable I mean more the contact and/or the individual pins in case one of them has managed to work itself loose.


It's unlikely you managed to damage both cores so I would probably rule that out. And it's not really possible to assemble the head with the print head board in the wrong position causing a bad connection.


And from the sounds of it, it's happening when the print head is homed, when there's the most stress on the cable.

Share this post

Link to post
Share on other sites

Thanks for the feedback.


I unplugged the main cable and plugged it back in, trying to make sure it stayed together as I screwed the top back on and that didn't seem to change anything. However, I discovered that when I push the printcore back manually with my fingers, it recognizes that there is a printcore in there. I'm assuming somehow the pcb is pushed back to far since it's unlikely that both printcores are just not going back far enough. 


The pcb seems to be mounted in the correct place. The pegs are in the holes on the board, and the tab at the bottom of the board is also set into place. Is it possible that I have it screwed too tightly and it's pulling the pcb back too far?

Share this post

Link to post
Share on other sites

I haven't tried cranking on the screw to see what happens so I'm not sure if that would be possible. In general the screws on an UM3 are tightened fairly "loosely". For the head it's 0.3Nm IIRC. Doesn't feel like something that would happen though unless there's very little margin for error for the spring fingers of the contacts in the head.


I can't say I've had any customers with this particular problem so it's a bit difficult to diagnose without getting my hands on it to be honest.

Share this post

Link to post
Share on other sites

There are 5 pins.  Two of them go to the temp sensor and that is enough for the printer to know that there is a core loaded.  The middle pin goes to the eeprom.  If that is an "open" then the printer will think the slot is empty yet turn on the LEDs at the same time I believe.


In addition you should loosen the top screw on the BB core (the one through the clear part) and recenter the circuit board left/right so it feels centered.  Do not try to loosen the screw on the heater block!  You will almost certainly destroy the core instantly if you do that as the heat break takes almost no force to break the heater block from the rest of the core.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Introducing Ultimaker Cura 3.6 | Beta
      Ultimaker Cura 3.6 | Beta is available. It comes with new features, bug fixes, and UX improvements. We would really like to have your feedback on it to make our stable release as good as it can be. As always, you can download the beta for free from our website, for Windows, MacOS, and Linux.
        • Like
      • 92 replies
    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
        • Thanks
      • 30 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!