Jump to content
payette

Ultmaker 2 extruder running backwards?

Recommended Posts

Posted · Ultmaker 2 extruder running backwards?

I've got two problems, but I want to solve the first before attacking the second.  My extruder is running backwards.  

Share this post


Link to post
Share on other sites
Posted · Ultmaker 2 extruder running backwards?

lol.  You probably have the wrong firmware.  The UM2 and the UM2+ feeders run in opposite directions.  So you probably got the wrong firmware.  Also do a "factory reset" as sometimes when you downgrade or cross-grade the firmware it doesn't carry forward the eeprom values and a "factory reset" fixes this so that you have the correct directions for all the extruders.

 

ALSO

 

Seriously consider getting the tinker firmware instead of the Ultimaker version.  The tinker version is much better with amazing features like the ability to reverse the feeder without installing different firmware and the ability to continue a failed print and much more.

 

Tinker marlin is here:

https://github.com/TinkerGnome/Ultimaker2Marlin/releases

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited) · Ultmaker 2 extruder running backwards?

You have probably flashed the wrong firmware, ie the firmware for the UM 2+ instead of the UM 2. Flash the proper firmware for your printertype and it should work correctly again.

 

edit: @gr5 beat me to it.

Edited by ahoeben
  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultmaker 2 extruder running backwards?

I really appreciate your responses, but I'm still not getting this too work.

 

first I reset the unit to factory resets - still backwards

 

second I redownloaded and reloaded U2 firmware - still backwards

 

third As a test I downloaded U2+ to see if that reverses the extruder - still backwards

 

Fourth  I tried the marlin alternative firmware - still backwards

 

Fifth.....I don't know.  I'm getting the firmware from github....I assume that is the right location.

 

Any ideas are appreciated

 

Share this post


Link to post
Share on other sites
Posted · Ultmaker 2 extruder running backwards?

Cura comes with firmware for both the UM2 and UM2+. Try those.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!