Jump to content
Ultimaker Community of 3D Printing Experts

Slicing Probleme


eddie_teddie
 Share

Recommended Posts

Posted · Slicing Probleme

Hallo zusammen,

 

ich habe ein Object das sich beim Slicen komisch verhält. Es ist eigendlich nichts anderes als eine Röhre. Aber wen ich die Röhre Aufrecht Slice werden die Enden geschlossen. Slice ich die Röhre liegend ist alles OK. Die Liegende Form ist halt schwieriger zu Drucken. Hat jemand ne Idee wie ich Cura das ausreden kann.

 

Das Problem tritt übringends auch mit anderen Slicern auf. Die miesten wie Cura, anere haben nur eine Seite geschlossen, andere Bekommen die Form nicht so hin.

 

Danke schonmal im Vorfeld

image.png.1335092ab559d91234d5f89d8d92b766.pngimage.png.53467c21f3d779898d7f0606399752da.png

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Hast du mal mit dem Windows 10 integrierten 3D Builder geschaut ob es vielleicht Fehler im Modell gibt. Der 3D Builder kann die teilweise auch recht gut reparieren, wenn er einen Fehler gefunden hat.

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Hallo,

     

    Also du hast eindeutig ein Model Problem, den die Flächen die bei dir rot sind zeigen dir den Überhang an, ein Überhang ist aber unten bei dir ist er oben.

    Das heißt das deine Flächen die falsche Ausrichtung haben

     

    Ich will nicht raten (falls du es selbst erstellt hast) mit welchen Programm du dies gemacht hast, ist es aber sketchup?😎

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Ich habe das Objekt selber erstellt und in einer vereinfachten Form auch alles meines erachtens nach richtig zugeordnet. Wenn ich ein Fehler im Modell habe muss ich den Beseitigen.

    Was ich aber nicht verstehe ist das dieser Fehler nur "Stehend" zum Tragen kommt, nicht aber "Liegend"

    Ich werde mir mein Programm nochmal genau anschauen. Danke für den Tip

     

    Erik

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Hallo Erik 

     

    Lade das Modell mal hoch, dann kann ich es mir heute Abend anschauen und dir sagen was falsch ist. Auch wenn ich mir schon denken kann wo der Hund begraben liegt ^^

     

    Grüsse

    zpm3atlantis

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Hallo, das ist nett.

     

    Ich habe dir ein einfacheres Objekt erstellt, was das selbe Problem hat. Nicht das fast 2000 Zeilen fassenede Objekt am Anfang. Alle drei Bilder zeigen das Objekt. Nur einmal zum Slicen um 90° gedrehtimage.thumb.png.93297f6961d036d42b084e94dfb00eb6.pngimage.thumb.png.10d3f89f8504d6c6dc8251cff50818e4.pngimage.thumb.png.b5381c6603709a7f6b19974c1ad3070e.png

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    HiHo

    Also ich meinte das 3D Modell als stl, denn dein Problem sieht danach auch, das es Fehler im 3D Modell gibt.

     

    Grüsse

     

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Übrigens: Es ist kein Wiederspruch, wenn der Slicer beim Drehen einmal ohne "Deckel" und einmal mit  "Deckel" es generiert. Das kommt sehr wohl vermutlich von der STL. Ursächlich ist, dass der der Slicer nicht mehr Außen und innen unterscheiden kann. Er analysiert von einem bestimmten Bezugspunkt aus. Wenn du das Objekt drehst, ändert sich damit auch der Bezugspunkt und damit auch die Fehlerposition zum Bezugspunkt. Führt zu anderer Interpretation und damit anderem Ergebnis...

    So, wie wenn du eine Platte mit 3 Bohrungen versuchst, auf 3 Bolzen zu schieben. Stimmt nur einer davon nicht, wird es nicht gelingen. Aber du wirst von allen 3 Punkten abwechselnd anfangen können und es wird jedesmal ein anderer "Falsch" in der Flucht sein. Welcher es aber wirklich ist, wirst du erst feststellen können, wenn du alle 3 zueinander vermißt.

    Es gibt Programme, die extrem beliebt sind, aber genauso prädistiniert für solche Fehler beim Exportieren, in STL, sind.

    Daher fragte Zerspaner_Gerd auch, welches Programm, bzw. ob es zufällig in Sketchup erstellt wurde. Nur weil es bei Erstellung super aussah, heißt es eben nicht, dass es auch "Wasserdicht" exportiert wird/wurde. Das war auch der Grund dafür, dass ich nicht mehr mit DesignCad arbeite (für bestimmte Sachen schon, weil ich da bestimmte Sachen recht schnell und einfach machen und in Konturen Bezugspunkte rauslesen kann, aber für den 3D Druck an sich nachher eben nicht).

    Der Gcode oder die Cura-Datei hilft da nicht viel! Auch Bilder nicht. Zpm3atlantis nütz da wirklich nur die STL an sich. Nur dort sieht man in der Fehleranalyse, wo der Hund begraben ist... In Cura siehst du eben nur die roten stellen, die schon darauf hin deuten - in der Ausrichtung. 

     

    Gruß, Digibike

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Hallo, sorry hab evergessen die Datei mit hochzuladen, es ist aber eine selbsterstellte Object Datei. Sketchup war da nicht involviert.

    Ich dachte immer das rote wären "Stresspunkte"

     

    Danke und Grüße

     

    text.obj

  • Link to post
    Share on other sites

    Posted · Slicing Probleme
    15 hours ago, Digibike said:

    Ursächlich ist, dass der der Slicer nicht mehr Außen und innen unterscheiden kann.

     

    Ich glaube @Digibike ist auf der richtigen Spur. Schätzungsweise die Hälfte der Dreiecke zeigt mit der Innenseite nach außen.

     

    Wenn ich das obj-Format bei Wikipedia richtig verstehe, ist also entweder die Reihenfolge der Vertices falsch oder es müssen zusätzlich Normalen definiert werden.

     

     

    text.thumb.png.a5efef55e5f52383f41c20fd75a8e0f6.png

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Mit was hast du es den erstellt, @Eddie_Teddy?

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    Ich habe die Form selber Programmiert mit PHP.  Ich benötige einige kompliziertere sich wiederholende Körper die einfach per Eigenschaften zu verändern sind.

     

    Deine Problematik kann ich ansatzweiße verstehen, aber wie kann ein Dreieck im Raum eine Innenseite und eine Aussenseite haben? Ich wüsste gerne was ich da falsch gemacht habe.

     

    Ich habe mir den Meshmixer jetzt mal runtergeladen und versuche mitdessen Hilfe Die Probleme zu finden

     

     

  • Link to post
    Share on other sites

    Posted · Slicing Probleme

    OK ich hab mal nachgelesen das ich am besten den normalvektor mit angeben muss. Hat jemand einen gute Link wie man den Berechnet?

    Das dies bei Oberflächentexturen benötigt wird verstehe ich ja noch, aber warum beim 3D Drucker.

     

    Danke für eure Hilfe

     

    Erik

  • Link to post
    Share on other sites

    Posted · Slicing Probleme
    5 hours ago, eddie_teddie said:

    OK ich hab mal nachgelesen das ich am besten den normalvektor mit angeben muss. Hat jemand einen gute Link wie man den Berechnet?

     

    mal sehen...

    Hier ist die Mathematik:

    https://math.stackexchange.com/questions/305642/how-to-find-surface-normal-of-a-triangle

     

    ...und hier (u.a.) eine php-Funktion zur Berechnung von Kreuzprodukten:

    https://www.geeksforgeeks.org/program-dot-product-cross-product-two-vector/

     

    6 hours ago, eddie_teddie said:

    Das dies bei Oberflächentexturen benötigt wird verstehe ich ja noch, aber warum beim 3D Drucker.

     

    Das liegt wahrscheinlich nicht grundsätzlich an fehlenden Normalvektoren, sondern daran, das sich in deinen Modellen die Innen- und Außenflächen berühren, aber trotzdem eine gemeinsame Fläche bilden sollen....

    Das versucht Cura irgendwie zu reparieren... mit wechselndem Erfolg....

     

    Im Abschnitt "Mesh Fixes" ist standardmässig die erste Option aktiviert ("Union overlapping volumes"). Wenn die ausgeschaltet wird, sieht es schon besser aus.

     

    test1a.thumb.png.562046440063c454e2788549c21d5aa5.png

     

    Viel Erfolg!

     

     

  • Link to post
    Share on other sites

    Posted (edited) · Slicing Probleme

    Hi zusammen,

     

    hatte gerade das gleiche Problem. Eine Art Röhre die stehend immer gefüllt wurde und liegend okay war. Habe nun an den Rändern oben und unten einen Loop Cut im Modell hinzugefügt -- und es funktioniert. Ich kann die Röhre nun stehend drucken. Hoffe es hilft jemandem. Grüsse Rene

    Edited by renehaegeli
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...