Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up
alegomo98

Reducing stair stepping effect on round surfaces

Recommended Posts

Posted (edited) · Reducing stair stepping effect on round surfaces

Hello!

 

I've been trying to print a half sphere using Cura and an Ultimaker 3. Because it is used in a friction pairing, it needs to have a really smooth surface, with (ideally) no stair stepping effect.

 

The first thing I tried was using fine layers, with a height of 0,1 mm. The chosen material was ABS, so it could be chemically smoothed with acetone. After the finishing process, the sphere was looking good on the lower layers, but nearing the top it still had noticeable stair steps. Not only that, but the very top of the print had a bad finish, right where the printer stops extruding. The remaining filament creates a really annoying tip that doesn't get smoothed out with the acetone vapor.

 

I decided to try out Cura's ironing feature, having had success removing the aforementioned tip with an Ender 3. It hasn't worked out at all with the Ultimaker 3, I get awful finishes when the ironing feature is enabled. I've tried turning the ironing flow off, changing the pattern from concentric to zig-zag and nothing seems to work well. 

 

Recently I've had better looking spheres with a layer height of 0,06 mm, but the top isn't quite working as I would like it to.

 

Has anyone had similar problems with their finishes? Any tips regarding stair stepping reduction on round surfaces would be very useful.

 

These are my print settings. Ironing is not enabled, because I haven't had any success with it. Support is enabled because the specific model I'm working with requires it. It doesn't affect the sphere's surface, though. I also have ASA, PLA, iglidur I-180 and Polysmooth at my disposal, with their respective chemicals/finishing tools.

 

Thank you for your time!

 

image.png.73e1379fb163c7be64af1dd695a837f8.png

image.png.e66a16fc2441d904b462ad8066793e6c.png

image.png.791a21f84998949b410cd2b09978b3d2.png

image.png.ee57b9db7bdf837f38fcbde49ed06dd1.png

 

 

image.png

 

image.png

Edited by alegomo98

Share this post


Link to post
Share on other sites
Posted · Reducing stair stepping effect on round surfaces

And now you're learning differential calculus and why PI is a never ending fractional number.

At the top of the sphere the angle of a tangent line starts to approach 0 degrees.  Cura considers the area under the nozzle as a rectangle with 90 degree sides.  When it calculates a layer, it pushes the rectangle up against the side of the sphere.  When it calculates the next layer it can't slide the rectangle over quite as far.  That leaves a little gap that is your step.  Lowering the layer height is all you can do.  If the layer height was .00001mm you would still have a step.  It would be a really small step, but it would be there.  As the layer height approaches zero the step width approaches zero but it never can get there.

The same thing happens on inclined surfaces but the steps are all the same size and are all triangular when viewed as a cross section.

Share this post


Link to post
Share on other sites
Posted · Reducing stair stepping effect on round surfaces

For this i use adaptive layers, with a minimum of 0.06mm. (this is the minimum i print)

These settings are (hidden?) under experimental. If you want to vary between 0.06mm an 0.2mm, set the normal layer height at 1.3mm and the layer max variation at 1.4mm. This is just an example, but it would be settings for a globe.

Can you change the layout of the parts?

For friction parts, i always try to print 1 of the touching parts without layers (Z flat)

For rounds i would print 1 horizontal an 1 vertical.

Ps, ironing is something to avoid in many situations, especially with fine layers.

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Reducing stair stepping effect on round surfaces

Well there is some hope that in some future this feature will become usable:

 

Actually most of our 3D printers are "only" 2.5D. They make their moves on a flat surface, then move up again and make a layer and so on... Real 3D would be simultaneous move of the Z axis while X and Y is printing. But this is far more complex than 2.5D... (Colisions, calculation and so on...).

I never tried this kind of printing and won't do so before this has become more easy to use.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Reducing stair stepping effect on round surfaces
15 hours ago, RudydG said:

For this i use adaptive layers, with a minimum of 0.06mm. (this is the minimum i print)

These settings are (hidden?) under experimental. If you want to vary between 0.06mm an 0.2mm, set the normal layer height at 1.3mm and the layer max variation at 1.4mm. This is just an example, but it would be settings for a globe.

Can you change the layout of the parts?

For friction parts, i always try to print 1 of the touching parts without layers (Z flat)

For rounds i would print 1 horizontal an 1 vertical.

Ps, ironing is something to avoid in many situations, especially with fine layers.

 

Thanks for the reply!

I sadly cannot change the part's orientation, which would indeed make things easier. I will try the adaptive layers out! I need the layers to be really thin throughout the whole print, though, for the acetone vapor to work its magic.

Share this post


Link to post
Share on other sites
Posted · Reducing stair stepping effect on round surfaces
2 hours ago, Curven said:

Well there is some hope that in some future this feature will become usable:

 

Actually most of our 3D printers are "only" 2.5D. They make their moves on a flat surface, then move up again and make a layer and so on... Real 3D would be simultaneous move of the Z axis while X and Y is printing. But this is far more complex than 2.5D... (Colisions, calculation and so on...).

I never tried this kind of printing and won't do so before this has become more easy to use.

 

That thought also crossed my mind. Even though I was able to set everything up with an Ultimaker 2+ and Slic3r, I've been having a lot of trouble generating good nonplanar prints. The nozzle collides with the print, it extrudes unnecessary amounts of material at certain points and kinda drags along the print's surface. I've been using a 0,8 mm nozzle (on the Ultimaker 2+) for the nonplanar prints, so maybe that's a reason for the roughness of my results. Printing a sphere has been even worse, with some layers protruding from the prints surface in the areas nearing the nonplanar layers.

 

I think nonplanar prints would most likely solve my problems, but I haven't had any luck with mine.

IMG_20200616_101351359.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...