Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
guy

The "Pause at height" plugin in Cura does not function on UM2

Recommended Posts

Does your safe position close to the end stop switch ? IT might be a problem.

Make sure your safe zone is not triggering any switches.

I am also concerned about this plugin, not so much by it not working (it works fine with my marlin board) but inability to set layer # insteaf of the height.

Looking at the layers # i can tell exactly where i need to pause the print, but using height pause is not as effective.

I need layer # pause to embed objects such as nut or somethign else inside the model and then print over it. I cant do it at the height, does not seem to work because print settings making it hard. There could be raft that i would not concider or somethig else.

Also why typing here with firefox spellcheck dont work ?

 

Share this post


Link to post
Share on other sites

https://raw.github.com/Dim3nsioneer/Cura-Plugins/master/TweakAtZ.3.0.1.py

this one is working just fine for me on my UM2 in Cura 13.12

 

Very odd. I downloaded the plugin from that link just now, installed it in the proper directory (moving the existing one elsewhere so it wouldn't be found), and tried it, and it still isn't working. I downloaded Cura 13.12 (I had been running 14.01), still nothing. I've made sure to select RepRap G-code generation in the Machine Settings. Not sure what I'm missing or if this is just a bug. I'm just asking it to lower the speed at 5mm from 40 mm/s to 13 mm/s (something I can easily search for manually), but it stays at 40mm/s the whole time. Kind of a bummer, TweakAtZ and PauseAtZ both seem really useful to me but it appears that neither works on my system for some reason.

Edit: Mac OS X 10.9.1

 

Share this post


Link to post
Share on other sites

Very odd. I downloaded the plugin from that link just now, installed it in the proper directory (moving the existing one elsewhere so it wouldn't be found), and tried it, and it still isn't working. I downloaded Cura 13.12 (I had been running 14.01), still nothing. I've made sure to select RepRap G-code generation in the Machine Settings. Not sure what I'm missing or if this is just a bug. I'm just asking it to lower the speed at 5mm from 40 mm/s to 13 mm/s (something I can easily search for manually), but it stays at 40mm/s the whole time. Kind of a bummer, TweakAtZ and PauseAtZ both seem really useful to me but it appears that neither works on my system for some reason.

Edit: Mac OS X 10.9.1

 

At which height do you want TweakAtZ to change the speed?

EDIT: Sorry, I overlooked the 5mm... So you put 32.5 into the speed box, correct? There are other people claiming Cura doesn't execute a plugin or that it works sometimes and sometimes not. The only thing I can recommend from the distance is to close Cura, reopen it and check it again.

 

Share this post


Link to post
Share on other sites

At which height do you want TweakAtZ to change the speed?

EDIT: Sorry, I overlooked the 5mm... So you put 32.5 into the speed box, correct? There are other people claiming Cura doesn't execute a plugin or that it works sometimes and sometimes not. The only thing I can recommend from the distance is to close Cura, reopen it and check it again.

I tried changing speeds at 5mm, but I've also tried a number of them in a row (like 5mm, 10mm, 20mm) in the same print, and changing other settings like extruder temperature.

I actually didn't notice that the speed was in percent, so I had put 13%. That ought to come out to 5.2mm/s though, which should still work fine, right? I tried other numbers as well, higher and lower, and the G1 feed rate doesn't change from the 2400 mm/m (40 mm/s). I've closed and re-opened and even rebooted the machine with no improvement. Hopefully I can figure out a workaround, this would be a handy feature.

 

Share this post


Link to post
Share on other sites

I'm in the middle of a long print so I can't verify this on the machine, but I rebooted and started fresh and it looks like the G-code does now have references to TweakAtZ in it. I didn't realize that the plugin doesn't actually change the feed rate parameter directly ("G1 F*"), rather it invokes another M-code (M220 IIRC, new one on me) to adjust it indirectly. So it's very likely that the combination of this misunderstanding, and my prior overlooking of the minimum layer time clamping the feed rate, is responsible, and everything is working as it was designed. I'll verify this when I get a chance, but I believe things are probably working fine.

Thanks everyone for putting up with my noobishness again! ;)

 

Share this post


Link to post
Share on other sites

I'm in the middle of a long print so I can't verify this on the machine, but I rebooted and started fresh and it looks like the G-code does now have references to TweakAtZ in it. I didn't realize that the plugin doesn't actually change the feed rate parameter directly ("G1 F*"), rather it invokes another M-code (M220 IIRC, new one on me) to adjust it indirectly. So it's very likely that the combination of this misunderstanding, and my prior overlooking of the minimum layer time clamping the feed rate, is responsible, and everything is working as it was designed. I'll verify this when I get a chance, but I believe things are probably working fine.

Thanks everyone for putting up with my noobishness again! ;)

You found it... :wink:

The plugin doesn't change any F-commands. But if you have set the flavor to 'RepRap' and put a different setting into the 'Flow' box in the basic settings tab in Cura, then this will change the F-Codes. So if you want to start with e.g. 90% and then switch to 100% flow, you should not put the 90% into the flow box but add a M220 S90 statement in your start.gcode. Or you put the 90% flow into the basic settings and put 111% into the plugin flow box in order to get again 90% * 111% = 100%.

I guess I just have removed any clearness... :wacko:

 

Share this post


Link to post
Share on other sites

I'm a little nervous to try to fix this, but this appears to be the problem:

#define ENABLE_ULTILCD2

is defined but not:

//#define ULTIPANEL

and the M0 and M1 code are on #ifdef ULTIPANEL

I haven't looked further if there is special LCD code that has to be written for this, as I don't know if the UI is differerent for ULTIPANEL and ULTILCD2

Is it easy to rebuild the firmware (I'm a pretty techy guy)? and not brick my ultimaker2?

 

Share this post


Link to post
Share on other sites

I don't know if the UI is differerent for ULTIPANEL and ULTILCD2

 

Very different. I think Daid just hasn't implemented this yet :(

I think there are also M codes to make a BEEP sound and M codes that introduce a sleep/pause. I'm sure those still work on UM2 (scroll way down for M codes):

https://github.com/ErikZalm/Marlin/

Above link is the REAL Marlin. The one being updated by volunteer hobbyists every week. Daid's custom fork for the UM2 was based on the erikZalm version.

 

 

Share this post


Link to post
Share on other sites

Maybe the 'old' M codes work if the flavor is set to 'RepRap'? I could imagine that the flag ';UltiGCode' defines the set of codes used by UM2Marlin. But it's just a shot in the dark, without having a serious look at any Marlin code... But for the time being it might be a way to use the plugin?

 

Share this post


Link to post
Share on other sites

The M0 and M1 code are more complicated - it requires a message to appear on the controller. And you have to push the button to continue. Also it moves the head I think maybe up a few mm?

Anyway the point is that the UM2 has a totally different controller and all the messages were changed as far as I can tell and maybe Daid needs to change that piece of code before M0 and M1 will once again work on UM2.

Whereas most of the M codes required zero code changes for the UM2.

 

Share this post


Link to post
Share on other sites

Yeah, it turns out it doesn't really work anymore in the arduino environment without hacking up one of the builtin arduino libraries (twi.c)

I've got it compiling now, but I'm not sure I've not broken i2c.

I'm trying to set up the command line environment now.

Maybe I can make some instructions, and it can be made sticky in the Marlin section?

 

Share this post


Link to post
Share on other sites

I filed an issue on github, and daid replied:

 

The M0 and M1 currently only work in the old LCD implementation (UM-Original / RepRap menus)

The ULTIPANEL define is for the old menus, and should not be mied with the ENABLE_ULTILCD2, you can however, disable ENABLE_ULTILCD2 and enable ULTIBOARD_V2_CONTROLLER, this will set the old menus on the new OLED display.

It's on my list to fix this, as well as to add a proper pause function.

 

Since I have command line compiling running now, I thought I'd give it a try. It does work but man, the old menus aren't as useable or nice as the new ones (and it's easy to mess up a print.)

I think I'll wait until daid gets to it, unless I'm really trying to avoid important work :) and in the meantime, there is a workaround if I absolutely need to do pause at height.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!