Jump to content
Ultimaker Community of 3D Printing Experts

PID Werte für 35W Patrone


Recommended Posts

Posted · PID Werte für 35W Patrone

Ich habe vor kurzem eine Thread im Tinkergnome GitHub gestartet, aber ich kriege keine Antworten mehr darauf, ob der 35W Wert korrekt ist oder ob da eine Zahl fehlt.

 

Quote

25W PID 10, 2.5, 100
35W PID 8, .5, 33 (neotko recommends)
40W PID 6.5, 1.5, 60
50w PID 5, 1.2, 50

 

Ich hatte komischerweise die 25W Werte im UM2+, obwohl der über eine 35W Patrone verfügt.

Ich bin mir bei den 0,5 in der Mitte nicht sicher, leider meldet sich der User nicht, der mir die Werte geschrieben hat.

Auch Neotko kann ich nicht kontaktieren, da er keine eMail Adresse im Profil hat.

 

Weiß da jemand mehr dazu oder kann mir die Zahlen bestätigen?

 

  • Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone
    3 hours ago, ACCSisko said:

    Ich bin mir bei den 0,5 in der Mitte nicht sicher, leider meldet sich der User nicht, der mir die Werte geschrieben hat.

     

    Die Frage ist doch erst ein paar Stunden alt....? Lass dem George mal noch ein bisschen Zeit, schließlich ist der in einer ganz anderen Zeitzone.

     

     

    Die Standardwerte für den UM2+ (35W) stehen hier:

    https://github.com/Ultimaker/UM2.1-Firmware/blob/UM2.1_JarJar/Marlin/Configuration.h#L206

     

    Ich bin mit den folgenden Werten ganz zufrieden (35W), aber perfekt ist das wahrscheinlich auch noch nicht:

    p:12.00 i:0.75 d:75.00

     

    Ich glaube, Heizwiderstände sind auch nicht alle präzise 35W (auch wenn sie als solche verkauft werden). Da gibt es durchaus Schwankungen. D.h. die genannten PID-Parameter sind eh' immer nur ungefähre Richtwerte.

     

    • Thanks 1
    Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone

    Das sind die Default werde aus der Firmware (eine etwas ältere da ich die zu Hand hatte)

     

    Für UM2 also 25Watt

        #define  DEFAULT_Kp 10.0
        #define  DEFAULT_Ki 2.5
        #define  DEFAULT_Kd 100.0

     

    Für UM2+ also 35Watt

        #define  DEFAULT_Kp 10.03
        #define  DEFAULT_Ki 1.50
        #define  DEFAULT_Kd 70.0

     

    Da ich schon seit einiger zeit auf Duet Board umgerüstet habe, und da scheinbar das "Auto Tune" ordentliche Werte geliefert hatte (ich weis es gar nicht mehr genau, aber wo her soll ich diese Werte her haben)

    Habe ich folgende Werte eingestellt:

     

    Original UM Patron(35Watt) Sensor (den von UM2):

    Computed PID parameters for setpoint change: P12.0, I0.431, D46.0
    Computed PID parameters for load change: P12.0, I0.849, D46.0

     

    3dSolex Patrone Sensor:

    Computed PID parameters for setpoint change: P7.1, I0.238, D29.3
    Computed PID parameters for load change: P7.1, I0.469, D29.3

     

    Scheinbar verwendet das Duet auch zwei verschiedene Werte, ob du damit was anfangen kannst keine Ahnung.

    Wie tinkergnome schon geschrieben hat, da gibt es Schwankungen untereinander.

     

    Aber eine Frage, hast du mit den vorherigen Werte Probleme?

    Ich weiß noch, wie ich damals Ewigkeiten mit den PID-Autotune rumgemacht habe und das Ergebnis war, das ich die Standard Werte wieder rein gemacht hatte.

    Erst wo ich auf Dual umgebaut hatte, und beim Düsen Wechsel (mit Standby Temp Absenkung) die Temperaturen entweder durch die Decke geschossen sind oder Ewigkeiten gebraucht haben weil sie sich so ca. 3-5C unter soll einzupendeln schien aber der Drucker wartete und wartete bis sie endlich innerhalb eines gewissen soll lagen bis er endlich weiter druckte, habe ich das Thema wieder aufgegriffen und versucht bessere Werte zu ermitteln, ohne Erfolg soweit ich weiß mit UM Board + Marlin, bin aber dann auf Duet RepRap Firmware umgestiegen und da hat sich das Thema dann erledigt

     

    Gruß

    • Like 1
    • Thanks 1
    Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone
    20 minutes ago, zerspaner_gerd said:

     

    Aber eine Frage, hast du mit den vorherigen Werte Probleme?

    Minimal, Schwankungen von bis zu 3°C und Fehler beim Abkühlen für Düsenwechsel ( 110°C statt den eingestellten 90°C).

     

    Das ganze fing aber erst mit Tinkergnome FW an (17.10.1).

     

    Ich würd schon gerne bisschen professioneller werden und den Drucker besser einstellen.

    Auch weil ich irgendwann eine 50W Patrone einbauen möchte wenn sie ausgetauscht werden muss.

     

    Ich will jetzt mal wieder verlässlich Qualität anbieten können anstatt das, was die letzten Tage rauskam. Bevor da nix läuft ist an externe Aufträge nicht zu denken.

  • Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone
    5 hours ago, ACCSisko said:

    Auch weil ich irgendwann eine 50W Patrone einbauen möchte wenn sie ausgetauscht werden muss.

    Also wenn du nicht vor hast mit einer 1mm Düse mit 0.6 Layerhöhe und rasender Geschwindigkeit zu drucken, bringt dir der 50W Heizer wahrscheinlich mehr Probleme als er bringt. Die paar Sekunden schnellere Aufheizzeit sind zum vernachlässigen und wenn die Düse dann auf Temperatur ist, dann ist es völlig egal ob 35W oder 50W. Die Schwankungen werden aber sicher mehr werden.

    • Thanks 1
    Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone

    Übersehen viele... Für die 0,25er Düse ist die Leistung schon zu stark, weshalb man extrem mit dem Tempo hoch muß. Wenn man nun noch auf 50 Watt geht, wird man wohl irgendwo bei 120 bis 150 mm/s landen, um vernünftig zu drucken - nur muß da die Mechanik halt auch mitmachen, ansonsten kommt dann das nächste Problem... Und da ist dann meist das Problem mit Ghosting & Co....

    • Thanks 1
    Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone
    13 hours ago, Smithy said:

    Also wenn du nicht vor hast mit einer 1mm Düse mit 0.6 Layerhöhe und rasender Geschwindigkeit zu drucken, bringt dir der 50W Heizer wahrscheinlich mehr Probleme als er bringt. Die paar Sekunden schnellere Aufheizzeit sind zum vernachlässigen und wenn die Düse dann auf Temperatur ist, dann ist es völlig egal ob 35W oder 50W. Die Schwankungen werden aber sicher mehr werden.

     

    Okay, das ist natürlich ein gutes Argument gegen die Patrone, dachte das die Schwankungen eher weniger werden.

  • Link to post
    Share on other sites
    Posted · PID Werte für 35W Patrone
    1 minute ago, ACCSisko said:

     

    Okay, das ist natürlich ein gutes Argument gegen die Patrone, dachte das die Schwankungen eher weniger werden.

     

    Wäre bei Analog so, aber bei Digital hat man weniger Verluste, aber es wird Digital geschaltet. D.h., es wird nur ein und aus geschaltet. Entsprechend wird das Signal getaktet. Wenn die Heizung überdimensioniert ist, Schwingt Sie mehr um die Zieltemperatur (zu viel Leistung = drüber, wieder runter kühlen bis zum nächsten schalten und das ganze geht von vorne los...).

    Jede Heizung ist halt ein Kompromiss. Sie soll bei 0,25er noch funktionieren, aber auch bei der 0,8er noch brauchbar sein. Da muß man halt abwägen. Je kleiner die Heizung, desto feiner läßt Sie sich regeln, aber geht mit zunehmenden Volumendurchfluss halt mehr und mehr an die Grenzen - mußt also immer mehr mit dem Tempo runter, damit Sie es noch einigermaßen durchheizen kann. Je größer, desto mehr Durchsatz schaft Sie, aber wenn der Durchsatz zu gering ist, verschwindet die Heizleistung ja nicht, also muß Sie immer heftiger geregelt werden = unbrauchbar für kleinere Düsen, da so hoch mit dem Tempo gegangen werden muß, um dem Überschwingen entgegen zu wirken, dass die Mechanik anfängt nachzuschwingen. Da hockst du dann ganz schnell in einer Zwickmühle...

     

    Gruß, Digibike

  • Link to post
    Share on other sites
    Posted (edited) · PID Werte für 35W Patrone

    Also die 50 Watt scheinen mir auch sehr Überdimensioniert.

     

    Die größte Herausforderung für die Patronen ist wahrscheinlich der plötzliche Lüfter Einsatz bzw. stellen (große plane Flächen) im Modell, wo dann die Luft abprallt und direkt auf den Heaterblock/Nozzle bläst und abkühlt.

     

    Wenn ich mich an den 25W Patronen zurück erinnere, kam der Heater Error eigentlich nur in Verbindung mit den Lüfter.

     

    Das kannst du bei deinen aktuellen Teile evtl. auch mal testen, vielleicht gibt es dir eine bessere gleichmäßigere Layer Qualität, einfach mal den Lüfter nur auf max. 50% Laufen lassen. Bei normalen Teile die eine gewisse Größe haben und keine besonderen Merkmale aufweisen reichen locker max. 50%.

     

    On 11/21/2020 at 5:23 PM, ACCSisko said:

    Fehler beim Abkühlen für Düsenwechsel ( 110°C statt den eingestellten 90°C).

     

    Das kommt mir bekannt vor, von der Atomic Methode. Das komische wenn ich mich richtig erinnere war das nicht jedes mal der fall, sondern nur manchmal. Evtl. hang es mit den PID-Werte zusammen. Aber bei 90C druckt man ja auch nicht, soll lieber bei über 190C gut regeln.

    Du kannst ja mal das PID Auto Tune laufen lassen, mit der Tinker Firmware konnte man es ganz einfach über das Menü anstoßen, vielleicht bringt es dir auf anhieb gute Werte (bei mir war das leider nicht der fall, unbekannte gründe)

     

    Gruß

    Edited by zerspaner_gerd
    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...