Jump to content
Ultimaker Community of 3D Printing Experts

cura not running in MX Linux


djquincy
 Share

Recommended Posts

Posted · cura not running in MX Linux

I got these errors whilst trying to run Cura 4.8.0 appImage in MX Linux: 

 

Quote

$ ./Ultimaker_Cura-4.8.0.AppImage
Fontconfig warning: line 5: unknown element "its:rules"
Fontconfig warning: line 6: unknown element "its:translateRule"
Fontconfig warning: line 9: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 8: unknown element "description"
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 76: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 76: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 84: saw unknown, expected number
Fontconfig warning: "/etc/fonts/conf.d/11-lcdfilter-default.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/11-lcdfilter-default.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/11-lcdfilter-default.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/45-latin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/49-sansserif.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/51-local.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/60-latin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-persian.conf", line 34: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/65-fonts-persian.conf", line 35: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/65-nonlatin.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/69-unifont.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/69-unifont.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 5: unknown element "its:translateRule"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 5: unknown element "its:translateRule"
Segmentation fault

Any help would be appreciated.

Thanks in advance

  • Link to post
    Share on other sites

    Posted · cura not running in MX Linux

    I have Ubuntu Linux.  Works fine for me.  I do get a handful of errors like you but it seems to work fine.  The key error is the "segmentation fault".  I definitely don't get that!

     

    Anyway please post the cura log file which will likely have much more information.  For me it's in:

    /home/gr5/.local/share/cura/master

     

    There are software people who work on cura on this forum and with the log file they will know much more.

     

    Is your Linux 64bit?  I think that's a requirement.  Also you need to have an x86 processor (intel or AMD).  Not some cell phone chip or something.  Not a chrome pad.

  • Link to post
    Share on other sites

    Posted (edited) · cura not running in MX Linux

    Thanks for the reply.

     

    My linux is 64bit and i have an intel processor. Just a  side note, installing cura 3.3.1 from the repository works but iam hoping to get this newer version running.

     

    I think i found the log file:

     

    Quote

    Fatal Python error: Segmentation fault

    Thread 0x00007f8add716700 (most recent call first):
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 293 in wait
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 424 in acquire
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/JobQueue.py", line 98 in _nextJob
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/JobQueue.py", line 123 in run
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 914 in _bootstrap_inner
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 882 in _bootstrap

    Thread 0x00007f8addf17700 (most recent call first):
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 293 in wait
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 424 in acquire
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/JobQueue.py", line 98 in _nextJob
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/JobQueue.py", line 123 in run
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 914 in _bootstrap_inner
      File "/build/env/4.8/inst/lib/python3.5/threading.py", line 882 in _bootstrap

    Current thread 0x00007f8b06630740 (most recent call first):
      File "/build/4.8/build/inst/lib/python3.5/site-packages/cura/UI/CuraSplashScreen.py", line 73 in drawContents
      File "/build/4.8/build/inst/lib/python3.5/site-packages/cura/UI/CuraSplashScreen.py", line 41 in show
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/Qt/QtApplication.py", line 536 in createSplash
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/Qt/QtApplication.py", line 543 in showSplashMessage
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/Qt/QtApplication.py", line 190 in startSplashWindowPhase
      File "/build/4.8/build/inst/lib/python3.5/site-packages/cura/CuraApplication.py", line 474 in startSplashWindowPhase
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/Application.py", line 239 in run
      File "/build/4.8/build/inst/lib/python3.5/site-packages/UM/Qt/QtApplication.py", line 341 in run
      File "/build/4.8/build/inst/lib/python3.5/site-packages/cura/CuraApplication.py", line 780 in run
      File "/build/4.8/build/inst/bin/cura", line 235 in <module>
      File "<frozen importlib._bootstrap>", line 634 in _load_backward_compatible
      File "<frozen importlib._bootstrap>", line 664 in _load_unlocked
      File "<frozen importlib._bootstrap>", line 957 in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 968 in _find_and_load
      File "/build/env/4.8/inst/lib/python3.5/site-packages/cx_Freeze/initscripts/Console.py", line 21 in <module>
      File "<frozen importlib._bootstrap>", line 634 in _load_backward_compatible
      File "<frozen importlib._bootstrap>", line 664 in _load_unlocked
      File "<frozen importlib._bootstrap>", line 957 in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 968 in _find_and_load
      File "/build/env/4.8/inst/lib/python3.5/site-packages/cx_Freeze/initscripts/__startup__.py", line 12 in <module>
      File "<frozen importlib._bootstrap>", line 634 in _load_backward_compatible
      File "<frozen importlib._bootstrap>", line 664 in _load_unlocked
      File "<frozen importlib._bootstrap>", line 957 in _find_and_load_unlocked
      File "<frozen importlib._bootstrap>", line 968 in _find_and_load

     

    Edited by djquincy
  • Link to post
    Share on other sites

    Posted · cura not running in MX Linux

    I'm not sure if this is correct but I think if you have 2 versions of cura sometimes they interact?  Usually not - I mean I have a few versions and it's fine but still - maybe delete everything (includes all profiles and every profile or setting change or machine you installed) in the configuration folders.  I think probably here:

    ~/.local/share/cura/master

  • Link to post
    Share on other sites

    Posted · cura not running in MX Linux
    15 hours ago, gr5 said:

    @ahoeben or @ctbeke have ideas?

     

    For Cura desktop issues it'd be best to tag one of the Cura developers like @nallath or @ghostkeeper.

  • Link to post
    Share on other sites

    Posted · cura not running in MX Linux

    Or even beter; Post it on our issue tracker on github so all the developers will see it 🙂

    • Like 1
    Link to post
    Share on other sites

    Posted · cura not running in MX Linux

    @djquincy - sounds like nothing obvious to some developers so maybe post your issue and log here:

    https://github.com/Ultimaker/Cura/issues

     

    If you don't already have a github account, you'll have to create one but it's free.

  • Link to post
    Share on other sites

    Posted · cura not running in MX Linux

    ok thx

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...