Jump to content

Ultimaker Cura Arachne Engine Beta 2


fvrmr

Recommended Posts

Posted · Ultimaker Cura Arachne Engine Beta 2

Hi everyone,

 

Earlier this year, we released the first beta of Ultimaker Cura Arachne engine. Which received an overwhelmingly positive response, thank you for all your feedback!

Since the first beta release we've been working on improving the Arachne engine.

 

What is the Arachne Engine?

Our new Ultimaker Cura engine allows you to create parts with ground-breaking quality, strength, and speed. This is made possible by fundamentally redefining how the inside of a model is generated – through adaptive line widths and optimized line positioning.

 

 Arachne-vs-4.12-width-v2.thumb.png.778c0f87f243ee05d0c84774c8974f0b.png

 

New features in Arachne second beta:

Back pressure compensation

Print quality is improved through dynamically adjusting print head velocity, which slows down or speeds up depending on the pressure of the material through the Bowden tube.

Printing order filling gaps

Gaps in models are now filled in after placing the outer wall, resulting in less over-extrusion.

Print quality enhancements

All print quality improvements from Ultimaker Cura 4.12 have been added.

 

Bug fixes:

- Fixed a bug where blobs in g-code were generated

- Fixed a bug where the Inner Line Width was wider than the end of the model

- Fixed a bug where the Seam placement was not on the correct corner

 

Read the full release notes for all the bug fixes and the known issues or read our full blog post.

 

Download the 2nd beta now!

 

Share your feedback, show your results and/or provide us your input for print profiles for your preferred 3D printer with us here in the comments below or on GitHub

  • Like 3
Link to post
Share on other sites

Posted · Ultimaker Cura Arachne Engine Beta 2

Is this new engine (when finally released) going to allow prints that have text in the first layer, to be printed with a brim on the OUTSIDE of the model only? So text doesn't get filled in?

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    Hi:  This seems really great!  However, no Outer Before Inner Walls option?  My parts aren't printing well with what seems to be the default or hard-coded inner before outer.

     

    Thanks.

  • Link to post
    Share on other sites

    • 1 month later...
    Posted · Ultimaker Cura Arachne Engine Beta 2
    On 11/27/2021 at 2:45 PM, surfski said:

    Hi:  This seems really great!  However, no Outer Before Inner Walls option?  My parts aren't printing well with what seems to be the default or hard-coded inner before outer.

     

    Thanks.

    @surfski - I think it's now under Wall Ordering and the selection would be Outside to Inside

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    @JackW327 Thank you!  I searched and searched for that setting, and couldn't find it.  Finally realized I had to "manage setting visibility" and enable it (along with many many other features!).   Strange to me that new and/or Arachne-specific features would be disabled by default...

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2
    10 hours ago, surfski said:

    I searched and searched for that setting, and couldn't find it.

    Did you know there's a helpful search field atop of the settings that helps you search for settings? It also shows settings that have not yet been made visible.

     

    The whole idea of NOT making all of the >300 settings visible is to make it easier to find the often-used important settings. Need something advanced? Use the search feature. Turns out you need that advanced feature often? Make it visible. Personally I like staying on the "Basic" set of visible settings, and use the search for the rest.

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    Been using it for a few weeks now - significant improvement in stability from Beta 1.
    - Occasional crashes but have not been able to reproduce (may be graphics card related)
    - Generally it "feels" faster (have not done back-to-back tests)

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2
    20 hours ago, ahoeben said:

    Did you know there's a helpful search field atop of the settings that helps you search for settings? It also shows settings that have not yet been made visible.

     

    The whole idea of NOT making all of the >300 settings visible is to make it easier to find the often-used important settings. Need something advanced? Use the search feature. Turns out you need that advanced feature often? Make it visible. Personally I like staying on the "Basic" set of visible settings, and use the search for the rest.

    @ahoeben  Thank you - I agree that search can be helpful.  However, if you don't know the name of a feature, it's quite difficult.  In regular Cura it's "outer before inner walls."  In S3D the it's "outline direction".  In PrusaSlicer it's "external perimeters first."  (And very easy to find.)  Searching with most of those keywords doesn't bring up "wall ordering."  If you know that the feature name has the word "wall," you will find it buried amongst ~80 other features.  So for me, search wasn't helpful in this case.  Second, this feature isn't advanced, but one of the most basic or fundamental.  It often makes the difference between a print completing, or utterly failing.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    All versions  with arachne engine  locks up on my New Dell XPS w/Core 9 Intel. I had to go to version  4.10

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    @samhar, how about versions 4.11, 4.12 & 4.13? They don't have the Arachne engine.

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura Arachne Engine Beta 2

    I am not sure if this is a bug or something I did wrong. After install the Arachne Engine, it loaded all my old profiles from Cura 4.12.1, but I can't save any changes to these profiles or rename profiles.

     

    For example, I made some random change to one of the profile, and select "Update profile with current settings/overrides", then switch to a different profile then switch back, the profile will revert back to original status without all the random changes I made. In "Manage Profiles (Ctrl + J)", I click the "Rename" button, enter a new name, then hit "OK" button, the profile list will do a refresh but nothing changed.

    Edited by Hibino
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura Arachne Engine Beta 2

    On macOS Big Sur 11.6.2.

     

    When Cura is displayed on external displays it is not possible to grab a model and move/rotate and so forth. Dragging Cura to the laptop display solves this. It is reproducable over and over again by dragging cura between displays. A problem existing for a long time / versions.

    Edited by ChrazZ
    added comment
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2
    On 11/27/2021 at 1:45 AM, Ch3vr0n said:

    Is this new engine (when finally released) going to allow prints that have text in the first layer, to be printed with a brim on the OUTSIDE of the model only? So text doesn't get filled in?

    option 1: ur print has empty text (holes)

    option 2: ur print has filled text with separated print time (2 print)

     

    Solution for option 1 and possibly option 2:

    don't use brim, but use SKIRT with 0 DISTANCE

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    option 1: wrong. Model is solid just fine. Text is on layer 1 in the middle of a model. Use a brim and cura adds a brim outside those text lines while in the middle of layer 1

    option 2: wrong again. Text is filled in, but not seperated print time. Look "Fibo filament box" on thingiverse and you'll see exactly what i'm talking about

     

    none of your solutions fix anything

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura Arachne Engine Beta 2

    This model?  This is in 4.13.1 with "Brim only on outside" turned on.

    image.thumb.png.5e031ad07d83715c8d2dc07d1d0fd752.png

     

    This is with "Brim only on outside" turned off.

    image.thumb.png.ffaedf00a2fd5a36da8f561ed6042143.png

     

    It's hard to see the brim lines but they aren't everywhere.  The "Bo" continue to be full but the others just have a single line, and then there are the areas without any interior brim.

    Behavior like this is almost always the model.  I'm sayin' "almost" because this time I don't think it is.

    On the other hand, flipping it over and printing it right-side up works.  It certainly doesn't need a brim.  It looks like @mardocheo's solution with a wide skirt set to zero distance works as well.  This is Arachne.

     

    image.thumb.png.d667ff71b804eb5d6d6b736267c11d9f.png

    On the other hand (that makes three) I didn't feel like perusing a boatload of STL's looking for the right one and so this may all be wrong.

     

    Edited by GregValiant
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    Is anybody else experiencing an issue with Beta2 where:
           "Top Surface Skin Pattern"
    set to
           "Concentric"
    does not work? (See below). Worked in Beta1 on the same models.
    Could there be a setting that over-rides Concentric?



    image.thumb.png.29accaa689010954b609602812eee2d0.png

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2

    Does not work for me in Beta II.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura Arachne Engine Beta 2
    On 3/30/2022 at 8:12 AM, Southways said:

    Is anybody else experiencing an issue with Beta2 where:
           "Top Surface Skin Pattern"
    set to
           "Concentric"
    does not work? (See below). Worked in Beta1 on the same models.
    Could there be a setting that over-rides Concentric?



    image.thumb.png.29accaa689010954b609602812eee2d0.png

    Update... I found it reported as a Bug on Github

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 7 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    ×
    ×
    • Create New...