Jump to content
Ultimaker Community of 3D Printing Experts
2fmraines

3dsmax into Cura Scaling Issues

Recommended Posts

I've tried and tried to find an answer to this.

I started modeling in inches, object is 4" sphere. Export as .obj or .stl and both come into Cura as 8mm. So I read that I need to model in mm. So I started a new file with units in mm. Created a 101.6mm sphere, exported and imported into Cura. Still imported as 8mm.

I'm working with a trial version of 3d Studio Max 2014 and the newest version of Cura.

Anyone have a clue why this is doing this?

 

Share this post


Link to post
Share on other sites

I did another test. I placed the 4" (101.6mm) object back into Cura. Upscaled it to 101.6mm (from 8mm) and it tells me that is 5.62% increase in size. So in theory if I take each piece of my final project (which is a total of 4" around) and upscale each piece by 5.62% everything will fit together correctly?

Just wish there was a way to get this to work right. 3dsmax doesn't give really any options when exporting STL format. Just a selection of Binary or ASCII, and rather to export all or selected.

 

Share this post


Link to post
Share on other sites

I'm a max user, you need to set your units in max to mm to get accurate translations in Cura.

make sure you do: customize -> units setup

Set it to metric, then go to system unit setup. make sure 1 unit = 1 mm

check on the option: "respect system units in files"

 

Share this post


Link to post
Share on other sites

Got to be some kind of bug in Max. I just set everything how you said. Created a 101.6mm sphere. Exported and now it's showing 203.2mm inside Cura and also in netFabb. If I do a .OBJ export and set scaling to half it comes out perfectly 101.6mm. I guess this is a simple option to fix the problem.

Thank you very much :)

 

Share this post


Link to post
Share on other sites

Anyone have a clue why this is doing this?

 

Technical answer (Valcrows solution will work, just explaining a bit better what is happening)

The problem is that STL isn't defined what the "unit" size is. And models are stored in "units". Now, most applications agree on the fact that 1 "unit" is 1 mm. But some applications work with 1 "unit" is 1 inch. Now, as whole of Cura works in mm, it's logical to have 1 unit = 1 mm.

 

Share this post


Link to post
Share on other sites

Technical answer (Valcrows solution will work, just explaining a bit better what is happening)

The problem is that STL isn't defined what the "unit" size is. And models are stored in "units". Now, most applications agree on the fact that 1 "unit" is 1 mm. But some applications work with 1 "unit" is 1 inch. Now, as whole of Cura works in mm, it's logical to have 1 unit = 1 mm.

 

Since this is likely to be a very common problem, is there a way to specify that a file is in inches during the load or perhaps the preferences? I have 4 other CAM programs that all handle this properly, so it seems like it couldn't be too hard.

Autocad Inventor STL files have the same issue, though the Inventor files are off by a scaling of 10

 

Share this post


Link to post
Share on other sites
Got to be some kind of bug in Max. I just set everything how you said. Created a 101.6mm sphere. Exported and now it's showing 203.2mm inside Cura and also in netFabb. If I do a .OBJ export and set scaling to half it comes out perfectly 101.6mm. I guess this is a simple option to fix the problem.

 

Thank you very much :)

 

Its not a bug. The sphere parameter is radius not diameter.

Share this post


Link to post
Share on other sites

I use inventor for my designs, and my stl files always show up 10 times smaller in cura than what i made them in inventor. Not a big deal, but i guess autodesk software is just a bit wierd with 3d printer files :)

 

Pretty sure your export scale is set to cm then, simple change to mm and you're golden without scaling issues.

 

Share this post


Link to post
Share on other sites

Technical answer (Valcrows solution will work, just explaining a bit better what is happening)

The problem is that STL isn't defined what the "unit" size is. And models are stored in "units". Now, most applications agree on the fact that 1 "unit" is 1 mm. But some applications work with 1 "unit" is 1 inch. Now, as whole of Cura works in mm, it's logical to have 1 unit = 1 mm.

 

Since this is likely to be a very common problem, is there a way to specify that a file is in inches during the load or perhaps the preferences? I have 4 other CAM programs that all handle this properly, so it seems like it couldn't be too hard.

Autocad Inventor STL files have the same issue, though the Inventor files are off by a scaling of 10

I get the same problem with inventor 2016 version and there is no options dialogue to change scaling in inventor because that is done when you choose your starting file i.e. standard ipt(mm) so you have selected the part file dimensions from the beginning. Therefore its not an inventor problem more on the side of Cura Although I get the same problem with simplify 3d and its much harder to correct the scale in simplify so I would really like to find a permanent solution to this problem.

Share this post


Link to post
Share on other sites

Technical answer (Valcrows solution will work, just explaining a bit better what is happening)

The problem is that STL isn't defined what the "unit" size is. And models are stored in "units". Now, most applications agree on the fact that 1 "unit" is 1 mm. But some applications work with 1 "unit" is 1 inch. Now, as whole of Cura works in mm, it's logical to have 1 unit = 1 mm.

 

Since this is likely to be a very common problem, is there a way to specify that a file is in inches during the load or perhaps the preferences? I have 4 other CAM programs that all handle this properly, so it seems like it couldn't be too hard.

Autocad Inventor STL files have the same issue, though the Inventor files are off by a scaling of 10

I get the same problem with inventor 2016 version and there is no options dialogue to change scaling in inventor because that is done when you choose your starting file i.e. standard ipt(mm) so you have selected the part file dimensions from the beginning.  Therefore its not an inventor problem more on the side of Cura Although I get the same problem with simplify 3d and its much harder to correct the scale in simplify so I would really like to find a permanent solution to this problem.

No you are correct when exporting from inventor you have to do this

1. In the save as dialogue drop down menu select save copy as.

2. Chose Save as Type STL Files(*.stl).

3. when you have chosen this option in 2. click the options button in the Save Copy As dialogue box.

under Format Binary Radio button select units as millimeter. Click Ok then go ahead and save STL file.

Problem solved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!