Jump to content
Andreasw

always rotating model by 90degrees in the same axis after open

Recommended Posts

Posted · always rotating model by 90degrees in the same axis after open

In 99% of all cases I rotate the the STL after import by 90 degrees in one axis.

 

Is there  maybe a place where I could set a command / script that automatically runs after I open an STL? 

 

 

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

I think it has to do with how you export your model, and the point of origin is at the wrong/not where you mean it place. This point decides what is up and what is down in your model. How to change this 0,0,0 position may depend on what software you use. Do you design the models yourself, where this happens?

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

Yes, this happens to me when I create things with Fusion 360. I could rotate them by those 90 degrees before they become a STL. (Or I could look into changing this in Fusion.) It is just strange that this 90 degrees turn seems to be needed for my parts 90% of the time. Since it does not matter, I should probably just 'rotate my thinking' when I start the object in Fusion. I was just wondering if there is a place for cura commands to be run during import. 

 

Thanks for getting back to me about this. 

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

@SteveCox3D , you are a Fusion 360 expert aren't you? Do you know how to change the point of origin for a model?

  • Like 1

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

Same over here, Fusion 360 user, when i use the normal xyz planes in Fusion, the 3d generated files are always 90% rotated.

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

Something interesting to check is if rotating actually does the trick; it would be my guess that you have to rotate and mirror the mesh to get it to be the same as the original. The problem is actually not a rotation, but the swapping of the Y & Z axis (ie: which axis points upwards, Y or Z?).

 

I think a plugin could be created to do this swapping automatically (or with a dialog).

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

The solution for dealing with this issue with Fusion 360 is fairly simple. 

 

For whatever reason Autodesk have chosen "Y-Up" as the default modelling orientation in Fusion 360.  That's despite all of the industries that I know using "Z-Up" (Z is the vertical axis in 3D space), and that includes Cura. So when you import your Fusion 360 model it positions the vertical axis in your model, which is the Y-axis, onto the horizontal Y-axis in Cura - and hence your model imports on it's side.

 

You can see what your current setting is if you look at the view cube in the top right hand corner where the axes are labelled.

 

There's an easy fix for this, and one that you do once and never have to re-orientate a model again.

 

Go to where your name is in the top right hand corner of the screen, click on the drop-down arrow to bring up the menu and select "Preferences".  On the Preferences window that opens up part way down there is a "Default modelling orientation" option where you can change from Y-Up to Z-Up (see the image attached), then click "Apply" and then "OK".  From then on every new model you create won't have this orientation issue - though the change will not change any old models you have created, or the one that you may be working on when you apply this change.

 

I hope that helps - I keep meaning to ask Autodesk why they use the Y-Up as default when everyone I know uses Z as the vertical 3D axis.  Making this change is something I get everyone to do at the start of all of the Fusion 360 training courses that I run. 

ATC File.jpg

  • Like 2
  • Thanks 2

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

In 3d modelling for computer visualisation, Y-up is more common. This includes all of OpenGl, so Cura internally uses Y-up as well, and there's quite a bit of juggling going on to flip between these orientations.

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

Steve this is perfect! It works great. Thank you. It seems that the preference change affects only designs during their creation. Going forward I'll save one step.Which is awesome. And I hope to remain thankful for your awesome explanation and documentation for a while. 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open
On 2/16/2018 at 2:45 PM, Andreasw said:

Steve this is perfect! It works great. Thank you. It seems that the preference change affects only designs during their creation. Going forward I'll save one step.Which is awesome. And I hope to remain thankful for your awesome explanation and documentation for a while. 

Glad that's sorted for you Andreas and that it will eliminate one step in the process of going from 3D model to 3D print

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

Steve,

Do you have the same trick for SolidWorks? I, too, constantly have this problem.

 

Something like a 1 click 90* rotate would also solve the problem quite quickly and be general.

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

I don't use Solidworks but I can see that it has the same issue where Y-up is the default setting.

Take a look at the two YouTube videos and the webpage link below to see if these help (it looks like you have to maybe create a new template for your designs to correct this problem in SW) :

 

 

https://ongaacam.com/reset-solidworks-planes-z-axis-call-top/

 

Share this post


Link to post
Share on other sites
Posted · always rotating model by 90degrees in the same axis after open

Huh, yeah, that's probably a reasonable way. Certainly the two "defaults" conflict. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 86 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!