Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker S5 Cooldown With ABS


AZ-RAD
 Share

Recommended Posts

Posted · Ultimaker S5 Cooldown With ABS

The mandatory cooldown time forcing the bed to drop below 60C is really quite frustrating when trying to print higher temp materials which require enclosures and higher ambient temperatures. When I'm printing ABS with a 100C build plate I really need to let it warm for like 30-60 minutes to ensure that the ambient temp in the printer is high enough that I don't get warping and layer splitting. If I have a failed print due to something like I just did where the autolevel decided to ram my nozzle very far into the build plate at one spot I basically loose 2hrs of print time as I need to let the thing fully cool down. I then need to let it fully warm up and get the air back to the required 35C ambient before I can tell it my print has been removed and then restart my print. I get this is a safety feature to prevent people from trying to rip prints off a hot glass bed and either damage themselves or the printer but there needs to be an advanced options menu to skip this for these kind of scenarios. The skip cooldown option that comes up doesn't seem to do anything here when it isn't greyed out.


I am missing something basic or is there a way to disable or change this safe cooldown temp with a variable or something? At this point I'm basically taking files home from my lab and printing them on my home printer (a Voron 2.4) as it does ABS better than this one. Users at some of our other sites ask me if they should replace their Prusa MK3s with S5s and honestly I'm having a hard time saying yes. At face value this printer will handle these higher temp materials better and hardware wise it's superior but then the limitations int he firmware for stuff like this make it very hard to recommend.

  • Like 1
Link to post
Share on other sites

Posted · Ultimaker S5 Cooldown With ABS
44 minutes ago, AZ-RAD said:

  At face value this printer will handle these higher temp materials better and hardware wise it's superior but then the limitations int he firmware for stuff like this make it very hard to recommend.

I'm with you on this..  I'm also an ABS guy.
I think I short-circuited the process once by cycling the power on the machine.

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 Cooldown With ABS

    It is/was also annoying for me, so I did some research on the firmware and here is a  solution how to get rid of the cool down phase. 

     

    Do this hack on your own risk and be very careful when you edit the file. Any mistake can brick your printer! And you have to do the same steps after the next firmware upgrade.

     

    You need to enable the developer mode on the printer and then ssh into it. Username root, Password ultimaker

     

    First we should enable SSH permanently to be on the safe side. When you enable the developer mode in the menu, it is just a flag to enable ssh during the startup of the printer. But when you have an error in the file, the startup will be interrupted and the SSH daemon will never be started. Therefore we enable it per default to always have access to the printer in case something goes wrong.

     

    For older firmware versions < v6.0 do:
    systemctl enable dropbear
     
    For the newer ones > v6.0:
    systemctl enable ssh

     

    Then you have to edit the file 

    /usr/share/okuda/components/progress/PrintProgress.qml

     

    There you can change the temperate which is considered to be safe in line 10:

    property var safeToTouch: Okuda.SystemStateProxy.printBed.temperature < 60.0

    Set it < 100.0 for example, to see everything below 100°C as safe.

     

    Then just reboot the printer.

     

    You should have some knowledge how to edit files in Linux. I am using the vi editor, but it could be strange to someone who have never used vi before. 

     

    And again, you could brick your printer when something goes wrong, so do it on your own risk. 

    • Like 1
    • Thanks 1
    Link to post
    Share on other sites

    Posted · Ultimaker S5 Cooldown With ABS

    And here a one-liner without the need to struggle with the vi editor. Just copy and paste the command line to the ssh terminal and hit enter. The safe temperature will be changed from 60.0 to 100.0 and the printer service will also be restarted after the change. No need to reboot the printer.

     

    sed -i 's/< 60.0/< 100.0/g' /usr/share/okuda/components/progress/PrintProgress.qml && systemctl restart griffin.printer

     

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 Cooldown With ABS
    1 hour ago, JTMD said:

    I'm with you on this..  I'm also an ABS guy.
    I think I short-circuited the process once by cycling the power on the machine.

     

    Yeah I tried power cycle but when it comes back on it still required the cool down.

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker S5 Cooldown With ABS
    49 minutes ago, Smithy said:

    It is/was also annoying for me, so I did some research on the firmware and here is a  solution how to get rid of the cool down phase. 

     

    Do this hack on your own risk and be very careful when you edit the file. Any mistake can brick your printer! And you have to do the same steps after the next firmware upgrade.

     

    You need to enable the developer mode on the printer and then ssh into it. Username root, Password ultimaker

     

    First we should enable SSH permanently to be on the safe side. When you enable the developer mode in the menu, it is just a flag to enable ssh during the startup of the printer. But when you have an error in the file, the startup will be interrupted and the SSH daemon will never be started. Therefore we enable it per default to always have access to the printer in case something goes wrong.

     

    For older firmware versions < v6.0 do:
    systemctl enable dropbear
     
    For the newer ones > v6.0:
    systemctl enable ssh

     

    Then you have to edit the file 

    /usr/share/okuda/components/progress/PrintProgress.qml

     

    There you can change the temperate which is considered to be safe in line 10:

    property var safeToTouch: Okuda.SystemStateProxy.printBed.temperature < 60.0

    Set it < 100.0 for example.

     

    Then just reboot the printer.

     

    You should have some knowledge how to edit files in Linux. I am using the vi editor, but it could be strange to someone who have never used vi before. 

     

    And again, you could brick your printer when something goes wrong, so do it on your own risk. 

     

    Amazing, I'm gonna give that a look next week!

  • Link to post
    Share on other sites

    • 3 months later...

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Ultimaker showcase | April 2022 | 4pm CEST | 10am EDT
        I'm excited because I've personally produced this showcase event, so if you are curious what else I'm up to nowadays, come check it out and say hi in the chat! It would mean a lot! 
          • Thanks
          • Like
        • 4 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 12 replies
    ×
    ×
    • Create New...