Jump to content

Firmware installation failed to verify


Recommended Posts

Posted · Firmware installation failed to verify

I have a UM3 with firmware 4.3.96 and I am trying to update it but it fails to verify.

WIFI setup doesn't work. it fails to create a hotspot but cable works partially.

When I use a cable the UM3 gets an IP and I can connect to that IP in the browser.

Cura finds the printer but won't stay connected - I get the blue check mark for 2 sec. so I can't do anything from Cura.

I have tried most of what I ca find by googling b ut nothing seems to work.

Please help!

  • Link to post
    Share on other sites

    Posted · Firmware installation failed to verify

    Hey @Morganw


    Welcome to the Utlimaker Community 🎉

    I recognize your error.
    You'll have to connect your printer to the internet because it doesn't know the date without it. 
    You can find more about the bug here: https://support.ultimaker.com/hc/en-us/articles/360014745220-Firmware-installation-failed-to-verify


    You can find the files you need to update to the latest firmware here: 
    Since you are on a firmware version older than 5 you'll need to read carefully and install a stepping stone firmware first.

    Let us know if you are still stuck, than we can explore other troubleshooting directions. 
     Hope this helps! 🤞

  • Link to post
    Share on other sites

    Posted · Firmware installation failed to verify

    Hi and thank you for your answer.

    I have actually tried this. An ethernet cable with internet is connected to printer and it doesn't seem to have any trouble downloading firmware it's when it is trying to install the firmware it fails. So I think I can confirm that it has internet access.


    Also when I put the two files on memory stick they don't show up. The printer doesn't recognise the files. So I can't do that either I'm afraid. If I download the 5.3 version it recognises it and I can choose to start installing it but it fails to verify it after a couple of seconds.


    It doesn't seem to be any way to get a new version of the firmware in, maybe I'll need to get a new motherboard?

  • Link to post
    Share on other sites

    Posted · Firmware installation failed to verify

    Oh that sucks.  So there is the old way to upgrade and the new way.  It switched over a few years ago.


    4.3.96 is an invalid version.  I'm not sure where you got it.  It was quickly replaced by 4.3.97.  I forget why - something to do with not being able to upgrade.


    4.3.96 is one of the two "stepping stone" firmware versions (the other being .97) that are not meant to do any printing - just get you to the newer version of 5.X (e.g. 5.2.8).


    I think you will need to do a "firmware recovery".  Ask your reseller for the procedure or you can read about it here:


    • Thanks 1
    Link to post
    Share on other sites

    Posted · Firmware installation failed to verify
    7 hours ago, gr5 said:

    These 'better' instructions are for the S3 and S5 R2 which has different hardware than the UM3, so this won't work.

    Perhaps you meant to refer to this article instead? https://support.ultimaker.com/hc/en-us/articles/360014745220
    There is explained that firmware 4.3.96 was a stepping stone version with a bug where it would fail to install the new firmware when the printer had no date set. Connecting the printer to the internet and then waiting a bit (or rebooting) should solve that.
    The newer 4.3.97 stepping stone was fixed by omitting the date check, required for printers without network connection.

  • Link to post
    Share on other sites

    Posted · Firmware installation failed to verify

    Thanks Carlo.  I got confused as there was someone else with an S5R2 also this week.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
          • Like
        • 18 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    • Create New...