Jump to content
Ultimaker Community of 3D Printing Experts
roykinn7

Thin gap between outer wall and inner wall, only on small circular insets but not on the perimeter of the print...

Recommended Posts

Firstly, I love Cura, been using it for a year, it keeps getting better and better! Thanks :)

I've been going crazy over this issue for months now, I've posted asking for help on r/3dprinting and the wanhao duplicator i3 google group and nothing I've tried works, or at least what does work messes something else up.

I've built some game hex pieces that have circular insets built around the perimeter to allow for tiny magnets. Every other detail of the print comes out great but these particular insets keep printing with this gap between the inner and outer walls.

Capture6.thumb.jpg.bd4005ea3f41d39cf8e017b7a3eec1f6.jpg

What baffles me is if I print the same size inset into a small piece of plastic like a tiny game piece they come out perfectly fine. These gaps appear all the way around the outer wall on each inset, sometimes slightly touching the inner walls but mostly there is a visible gap. Here is a blender mockup I built to visualize the problem better.

Capture3.thumb.JPG.e2cf2320790a4e536785566eeae463da.JPG

The STL looks fine in Cura, here are screenshots of the STL and viewed in Layer Mode.

Capture1.thumb.JPG.ad1be3ef2f7948a744feb173f36e6e9f.JPG

Capture2.thumb.JPG.c254bf7c1226bc25a111bebc83b83120.JPG

I've tried many many things...

...adding an infill and skin overlap of .2 then .4mm

...playing with my retraction settings (I thought maybe as the printer retracted to travel from one inset to the next it was under extruding when it got to there.)

...I tried to give Compensate Wall overlap a negative value to increase overlap between inner and outer wall but the software is currently just a check box.

...I've got Fill Gaps Between Walls set to Everywhere.

...I slowed my Outer Wall print speed down to 10mm/s

The only thing that fixed the matter ruined every other bit of my print, by editing the Outer Wall Inset by about .2mm the outer wall overlapped the inner wall and printed with no gap. But not only does this throw off all of my tolerances which I had to recalculate it also makes for poorly printed small details, so I had to abandon that "fix".

The models are built in Fusion 360.

I'm printing on a Monoprice Maker Select V2.1

That's a .4mm nozzle.

I've tried multiple different brands of PLA, printing from 195-205f.

The insets have a diameter of 3.325mm, I'm wondering if this is causing a problem with the nozzle width, but even that doesn't make sense to me, again, these holes print out just fine one at a time.

Anybody out there that can shine some light on why I'm having so much trouble here? I think my hair is graying over this nonsense :/

Share this post


Link to post
Share on other sites
57 minutes ago, JasonC said:

Did you manage to fix this issue? I'm getting the same problem.

It's been awhile since I used cura, upgraded to a prusa and have been using slic3r since so my recollection isn't perfect but here are two things that helped but did not completely rid me of the problem...

 

1. At first I had some success using what I think was called the inner wall offset setting and pushing the inner wall closer to the outer wall, or maybe it was outer wall offset pushing closer to the inner wall. I think I remember the problem with this is it changed the dimension of the hole, so it was likely the latter of the two. You can also play with the order in which it prints the walls too, outer before inner or vice versa.

 

2. What worked better was a new setting that came along, last time I used it the setting was in experimental. It was called something like wall print optimization, it would calculate the wall printing order so that, if say, the model had two holes or more on a surface like the print above it would print hole #1, outer to inner walls or inner to outer before moving to hole #2.

 

This worked best, I think the problem had something to do with printing all outer walls first and the time it took before it came back to each hole to print the inner walls would allow for the tiny outer walls to cool and contract, shrinking and creating the gap

 

Since the wall order optimization setting forces the printer to print each hole individually before moving to the next the outer and inner wall have the time to properly fuse together before the first wall retracts. That's just my guess, but iirc it seemed to help if not in some instances completely fix the issue.

 

Make sense? I'm not totally sure it does.

Share this post


Link to post
Share on other sites

Thanks for reply.

 

Yes that makes perfect sense. I've been experimenting with the optimise wall function but for other reasons so maybe that is what is helping on some models but not others. I will look into that further and see what I can find.

 

I also run a 2 Prusas but never tried slic3r so maybe I'll take a look at that if I can't improve things.

 

Thanks again for you help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!