Jump to content
ahoeben

Sidebar GUI for Cura 4.0

Recommended Posts

Posted · Sidebar GUI for Cura 4.0
On 1/11/2019 at 5:45 PM, nils91 said:

i wish u could just block the computers from ultimakers so they are forced to use this shitty dropdown menu themself.

You mean like we're already doing? Uh, okay. No need to block anything for that.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0
34 minutes ago, nallath said:

You mean like we're already doing? Uh, okay. No need to block anything for that.

 

What I think he meant, sort-of tongue in cheek, was that I somehow disable my plugin on computers at ultimaker hq, force-dog-feeding the 4.0 interface to Cura developers. I can appreciate the joke.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

I know. But I kinda like the new design. Mostly because I know most of the settings by heart, so I just use the search function.

 

So he's essentially making the same "mistake" we had in the first design; assume that everyone uses (or likes to do atleast) software in exactly the same way. 

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Hello
I was already looking forward to the usable sidebar. But it doesn't work. The area where values are displayed is only the top half of the screen.
Mac OSX 10.13.5 on mac Pro

 

7xWTa_s.png

Share this post


Link to post
Share on other sites
Posted (edited) · Sidebar GUI for Cura 4.0

A newer version of the plugin is available further down the thread from where you have downloaded it:

 

 

Edited by ahoeben

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Hi, sorry for question but i'm pretty new with cura.  How to install this plugin ?  sidebar standard cura 4 is unusable....

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

@marcottt:

After downloading, you can install the plugin by dropping it into a running Cura 4.0 BETA window. Restart Cura, and you should get a sidebar in Cura 4.0 beta.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0
On 1/14/2019 at 12:03 PM, nallath said:

I know. But I kinda like the new design. Mostly because I know most of the settings by heart, so I just use the search function.

 

So he's essentially making the same "mistake" we had in the first design; assume that everyone uses (or likes to do atleast) software in exactly the same way. 

heyaa,

 

pretty sure im 3times faster with scrolling to the settings cuz i know where the setting is than u with typing those mostly long setting labels  and waiting for the search results to pop up, and the load time of the search results is very bad, too. thats why i gave up the search in 3.6 already and learned the positions of the settings.

 

 

only one pro cura is left, and this is tree support. if other slicers start to implement it i finally can completly shutdown cura 4 ever.

but yep, ur tree support is great.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

The SidebarGui plugin is now available from the Marketplace. Note that the version from the Marketplace is only compatible with Cura 4 beta 2. If you are still using Cura 4 beta 1, please upgrade to beta 2.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

i think have find a little bug: if you have cura 4 beta 1 and sidebar installed, when you install beta 2 and keep configuration, the slicer slide (the slider where there is the number with layer to investigate slicing result) disappear (i think is behind the menu). 
You need to remove plugin, when restart and install plugin from market.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Yes, this is a known problem. The "beta" version linked in this thread is ONLY compatible with beta 1. The version in the Marketplace is ONLY compatible with beta 2. I hope the version in the Marketplace will be compatible with the final release of Cura 4, but I can not guarantee.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Good job on this plug-in. Seems to work very well.  I was just wondering, is there a way to switch back to the standard gui without uninstalling this plug-in ? I didn't se an enable/dis-able button anywhere.

 

Thanks

 

-RC

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

In Marketplace there is an “Installed” tab. You can disable plugins there. You still have to restart Cura.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Thank you, your plugin works very well. I just installed cura 4.0 and had no Idea what was going on. I like to scroll through all my settings every time I load a new model. I don't understand why the developers think its better to search for a dozen different settings rather then scroll through the list and fiddle with each one as you go, especially when the search feature is so slow, although it does seem a bit snappier in this version.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

powerfull job. I like the add-on. I am using it with 4.0.0 version.  thanks a lot. 

one question : where is the "support bloker (E) " ?

 

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

The Support Blocker tool can be found in the toolbar on the left. The Sidebar GUI plugin does not change that.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

He,

tks for your answer.

 This was ok  in 3.6 but not on my 4.0.0 version :

blocker.thumb.jpg.bae0762797f5a0b193d3521b01fe6e0e.jpg

Note that if I import  3MF file which include blocker from 3.6 , they are still working well. I may handle them in 4.0.0 without problem (copy ok) but can not create any new one

What did I miss ?

kind regards

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Well.

I un-install both versions 3.6.0 and 4.0.0 with "Revo uninstaller" to be sure to clear every things, and re-install 4.0.0 and 3.6.0.

Miraculously, the section "support blocker" has reappeared on both sides.

661459578_retourdublocker.thumb.png.b786ae8817b4af2ab323dccec7ef68d8.png

ouf :)

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Cool. But that still has nothing to do with the Sidebar GUI plugin.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Correct, the Sidebar GUI is working quite well and is very powerfull.

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Am it the only one where I can't change parameters in the sidebar after a while? A restart of Cura 4.0.0 does fix the issue only to have it come back 10 minutes to 5 hours later. Without this plug in, the issue never happens. The fix by uninstall was recommended on a different forum - so known issue? A fix in the future?

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

I have an Anycubic I3 mega and a MK3S. I connect both without any problem via USB ( Windows 10 family version 1809)  under Pronterface.

I am out till end of the week. when back, I will check under CURA with your wonderfull Sidebar GUI. ( Did I say tks for it ?) 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

I should have said thanks too - I absolutely love this plug in - just wish I didn't have this issue where I can't edit parameters - i did follow this link and yes, for me, different installs on different computers end up with the same issues. (1 printer initially, but 3 now, with Octoprint, now Ender with Klipper - man do I love it!!!)

 

Thanks. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Sidebar GUI for Cura 4.0

Sidebar GUI doesn't seem to be working in Cura 4.1, is that something I'm just messing up on, or is it b/c the plugin has to be updated to work with 4.1?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!