Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker S5 camera stops working after a while


axelaxel
 Share

Recommended Posts

Posted · Ultimaker S5 camera stops working after a while

Hello,

 

our Ultimaker S5's camera stops working after continuously streaming for a while, about 4 to 7 days.

After it stops working, accessing the stream at <ipaddr>:8080/?action=stream or <ipaddr>:8080/?action=snapshot loads forever without any image data transferred.

mjpg-streamer reports no errors, other HTTP API endpoints still work. After restarting mjpg-streamer it works again, until it doesn't.

I have found this issue jacksonliam/mjpg-streamer/issues/100 on a fork of mjpg-streamer describing the same problem.

 

The printer is running firmware version 5.2.8.20190320 but this happened with previous versions too.

 

Here is the most recent log, but there are no errors. The stream stopped sometime on the 31st of March:

root@ultimakersystem-<macaddr>:~# journalctl -u mjpg-streamer@0.service
-- Logs begin at Wed 2019-03-27 09:17:19 UTC, end at Mon 2019-04-01 08:29:11 UTC. --
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: starting application
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: MJPG Streamer Version.: 2.0
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: Using V4L2 device.: /dev/video0
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: Desired Resolution: 800 x 600
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: Frames Per Second.: not limited
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: Format............: JPEG
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: TV-Norm...........: DEFAULT
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: www-folder-path...: disabled
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: HTTP TCP port.....: 8080
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: username:password.: disabled
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: commands..........: enabled
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: starting input plugin input_uvc.so
Mar 27 09:17:19 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: starting output plugin: output_http.so (ID: 00)
Mar 27 09:32:47 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>
Mar 27 13:13:31 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>
Mar 27 15:29:06 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>
Mar 28 15:08:26 ultimakersystem-<macaddr> mjpg-streamer[525]: Ignoring empty buffer ...
Mar 29 09:04:28 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>
Mar 29 11:35:33 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>
Mar 29 12:17:28 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>
Mar 30 13:50:00 ultimakersystem-<macaddr> mjpg-streamer[525]: Ignoring empty buffer ...
Apr 01 07:03:18 ultimakersystem-<macaddr> mjpg-streamer[525]: MJPG-streamer [525]: serving client: <ipaddr>

mjpg-streamer version:

MJPG Streamer Version: 2.0
Compilation Date.....: Jun 29 2017
Compilation Time.....: 13:49:26

 

  • Link to post
    Share on other sites

    • 9 months later...
    Posted · Ultimaker S5 camera stops working after a while

    It is an old problem which still exists. After some time, can be days, sometimes weeks, the stream is not working anymore. A Cura Connect Reset via the printer menu helps to recover the stream again.

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    We are having the same problem with our new S5 too. The reset of Cura connect on the printer fixes the camera, but only for a short time.  Never have a problem sending prints over the network to the printer. It is a hard wired network. Not using wifi

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Yes it is not depending how you have connected the printer and only the video stream is affected.

     

    UM3 has the same issue, so it is not isolated to the S5. 

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Thank you for your replies.

    Reset of Cura connect also resets all the analytic data, so we do a reboot of the printer. 

    Is the video stream problem related to an unstable connection?

     

    I have one display constantly showing the webpage "/print_jobs".

    Will printing the printer connection looks very unstable, every 1-5 minutes its is unavailable for 1-3 seconds.

    Is this a part of the same problem? 

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Hi. Are there any news about that topic? We have 3 Ultimakers and the webcam on all printers stop working after a couple of hours.

     

    Kay

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Maybe @robinmdh knows something?

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    It seems not ...unfortunately. Is there an easy way do downgrade the firmware? I just find the actual firmware to download. 

     

    Kay

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Yes, absolutely but requires removing the bottom cover.  Talk to your reseller.  For a while they would only let you downgrade UM3's and S3s because the S5 has deadly  voltages inside but if you promise to be careful  and demonstrate competence you can downgrade S5 as well now.  They really really really don't want you to kill yourself.

     

    You will need a micro SD card.  Here are the general instructions but only the resellers know where to get the images:

     

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    is there a fix for this?, what is the cause?. I usually just reboot the printer, but it's getting old. Please advise.

     

    thanks!

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Not yet, but I heard/read something that the next firmware could have a fix for it.

    The cause is that the mjpgstreamer process which is responsible for the video streams dies after some time. 

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Hello. We've updated one of our US5 and we still have the problem with the stream.

     

    Kay

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Also having this issue, trying to spend as little time at work as possible at the moment. So not been able to monitor prints from home as the webcam stops working after 30minutes is a pain!

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Hello, thank you all for your messages. This should most likely be fixed in the upcoming firmware, not the existing firmware. It is currently being tested. For the time being it helps if your Ultimaker S5 (Pro Bundle) is connected via ethernet. Thank you for your time and our apologies for the inconvenience! 

    • Thanks 1
    Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Hello everybody, 

     

    Hope you are all well. I am happy to inform you that the new firmware has been approved after testing. This means we will move forward with the release next week. This message is not an official release notice, but I've told you I would let you know as soon as more information is available, so here we are. We still have to prepare some things for the actual release, hence it will be next week. When it is officially released the release notes will be published in the firmware thread. You can follow the category and receive a notification when a new post is added. I hope knowing help is on the way will make up for something. 

     

    Have a great weekend, 

    • Thanks 1
    Link to post
    Share on other sites

    Posted (edited) · Ultimaker S5 camera stops working after a while

    Our printer has the new firmware for three days now. I have a camera stream open also for three days now in VLC.

    For now it is still working. This was only working for a maximum of a few hours before the new update.

     

    Thank you for your work and the messages. 

    Edited by TomLoonen
    • Thanks 1
    Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    Hi. We still have the issue with the camera feed on our US5. And yes we've installed the newest firmware. Does anybody also have this problem after updating to the newest firmware?

     

    Kay

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while

    We haven't had any problems anymore after the update.

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while
    1 hour ago, kayle said:

    Hi. We still have the issue with the camera feed on our US5. And yes we've installed the newest firmware. Does anybody also have this problem after updating to the newest firmware?

     

    Kay

     

    Doesn't it reconnect automatically if it would happen?

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while
    3 hours ago, SandervG said:

     

    Doesn't it reconnect automatically if it would happen?

     

    Unfortunately not, no. I had to SSH to our ultimaker and reset the mjpg-streamer by myself 😞

     

    Kay

  • Link to post
    Share on other sites

    Posted · Ultimaker S5 camera stops working after a while
    On 8/26/2020 at 2:10 PM, kayle said:

     

    Unfortunately not, no. I had to SSH to our ultimaker and reset the mjpg-streamer by myself 😞

     

    Kay

     

    Let me check with our product experts what they think is worth checking. Has this happened once, or (still) frequently?

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...