Jump to content
Ultimaker Community of 3D Printing Experts
xperiment

Cura verschliesst Öffnungen

Recommended Posts

Folgendes Anliegen: Ein Objekt in Sketchup erstellt und im Boden eine Öffnung gelassen, die in das hohle Objekt führt.

Aber jedesmal wenn ich das Objekt in Cura lade, verschliesst er mir das Loch und produziert eine geschlossene Plattform am Boden! Egal welche Einstellung ich bei Cura ändere.

In der normalen Ansicht wird mir das Objekt zwar regulär angezeigt, jedoch sieht man den geschlossenen Boden in der Layer Ansicht :-(

 

Share this post


Link to post
Share on other sites

Kontrolliere doch mal, was in Cura unter Expert - Open Expert Settings... (oder CTRL + E) im Bereich 'Fix horrible' eingestellt ist.

Ich würde hier mal alle Hacken raus nehmen und dann nochmal überprüfen ob das Loch nun offen ist.

 

Share this post


Link to post
Share on other sites

Alles schon probiert, ich druck es jetzt ohne Loch und bohr dann eins rein! Seit Stunden sitz ich daran!

Ist das Loch durchgängig, ist alles kein Problem. Aber ein Loch von unten in einen hohlen Raum ist wohl zu komplex ;-)

@Teddy: Das ist http://www.thingiverse.com/thing:31331

Ich wollte in die Bodenplatte halt ein Loch haben, damit ich dort Sand als Gewicht reinfüllen kann. Ich denke nicht das die Datei kaputt ist. Sketchup zeigt mir ja alles richtig an, auch Meshlab hat das Loch noch im Modell. Nur Cura verschliesst es in der Layer Ansicht! :-(

 

Share this post


Link to post
Share on other sites

Hey,

das Problem hatte ich auch schon bei diversen anderen Objekten. Meines Wissens gibt es da auch keine wirklich Lösung in cura,da das Objekt immer aus einer geschlossenen Hülle bestehen muss ( da die "wände" in 3D-Programmen faktisch keine Dicke besitzen).

Die einzige "Lösung" die ich für mich gefunf´den hatte,war das Objekt im 3D Programm Doppelwandig zu gestalten und dann mit infill zu drucken.

 

Share this post


Link to post
Share on other sites

Wenn ich beim Loch quasi ein Rohr nach oben in den Hohlraum ziehe, wird lustigerweise das Loch richtig angezeigt, jedoch verschliesst Cura das Rohr dann oben beim Ende wieder. Das gibts doch nicht!

Gibt es noch Alternativen zu Cura?

 

Wenn ich Dich richtig verstanden habe, bringt das mit dem Cut Offset in Cura auch nichts?

EDIT: Machst Du ein Loch irgendwo in die Oberfläche (sprich Löschen der Flächen) oder modellierst Du effektiv einen Hohlraum? Nur mit der zweiten Variante wird ein Slicer zurecht kommen...

 

Share this post


Link to post
Share on other sites

Ich hab' das Ganze gerade mal in Blender probiert:

- original STL File importieren

- Modifier 'Solidify' darauf anwenden (hier gewünschte Wandstärke definieren)

Somit wird aus dem Vollkörper ein hohler Körper mit definierter Wandstärke.

Danach noch einen Zylinder vom Boden per Modifier 'Boolean' abziehen um somit das Loch rein zu modellieren.

Export als STL.

Das Ergebnis in Cura zeigt das gewünschte Loch.

Evtl. kann Blender hier mehr (oder arbeitet sauberer) als Sketchup.

 

Share this post


Link to post
Share on other sites

Hallo,

Meine Erfahrung dazu mit einem Rohr mit einseitigem Flansch:

Modell wurde in Trimble (Sketchup) erstellt

Ausdruck mit CURA und UMO+

Problem

Das Rohrende am Flansch wird verschlossen gedruckt, obwohl im STL - Modell offen dargestellt.

Sichtbar wird das in Cura wenn man die Schichten durchfährt

Abhilfe

Modell in Netfabb Basics laden und markieren

Unter Extras „New Analyses“ durchführen

In der Infospalte rechts werden „flipped Triangles“ angezeigt, werden auch im Modell mit anderen Farben angezeigt

Unter „Extras“ auf „Repair Part“ gehen, im Menü „Fix Flipped Triangles“ wählen und „Apply Repair“. Die Falschfarben verschwinden im Menü.

Unter „Part“ das Modell exportieren

Der Druck mit diesem Modell ist in Ordnung

Ursache: speziell bei Sketchup kann es sehr leicht passieren, dass die Oberfläche falsche Orientierung bekommt und man das nicht erkennt.

Share this post


Link to post
Share on other sites

Hallo Zusammen

Ich vermute hier den Standard Fehler bei solchen Sachen. Du kannst nicht einfach ein Loch machen indem du ein Polygon löscht. Die wird Cura automatisch als Polygonfehler erkennen und verschliessen. Du musst das loch modellieren.

Polygone haben zwei Seiten eine innen und einen Aussenseite, dementsprechend ist auch dein Objekt aufgebaut. Wenn plötzlich ein Polygon mit der innen Seite nach aussen zeigt, ist das für Cura unverständlich und es probiert den schaden zu reparieren.

Grüsse

zpm3atlantis

Share this post


Link to post
Share on other sites

Hallo,

ich habe da ein ähnliches Problem wenn ich einen Zylinder in Sketchup modelliere, nur das aber Cura den Zylinder oben nicht schliesst.

Auf dem Foto zu erkennen.

UGBAjZI.png

Der Zylinder ist nicht abgeschlossen. (Aussenwand zur Innenwand)

Wenn ich mir dies im Blender anschaue. Sieht dies gut aus.

7U9IfXC.png

Ich habe schon einige Zylinder in Sketchup modelliert, einige sind OK die anderen eben nicht. Ich modelliere sie immer gleich. Ich habe aber noch nicht herausgefunden warum es manchmal geht und manchmal nicht.

Share this post


Link to post
Share on other sites

Hallo,

ich habe da ein ähnliches Problem wenn ich einen Zylinder in Sketchup modelliere, nur das aber Cura den Zylinder oben nicht schliesst.

 

Es kann an SektchUp liegen, das es defekte STL erzeugt. Der Wechsel auf ein anderes CAD wäre anzuraten. Ich verwende DesignSpark Mechanical. Das kostet nix und funktioniert ähnlich wie SketchUp, erzeugt aber vernünftige Dateien für Cura & Co.

Oder Du hast die falschen Einstellungen in Cura. Welche Version hast Du am laufen?

Die Wandstärke sollte immer ein vielfaches vom Düsendurchmesser sein, sonst kann es vorkommen das Cura das nicht richtig füllen kann.

Share this post


Link to post
Share on other sites

und wie so kann nicht CURA ein Problem haben?

ich habe mir mein Modell in Blender nochmal angeschaut, und es scheint mir das die Polygone korrekt sind.

Q4Vx3JV.png

oder nicht?

In Cura aber so aussehen:

2ZsGpP9.png

 

Sicher kann auch Cura ein Problem verursachen.

Der Vergleich mit Blender und Cura kann aber nicht funktionieren. Blender ist ein 3D Programm, Cura zeigt die Daten aber als umgerechnetes Schichtmodell an. Was zeigt Dir Cura denn bei 100 InFill?

Share this post


Link to post
Share on other sites

Was zeigt Dir Cura denn bei 100 InFill?

 

Das gleiche.

Ich habe jetzt meinem Kollegen den Auftrag gegeben das ganze in seinem Professional 3D Programm zu zeichnen. Das gleiche Programm benutzt er auch für Maschinen Teile zu zeichnen. Mal schauen wie diese dann in Cura aussehen.

Share this post


Link to post
Share on other sites

Hallo Leute,

ich habe den Fehler mit der (Bohrung) rekonstruiert.

Objekt wurde mit Flächen erstellt und nicht als Körper.

Cura verabeitet das Objekt je nach Richtung ob liegend oder stehend ist.

Das gleiche Objekt wurde 3 mal geladen und nur die Lage verändert und das sieht so aus. Das erklärt warum die (Bohrung) verschwunden ist.

111.thumb.JPG.48f2678e6aeeb97eb2472ca764d12689.JPG

222.thumb.JPG.8f7fbfa91a4afb7c8089ee97f5524dd2.JPG

Bei Craft Ware sieht so aus.

333.thumb.JPG.a47834ed28196b8919b935e143b9f8ac.JPG

444.thumb.JPG.44b8334caa232b2466f5c26c5def89ae.JPG

Das Objekt kann durchaus in Ordnung sein, nur die Programme intepretieren sie unterschiedlich.

Und hier das Objekt.

https://drive.google.com/open?id=0B8SLtGEIZlAEcWw2NkREby01YUk

111.thumb.JPG.48f2678e6aeeb97eb2472ca764d12689.JPG

222.thumb.JPG.8f7fbfa91a4afb7c8089ee97f5524dd2.JPG

333.thumb.JPG.a47834ed28196b8919b935e143b9f8ac.JPG

444.thumb.JPG.44b8334caa232b2466f5c26c5def89ae.JPG

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Introducing Ultimaker Cura 3.6 | Beta
      Ultimaker Cura 3.6 | Beta is available. It comes with new features, bug fixes, and UX improvements. We would really like to have your feedback on it to make our stable release as good as it can be. As always, you can download the beta for free from our website, for Windows, MacOS, and Linux.
        • Like
      • 95 replies
    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
        • Like
      • 30 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!