Jump to content
Ultimaker Community of 3D Printing Experts

Adding 12V LEDs to Ultimaker


Recommended Posts

Posted · Adding 12V LEDs to Ultimaker

Hi Guys,

I have a string of 12V white LEDs that I want to add to the ultimaker, so I can see prints better.

Know anywhere where I can connect them to, that supplies 12V?

Thanks :) I'm new to Arduino

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker
    I have a string of 12V white LEDs that I want to add to the ultimaker, so I can see prints better. Know anywhere where I can connect them to, that supplies 12V?

    There isn't much spare 12V supply in the UM, you can draw some extra current from the port that runs the stepper fan, but the LM7812 that is providing the 12V for the fan will get hot, and needs a cooling fin, or other cooling means, plus it can not support infinite amounts of current (I think they are rated 1A, but drawing 12V 1A means that 7W heat are generated, enough to kill that little thing without cooling).

    I made a custom board, with 2 additional LM7812, getting 19V from the heated bed terminal, and GND where ever it's convenient for you:

    _MG_2277%252012V%2520supply.jpg

    _MG_2278%252012V%2520supply.jpg

    but they are still getting warm... the average 12V LED strip draws about 200mAh, so connecting about 3 to each LM7812 is well within bounds, 4 is probably still OK, depending on the size of your cooling fin.

    For another project I am using proper voltage controllers: http://www.pololu.com/catalog/product/2110 and should have used that one instead of the two LM7812, but now I am too lazy to fix it, since it works.

    as another simple alternative, you can power 12V LED strips (and additional fans) from and external power supply, I have for example an old apple iPod firewire charger (first gen iPod!) that will happily supply 12V, and FW400 cables are abundant (simply chop of one end, and wire the 2 power supply cables accordingly, ignoring the 4 data wires.

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    Hmm I connected quite a long LED strip, removing now for fear of overheat. The light wasn't constant too and appeared to pulse in sync with the 12V fan current - I'm assuming the fan motor is pulsed to save energy, seems that way.

    More importantly, you mentioned there's a 19V terminal for a heated bed? I want to try printing in ABS as what little that I've printed looks awesomely smooth! Anyway for me to connect a HBP?

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker
    More importantly, you mentioned there's a 19V terminal for a heated bed? I want to try printing in ABS as what little that I've printed looks awesomely smooth! Anyway for me to connect a HBP?

    Yes, there is 19V in many places, that is the juice that is coming from the power supply. the stock power supply has 120W iirc, which isn't enough to run a HBP (which needs 80-200W, depending on what kind you like, just by itself, and hooking it up to your stock power supply will not end well). see HBP discussions on the google group, and elsewhere in this forum.

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    I'm not really good with electronics (Still on the "Don't let the smoke out" theory, ha) but I am wanting to do this.

    Will I need any capacitors to run this to avoid "noise" or is it fine without since the input is DC? I am only trying to run one set of LED's from the spot on the board labeled 19VDC LED. It is the "Dioder" set from IKEA of flexible RGB lights I had lying around. Transformer from the wall outlet says it's output is 12VDC 5W max. I already have them in place and they look great, only eyesore is taking up 2 outlets.

    I'm honestly not even sure how to use a breadboard. Could you please provide like a diagram or something of the sort of what you did up there? Do I need multiple regulators? Easily upgradeable to add fans like you have in the future?

    Sorry to ask a million questions, any help appreciated.

    -Mike

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    LED_Volt_Reg_Circuit.jpg

    Just hooked this up and it works perfect!

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    Ooo can't see your photo! :p Where did you connect it to?

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    It works if you go directly to the image:

    http://postimage.org/image/y2n7xnnzb/

     

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    So it's an add-on circuit? Like a bread board? :)

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    Sorry about that.

    LEDVoltRegCircuit.jpg

    I connected to the Ultimaker where it says "LEDs 19VDC". It's near where you plug in the heater wires for the extruder on the side.

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    dd321a4a.jpg

    0272e2ba.jpg

    Don't make fun of the screw! Haha, it's all I had, ripped it out of a busted monitor cable. The screw in the first picture was temporary (wrong thread pitch, just jammed it in to hold it on there for a while)

    7fc92d65.jpg

    b6ea9a0e.jpg

  • Link to post
    Share on other sites
    Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker
    dd321a4a.jpg

    I should maybe add some caps into my setup also...

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    You can run LEDs off of any voltage you want. If your LEDs already have a current limiting resistor (they probably do if they are labeled as 12V LEDs) then you will just need to add an additional resistor in series with the LED to adjust the current limit for the higher (19V) power supply voltage. Regular LEDs consume VERY little current compared to everything else in your printer (~20mA). If I make some assumptions about your LED I would guess that it has around a 560 ohm resistor in series already (20mA maximum current, 12V, 2.0V forward LED voltage). To safely run off of 19V you can just add another 560 ohm resistor. However, that will keep the current through the LED roughly the same, if it's too bright or you don't mind it being a little less bright you can always run it with a 1k resistor without any issues.

    -Matt

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker
    You can run LEDs off of any voltage you want. If your LEDs already have a current limiting resistor (they probably do if they are labeled as 12V LEDs) then you will just need to add an additional resistor in series with the LED to adjust the current limit for the higher (19V) power supply voltage. Regular LEDs consume VERY little current compared to everything else in your printer (~20mA). If I make some assumptions about your LED I would guess that it has around a 560 ohm resistor in series already (20mA maximum current, 12V, 2.0V forward LED voltage). To safely run off of 19V you can just add another 560 ohm resistor. However, that will keep the current through the LED roughly the same, if it's too bright or you don't mind it being a little less bright you can always run it with a 1k resistor without any issues.

    please keep in mind that we were (probably) talking about LED strips, which use up a much greater current than a single LED...

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    The RGB strips I used run about 400mA

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    Omg the light! Haha! That looks amazingly bright!

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    You inspired me to add my own lights.

    I found these super bright diodes at Clas Ohlson. 5000 mcd, 3.2V 20mA

    4 of them and a small resistor only draws 20mA from the 19V and I have 20000 mcd of light :-)

    And of course I needed to add a light-switch 8-)

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    [Removed]

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker
    You inspired me to add my own lights.

    I found these super bright diodes at Clas Ohlson. 5000 mcd, 3.2V 20mA

    4 of them and a small resistor only draws 20mA from the 19V and I have 20000 mcd of light :-)

    And of course I needed to add a light-switch 8-)

    That's a pretty nice setup you have going there!

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker
    That's a pretty nice setup you have going there!

    Thank you. I could probably have added two more diodes to get 50% more light without the resistor and still at ~20mA, but I only had one more diode and the shop was too far away ;-)

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    Does the size of the Elco's matter Kit? From what I understand it would only take longer to 'fill up'. So taking a 1000uF in stead of a 10uF? Or will that introduce stability issues? Isn't the 19V already stable and filtered?

    I can't seem to find smaller caps here at home. I do have the 0.1uF though. I also seem to find enough diagrams where they just hook up the 0.1uF's without the elco's.

     

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    So, I made my 7812 board to take 19V from the LEDs pins and convert it to 12V to power the IKEA Dioder leds.

    It works!

    http://i.imgur.com/5IaEPrW.jpg

    http://i.imgur.com/Utkj96h.jpg

    It uses 0.22A @ 12V. The heat sink looks kinda overkill, but the 7V difference times 0.22A is still roughly 1.5W and it got pretty hot. Better safe than sorry.

    It works with a manual switch to turn the leds on and off, but is hackable to use Gcode if need be later on.

     

  • Link to post
    Share on other sites
    Posted · Adding 12V LEDs to Ultimaker

    Great work!

    Did the same app. one year ago, also with a manual switch. Up to now my 7812 is still fine - can recommend your/our solution :-)

  • Link to post
    Share on other sites

    Archived

    This topic is now archived and is closed to further replies.

    ×
    ×
    • Create New...