Jump to content
studioAdhoc

UM3E _ build plate far away from printheads (10cm)

Recommended Posts

Posted · UM3E _ build plate far away from printheads (10cm)

Hello, I'm coming up to you about an issue I have with a UM3E that I tried to use after few months of inactivity.

 

I installed the last firmware normally via the printer but, when I wanted to start a print, the UM3E failed during auto levelling step.

Actually, the build plate stops at 10 centimeters from printheads, even if I try to level it manually.

 

I tried every "normal" ways to solve the problem, user reboot, factory reboot, second setup of the firmware, via USB this time… nothing changed.

 

The printer acts as if it was an UM3 not Extended, but it is… Every print I launch is considered too big for the printer, even the smallest thing. Maybe there is a conflict between Cura, where the printer is correctly set, and the firmware of the printer, set on the UM3 height instead of UM3E height.

 

I really don't know how to check in the firmware and if it is possible to fix my UM3E…

Please, help ! 

 

DSCF7651.JPG.bf6cd54079fe784cee919d36c9cb0548.JPG

Build plate "raised"

 

DSCF7652.JPG.91a4193da8e5fd093dfc61a7c3a4e682.JPG

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)
29 minutes ago, studioAdhoc said:

The printer acts as if it was an UM3 not Extended, but it is…

 

Your printer has an identity crisis...?

- the question is... why? Did it got a new mainboard recently?

 

This topic may help:

 

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)

Hi @tinkergnome, thank you for the quick answer!

There is no obvious reason that could explain this identity crisis but few months of sleeping in a dark place… Every part comes from the original brand new box.

 

The topic seems to talk about the same issue and I'm excited about trying @Daid 's solution :

 

Quote

python3 /ulti_installer/configure_eeprom.py 9066" (or 9511 if you need an extended instead of a normal UM3)

 

But I don't know how to send this command line to the printer… Is there a console on Cura ? Or do I have to install Python 3 ?

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)

I would first try a factory reset as you will have to put your UM3EXT into developer mode and log in for the procedure described above.

Share this post


Link to post
Share on other sites
Posted (edited) · UM3E _ build plate far away from printheads (10cm)
5 hours ago, studioAdhoc said:

But I don't know how to send this command line to the printer

 

If you want to do this, you have to connect with an ssh client to the printer.

In developer mode you can access, delete and change any file on the printer. That means you can completely mess up your device - so be very careful. If you have no clue what ssh is or how a linux system works... you should better ask your reseller for assistance - give him/her the link from the topic that is mentioned above (better safe than sorry...)

 

As a minimum for the DIY approach: read the first paragraphs of this topic about "developer mode" and "what does it do" before you start:

 

 

 

BTW:

what is the output for the "Hardware type ID", if you scroll down on this screen?

DSCF7652.JPG.91a4193da8e5fd093dfc61a7c3a

 

Edited by tinkergnome
  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)

Okay, I think I understood what I have to do but I'm not really used to this kind of tricky business.

Without instructions for Windows, I think I won't be able to solve this by my own…

I have no idea of how I could connect to the ssh server.

 

@tinkergnome the Hardware Type ID is 0, it must be related to the "unknown" type of the printer.

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)

Yep. the correct ID should be "9511" (for an UM3ext)

Authorized resellers from your country should be able to configure it for you, or can provide you with detailed instructions.

Good luck!

 

Share this post


Link to post
Share on other sites
Posted (edited) · UM3E _ build plate far away from printheads (10cm)

Hi, I asked a friend with more skills than me for some help 

 

He acceed to the ssh server of the printer, logged in with ROOT and tried to launch Daid's command (seen above) to set the Hardware type ID to "9511".

 

But,

an error occured, with this message (last line) :

python3 /ulti_installer/configure_eeprom.py 9511
Traceback (most recent call last):
  File "/ulti_installer/configure_eeprom.py", line 24, in <module>
    eeprom = EEPROM()
  File "/ulti_installer/eeprom.py", line 22, in __init__
    self.__mac = binascii.hexlify(f.read(6)).decode('ascii')
TimeoutError: [Errno 110] Connection timed out

So the connection timed out, apparently…

We were so close… and we can't figure out why did it happen.

Edited by studioAdhoc

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)

seems like the system can not even read from the EEPROM, the comment in eeprom.py say:

# Location of the EEPROM in the filesystem (eeprom is exposed as a file-like object by linux)
__SYSTEM_EEPROM_FILE = "/sys/bus/i2c/devices/1-0050/eeprom"

Your friend can check, if this "file" exists on the printer, but to me it looks more and more like a hardware error of the Olimex board?

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E _ build plate far away from printheads (10cm)

Hi,

We looked for EEPROM feedback and had no response...

It seem that you're right, Olimex board or the EEPROM chip must be damaged.

I hope the machine's warranty is still working !

 

So :

 

A Build Plate height issue can be caused by an "identity crisis" from the printer, that's to say the machine doesn't know what type of hardware it is. Our conclusion (so far and in this particular case) is that this identity crisis itself is caused by a hardware damage on the Olimex board, concerning the EEPROM chip.

 

Thanks a lot for your help !

I hope this printer will survive 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!