Jump to content
maht

Ultimaker Cura 4.6 released

Recommended Posts

Posted · Ultimaker Cura 4.6 released

UMS3_Highspeed-vehicle-heatcam-mount-cloud.thumb.jpg.aabc3a0b776ad312a60229a8878c9f37.jpg

 

THANK YOU to all Ultimaker Cura users helping in the fight against COVID-19 – with 3D printing, volunteering, or just by staying home. Want to get involved? Find out more.

 

What’s new in Ultimaker Cura 4.6?

 

New Intent profiles. In version 4.4 we introduced Intent profiles for the Ultimaker S3 and Ultimaker S5 which allow you to start prints at the click of a button without a lot of configuration steps. Due to popular demand, version 4.6 expands the range of Engineering Intent profiles to include more of the Ultimaker material portfolio: PC, Nylon, CPE, and CPE+. These work with 0.4 print cores.

 

During the beta period we also fixed some bugs:

 

Crash if logging in on two instances at the same time. During the beta period we caught a critical bug where logging in to an Ultimaker account with two instances of Cura would crash the second instance. It crashes because while the web page is open, Cura opens a web server in the local host. The web page redirects to that web server when you've logged in, so that it knows that the log-in was successful and what the credentials are. Both instances try to create a web server on the same port, which is impossible.

 

"Changes detected from your Ultimaker account" message. We fixed a bug on MacOS where duplicate "Changes detected from your Ultimaker account" popups would appear at a single time.

 

Crashes when inactive. Some people reported experiencing crashes when the computer had been inactive for a long time, or when the laptop got suspended or went to sleep. This has been fixed.

 

Support blocker is not blocking support. Fixed an issue where the support blocker was not blocking support.

Sending slice message takes too long when using mesh helpers. Fixed an issue where it would take too long to trigger a slice when using the mesh helpers and support blocker.


What else has changed?

 

Hole Horizontal Expansion. smartavionics has contributed a new setting that applies an offset to all holes on each layer, allowing you to manually enlarge or contract holes to compensate for horizontal expansion.

 

Transparent support rendering. In preview mode with ‘Line type’ selected, support material will render with transparency so you can easily see what’s being supported.

 

UMS3_Highspeed-vehicle-heatcam-mount-transparent-support-layer.thumb.jpg.df929ae00e3f14644b87d17c33e1c3ed.jpg

 

Infill mesh ordering. When you have three objects overlapping each other and you set two of them to "Modify settings for infill of other models", then the setting "Infill Mesh Order" determines which of the two infill meshes gets priority where they overlap. This was broken for cutting meshes, so BagelOrb contributed a fix.

 

Print monitor preheat fields. When connected via serial or using Octoprint, values in the print monitor preheat fields were broken in previous versions. They have now been fixed by fieldOfview.

 

Stepper motor disarming during pause at height. Some printers automatically disable their steppers after a pause after a certain time. This script makes it possible to set that in the pause script (instead of relying on default behavior of the firmware).

 

Updated installer. Small fixes have been made to the installer. To keep up with the times, we’ve also updated the images to display an Ultimaker S3 instead of an Ultimaker 3.

 

Third party printers

 

Flying Bear printers. oducceu has contributed a machine definition for the Flying Bear Ghost 4S Printer.

 

Magicfirm printers. jeffkyjin has contributed machine definitions for MBot Grid II+, MBot Grid II+ (dual), MBot Grid IV+ and MBot Grid IV+ (dual).

 

HMS434. Updates to the HMS434 machine definition have been contributed by maukcc.

 

FabX Pro. hussainsail2002 has contributed machine definitions for FabX Pro and print profiles for REDD materials.

 

Want to add a third-party machine definition to Ultimaker Cura? Here’s how

 

Disclaimer:  Third-party machine definitions are accepted as contributed, and will not be tested or maintained in any way by the Cura development team. Make sure anything submitted to us is thoroughly tested.

 

Plugins and the Marketplace

 

You can use the Ultimaker Marketplace to download plugins and material profiles for Ultimaker Cura. Here are some new things that have been worked on:

 

Separators in extensions menu. fieldOfview has contributed a new method for plugin authors to add separators between menu items in the “Extensions” submenu. The method is backwards-compatible so changes don’t have to be made in Cura and Uranium together.

 

SDK version bump. We also made a minor SDK version upgrade to 7.2.0

 

ThingiBrowser 2.0.0 by Chris ter Beke allows you to download objects from Thingiverse directly into Cura. It now also supports MyMiniFactory.

 

Material Cost Tools by fieldOfview allows you to export and import material cost and weight data into a CSV format for easy sharing.

 

 

Download now!

 

Thanks for all the contributions to make this release possible. A special mention goes out to smartavionics and fieldofview for their significant contributions to Cura. The full release notes have download links and even more detail about this release. 

 

Any issues you experience with Cura 4.6 should be reported on GitHub. We have an issue template, please be sure to use it so that we have all the info we need to help you. Issues with plugins should be communicated to the plugin author and not us.

 

Let us know what you think of this release in this thread!

 

Stay safe everyone!
 

  • Like 2

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

I downloaded and installed Cura 4.6 then tried to install the z-offset plugin from marketplace which said it was added to Cura. However, I couldn't find it anywhere then closed it down. When I clicked on the logo on my desktop what opened was cura 4.5, which I found had no z-offset plugin . So I removed this and inadvertently removed Cura 4.6 as well. When I redownloaded for a second time Cura 4.6 it refuses to install. How do I get it up and running and being able to add the z-offset plugin? 

I'm using an Anycubic i3 Mega-s 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

Hello,

 

I downloaded and installed 4.6 and set up- Thank you for adding Printer profile for Crealty Ender 3 Pro... It has "nozzle size" as "empty" and i cannot find where to change this. Please advise.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

Maybe try to reboot your PC. Sometimes the os needs to clean up some installation mess because files get blocked by other processes. Then install once more Cura 4.6.

Z-Offset. After installation of this plugin you will find the entries under print settings

Z-Offset.PNG

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura 4.6 released

So the issue is here:

image.thumb.png.b6799743097d43100df4ef06ec6811d9.png

 

 

Edited by jgillis
mistook a previous reply for a reply to mine

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

I'm getting weird behavior when I print a skirt with Cura 4.6.  after printing the purge line, it the nozzel moves all the way to the other side of the bed, prints one line of the skirt, then moves and prints the second line from a different starting point. in Cura 4.5 it started the skirt from a point closest to the purge line and then printed the entire skirt in one continuous line.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

A quick question concerning the new "Stepper motor disarming during pause at height" feature. In Cura, it states,

"Disarm Timeout - After this time steppers are going to disarm (meaning that they can easily lose their positions). Set this to 0 if you don't want to set any duration."

I'm a little fuzzy about this. Does this mean that if you select 0 for Disarm Timeout, the steppers won't timeout? Or will they immediately timeout?

 

cura.png

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura 4.6 released
10 hours ago, reyd8 said:

I'm getting weird behavior when I print a skirt with Cura 4.6.  after printing the purge line, it the nozzel moves all the way to the other side of the bed, prints one line of the skirt, then moves and prints the second line from a different starting point. in Cura 4.5 it started the skirt from a point closest to the purge line and then printed the entire skirt in one continuous line.

 

Also a problem with the skirt here, the purge line it is not outside my print, but in the print;  i had already 2 bad prints before i figured out what the problem was. Back to 4.5 it is. And is use a ultimaker S5.

Edited by RudydG

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

In the rotate menu, the align face to buildplate doesn't always work, I had to select a weird part to align before I could align a simple perpendicular plane

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released
4 hours ago, jgillis said:

Hello,

 

I downloaded and installed 4.6 and set up- Thank you for adding Printer profile for Crealty Ender 3 Pro... It has "nozzle size" as "empty" and i cannot find where to change this. Please advise.

I am having the same problem.  I am on a MAC with the latest OS.  I had Cura 4.1 with Creawesome Mod installed.

Screenshot 2020-04-21 15.54.19.png

Screenshot 2020-04-21 15.57.07.png

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

You guys need to tell us who are handling 3rd party printers exactly what it is you are doing between these versions to render the [self censored] nozzles sizes we create unavailable with each version. It's getting tedious.

 

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

3rd party printers are usually not the responsibility of the Cura development team. How it works is, that you need to ask the owner of this setup or better Creality to support their printer with an working setup profile.

 

Beside this, maybe it is worth to check wether setup a new printer profile helps. This is not a general problem because I had test it just before with creating a new printer profile from the printer definitions and there I have a nozzle size ;).

Hope this will help.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released
13 minutes ago, DivingDuck said:

3rd party printers are usually not the responsibility of the Cura development team. How it works is, that you need to ask the owner of this setup or better Creality to support their printer with an working setup profile.

 

Beside this, maybe it is worth to check wether setup a new printer profile helps. This is not a general problem because I had test it just before with creating a new printer profile from the printer definitions and there I have a nozzle size ;).

Hope this will help.

 

I think you misread what I was asking. I AM the one who writes the profiles every release. You also misjudged that I wa stalking about Creality. Blegh. (laughs) I t IS a general problem when you have a handful of printer models and you are trying to play ball with the catalog of now expansive nozzles and profile shenanigans present in the system that been put in. 

 

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura 4.6 released

Well, no. I OWN one beside of 5 other self builds. And they are running all with the 4.6 beta and 4.6 from yesterday. Don't start blaming as I also don't do it...

 

Edit:

Well maybe I had a bit overreacted after reading the conversation again... I understand your point.

 

Beside this, when you create a new printer profile from your definition files, like an Ender 2 or 3 it looks like the nozzles are available again.

Edited by DivingDuck

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

For the Ender 3 related questions: third party printers are merged with Cura via pull requests. A list of the latest changes for these printers can be found here. If you look through the pull requests list on our repo, you are able to see all the latest third party printer changes.

 

We need to take a hands off approach to third party printers because there are many, many variables to account for and no way for us to test them. The responsibility of testing falls on the contributor.

 

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released
18 hours ago, kruegkel said:

I am having the same problem.  I am on a MAC with the latest OS.  I had Cura 4.1 with Creawesome Mod installed.

Screenshot 2020-04-21 15.54.19.png

Screenshot 2020-04-21 15.57.07.png

 

I had the same problem when trying to add a new "Ender 3 Pro" printer.
It works if you check "Ender 3" instead.
I think it's because variants are missing from ressources for Ender 3 Pro.

Capture.PNG

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

Cannot open Cura 4.6 after install on macOS Catalina 10.15.4 (downloaded and dragged into the applications folder). I have seen similar pop ups when other applications had not been optimized/updated for the latest macOS.

 

Can I download 4.5 for now?

Screen Shot 2020-04-22 at 2.35.23 PM.png

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released
13 hours ago, mkompas said:

Cannot open Cura 4.6 after install on macOS Catalina 10.15.4 (downloaded and dragged into the applications folder). I have seen similar pop ups when other applications had not been optimized/updated for the latest macOS.

 

Can I download 4.5 for now?

Screen Shot 2020-04-22 at 2.35.23 PM.png

 

We need to update the Apple certifications and with everyone working from home that hasn't been possible (not many of us use a mac). It is a known issue and we're going to fix it.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released
14 hours ago, ahoeben said:

 Thank you!

 

3 hours ago, maht said:

 

We need to update the Apple certifications and with everyone working from home that hasn't been possible (not many of us use a mac). It is a known issue and we're going to fix it.

Completely understandable. Thank you for the feedback.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

I had the same problem. You have to allow Cura to open. Under Security settings is a new button where you enable Cura to start.

 

The Error Message is a little bit confusing.... 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released
5 minutes ago, zungara said:

I had the same problem. You have to allow Cura to open. Under Security settings is a new button where you enable Cura to start.

 

The Error Message is a little bit confusing.... 

That worked thank you!

 

Within system preferences under Security and Privacy, in the General tab, a message will be displayed to allow Cura to open once you're presented with the error.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura 4.6 released
Quote
On 4/22/2020 at 11:15 AM, ezekiel777 said:

 

I had the same problem when trying to add a new "Ender 3 Pro" printer.
It works if you check "Ender 3" instead.
I think it's because variants are missing from ressources for Ender 3 Pro.

Capture.PNG

 

SOLVED:

 

You are correct.  If you copy the files:

 

  • creality_ender3_0.2.inst.cfg
  • creality_ender3_0.3.inst.cfg
  • creality_ender3_0.4.inst.cfg
  • creality_ender3_0.5.inst.cfg
  • creality_ender3_0.6.inst.cfg
  • creality_ender3_0.8.inst.cfg
  • creality_ender3_`1.0.inst.cfg

 

name the copies as:

 

  • creality_ender3pro_0.2.inst.cfg
  • creality_ender3pro_0.3.inst.cfg
  • creality_ender3pro_0.4.inst.cfg
  • creality_ender3pro_0.5.inst.cfg
  • creality_ender3pro_0.6.inst.cfg
  • creality_ender3pro_0.8.inst.cfg
  • creality_ender3pro_`1.0.inst.cfg

 

I don't know if this part is necessary but within all those files I changed the 4th line from:

 

  • definition = creality_ender3

 

to:

 

  • definition = creality_ender3pro

 

And everything works now.  

 

 

Edited by erikk

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

So it looks like we will do a patch release next week to fix some algorithm issues. While we're at it we can probably pull in some changes for Creality printers as well.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.6 released

Awesome you guys are always updating! One question Why no intent profiles View for older models? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...