Jump to content

Material Sync not working


kwakefield

Recommended Posts

Posted · Material Sync not working

I have an UMS5 and am trying to sync some new materials from Cura 5 to my printer. I have confirmed that my printer is on and connected via cloud to Digital Factory. I believe wifi is also enabled. The firewall is off. I start the sync process and it just sits here forever. Any suggestions for things to try?

 

image.thumb.png.5b5217e0ba97769988c9890e0ca4a016.png

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Hey @kwakefield,

     

    Ugh, sorry to see that you are stuck. 😞
    What material were you trying to sync/print with? 

    I know it's been a while, did you figure out how to get the material you wanted on your printer?
    You can find more instructions to do so here: https://support.ultimaker.com/hc/en-us/articles/360013137919-Synchronizing-material-profiles

    If you encounter this again, can you share your log files with us?

    You can find your log file here:

    Windows: %APPDATA%\cura\<Cura version>\cura.log or usually C:\Users\\<your username>\AppData\Roaming\cura\<Cura version>\cura.log

    MacOS: $USER/Library/Application Support/cura/<Cura version>/cura.log

    Ubuntu/Linux: $USER/.local/share/cura/<Cura version>/cura.log

    We can use that to prevent other users from encountering this again.
    Thank you 😄

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Hi @MariMakes,

     

    Thanks for your reply. No, I’ve not yet been able to sync/upload material profiles to the printer. I’ve installed the remote support plugin and am currently running the CPU profiling while syncing. So far it’s been running for … maybe 5 minutes or more. The MacOS activity monitor screenshot is attached.  It’s an Apple M1 macbook pro (13-inch, M1, 2020 with 16GB memory running Monterey 12.5.1)

     

    How long is it supposed to take to sync one or two custom materials (one TPU and one PLA)

     

    Screen Shot 2022-10-08 at 3.20.22 PM.png

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    I finally stopped the sync process. Attached is the log file. Hopefully something in there can help track down the issues. I did take a peek at the log and it looks like something (output device) is constantly timing out < shrug >

    cura.log

  • Link to post
    Share on other sites

    Posted (edited) · Material Sync not working

    Having the exact same problem. Syncing from Cura just sits there and spins. I can see traffic via my router going to/from the printer, but it still keeps spinning the syncing icon. Not sure what to expect at this point.

     

    All I was really trying to do is sync a customized material profile that matches the 3DXTech CarbonX PETG+CF profile from the marketplace. I'm not using that one (not even installed) because it doesn't support the CC 0.4 nozzle (even though 3DXTech website says it's viable as a nozzle diameter). 

     

    And, following the USB method says there's no new material profiles...

    Edited by ReynoldsBeta
  • Link to post
    Share on other sites

    Posted · Material Sync not working
    On 12/4/2022 at 3:45 AM, ReynoldsBeta said:

    Having the exact same problem. Syncing from Cura just sits there and spins. I can see traffic via my router going to/from the printer, but it still keeps spinning the syncing icon. Not sure what to expect at this point.

     

    All I was really trying to do is sync a customized material profile that matches the 3DXTech CarbonX PETG+CF profile from the marketplace. I'm not using that one (not even installed) because it doesn't support the CC 0.4 nozzle (even though 3DXTech website says it's viable as a nozzle diameter). 

     

    And, following the USB method says there's no new material profiles...

    Having the exact same problem here. USB doesn't work either.

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    I have the same problem here on my S3

    I tried to synch it with Cura on a mac. I tried with a network cable and also via WiFi.

    Some time ago I was able to sync my profiles via USB. but since 5.0 this is also not possible anymore. For me it seems to be an Issue with the printer firmware and not with Cura.

     

    @MariMakes does your team know about the background of this error?

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    I also tried a factory reset - but it did't work

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    I was wrong - it is a Cura Problem. Today after uptating to 5.2.2 i get an "official error" - could not connect to digital factory. So I Uninstall Cura and everything that cura saved in my application support folder, restart my mac and reinstall a fresh 5.2.2 - Problem solved! Material sync works.

    • Thanks 1
    Link to post
    Share on other sites

    Posted · Material Sync not working

    Hey @pascal_heussner,

     

    Thanks for the updates! 
    Glad to hear your issue is resolved. 😊

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    I'm having the same problem. The 'Syncing' message is rotating but nothing happens.

     

    I tried upgrading from Cura 5.2.1 to 5.2.2 but it made no difference.

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    @jeremymorgan if you use a mac maybe try my way.

    Be careful because with this way - you will reset all of your cura settings. 

     

    uninstall Cura with dragging the app in the trash bin ->

    open the finder - go to your user root folder -> go to library (if you not see the library you have to activate the visibility in the finder settings or use the option key while clicking on the go to menu) -> go to the "Application Support" folder -> look for the "cura" folder in there. -> if you want: make a safety copy of it -> delete the "cura" folder -> reinstall cura

     

    *maybe it also work without a  new installation just with the erase of the application support cura folder just close cure -> delete the cura folder in the application support -> restart cura

     

    *please be careful with changes in folders in the library and also in the application support. -> These are system relevant folders.

  • Link to post
    Share on other sites

    Posted (edited) · Material Sync not working
    On 2/5/2023 at 10:26 AM, pascal_heussner said:

    @jeremymorgansi vous utilisez un mac, essayez peut-être à ma façon.

    Soyez prudent car de cette façon - vous réinitialiserez tous vos paramètres de cura.

     

    désinstallez Cura en faisant glisser l'application dans la corbeille ->

    ouvrez le localisateur - allez dans votre dossier racine de l'utilisateur -> allez à la bibliothèque (si vous ne voyez pas la bibliothèque, vous devez activer la visibilité dans les paramètres du localisateur ou utiliser la touche option tout en cliquant sur le menu aller à l'adresse) -> allez dans le dossier "Application Support" -> recherchez le dossier "cura" là-dedans. -> si vous

     

    *peut-être que cela fonctionne également sans une nouvelle installation juste avec l'effacement du dossier de cura de support de l'application juste fermer cure -> supprimer le dossier cura dans le support de l'application -> redémarrer cura

     

    *veuillez faire attention aux modifications apportées aux dossiers de la bibliothèque et également au support de l'application. -> Ce sont des dossiers pertinents pour le système.

    bonjour

     

    J'ai le même soucis que de nombreux utilisateur. 

    j'ai suivi la procédure : Nickel ça fonctionne.

     

    Merci

     

    Edited by regisgwada
    Resolved
  • Link to post
    Share on other sites

    Posted · Material Sync not working

    So the solution is to reinstall Cura? oof. 

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Hey @vagredajr007,

     

    Did you try the USB workflow?
    Under Settings, Maintenance,  you can find Import Material Profiles.

    If you have UFPs with new materials it will extract them from there. 
    You can also sync materials with USB.

    You can learn more about the flows here: 

    https://support.makerbot.com/s/article/1667412729968

  • Link to post
    Share on other sites

    Posted (edited) · Material Sync not working
    On 9/4/2023 at 4:28 AM, MariMakes said:

    Hey @vagredajr007,

     

    Did you try the USB workflow?
    Under Settings, Maintenance,  you can find Import Material Profiles.

    If you have UFPs with new materials it will extract them from there. 
    You can also sync materials with USB.

    You can learn more about the flows here: 

    https://support.makerbot.com/s/article/1667412729968

    Yes, I just tried that with 2 different USB sticks, both seen by the S5, both had the .umm files exported from Cura, and still the S5 says "no new materials to import" or whatever (I will take a photo next time). There seems to be no way to get this to work, so I don't know what's next.

     

    Note: Firmware on the S5 is up-to-date. Cura is version 5.4. Surely I'm not the only person on the planet with this issue.

    Edited by vagredajr007
  • Link to post
    Share on other sites

    Posted · Material Sync not working

    I also tried using this method: https://support.ultimaker.com/s/article/1667337567839

     

    And again, failure. Have y'all just thought about fixing the issue? Photo attached of what I see whether it's a .umm or .ufp file. 

    IMG_5298.JPG

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Hi @vagredajr007
    Im sorry you are having issues with material sync.

    I would recommend reaching out to UltiMaker Support directly for help on the issue.
    UltiMaker does not provide direct support via the community, so if you have an issue I would recommend contacting Support.

    You can contact support here: https://support.ultimaker.com/s/contactsupport

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Hello everyone,

     

    I use an S3 (FW 8.2) and Cura 5.5.0 and also have the problem that the material synchronization does not work.

    The S3 is connected to the network and Digital Factory.


    When I press the sync button in Cura, the sync symbol spins for several minutes and nothing happens. I can then only cancel the synchronization.

     

    When I try to synchronize via USB, I get the message that no new profiles were found.

     

    Is there a solution to this problem?

     

    Regards,
    Dirk

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Also having the exact same issues and tried both workflows: USB and Cura sync. Both don't work.

     

    S5

    Cura 5.5.0

    Firmware 8.3.0

     

    --------------

    Update:

     

    Updated to Cura 5.6.0 stable

    Followed the exact workflow here: https://support.ultimaker.com/s/article/1667410781024

    But now, when I try to import one of the suggested custom profiles, it shuts down Cura....

  • Link to post
    Share on other sites

    Posted · Material Sync not working
    Link to post
    Share on other sites

    Posted · Material Sync not working

    Here is a work around....

     

     

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    @Masterdark: Thank you! I've read the work around and understand it.

     

    I'm pretty sure that will work, but the thing is that I don't know what GUID/material is causing it (I just started in 3D printing with my recently bought S5 so i've been fiddeling around with setting and materials). And as I understand from the post even the API is not listing the 'phantom' material.

     

    Will it work if I reset the printer firmware to factory settings? Are all materials (even phantom) deleted then? 

     

    I that works, then I can sychronise the materials between Cura and the printer again. But what can I do to prevent introducing the problem again? What can I look for and correct in the list of materials in Cura?

  • Link to post
    Share on other sites

    Posted · Material Sync not working

    Hello,

     

    unfortunately I can't tell you how to make the phantom material visible. I also don't know whether a factory reset deletes the phantom material.

     

    I only add material via the API.

     

    To do this, I export the newly added or customized material from Cura and save it to disk and

    I change the file extension of the exported file to xxxx.XML

     

    Then I open the export file with e.g. Notepad++.


    To check whether the new material file matches the printer (S3, S5...)
    search within the file for a corresponding entry, e.g.
    <machine_identifier manufacturer="Ultimaker B.V." product="Ultimaker S5" />

     

    Then check whether the GUI for this new material has already been assigned.
    The GUI is included in the export file in the corresponding tags, e.g.
    <GUID>acede1e1-f0bc-457d-83eb-029006bad66c</GUID>

     

    To check, enter this GUI in the API under GET/meterials, see screenshot.

     

    If the GUI already exists, change the GUI slightly and check again using the API.

     

    If a GUI not yet stored is found, enter it in the export file and save the file.

     

    The customized material file can then be transferred to the printer via API (POST\materials), see screenshot.

     

    gui01.jpg

    gui02.jpg

    gui03.jpg

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...