Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
sonarok

NetFabb 4.9.4 - Update Issue Thread

Recommended Posts

Hi everyone,

i was looking forward to this update because retraction was promised to be fixed and that is / was the biggest gap on printing with netfabb. currently i always need to decide if i need a print with no stringing (then i use cura) or i dont care about stringing but need very nice surfaces or thin walls like for "writing" texts on models etc. (cura doesnt close thin walls correctly for example i have a 1 mm wall that result in 2 shells each 0,4mm and a gap of 0,2mm between them)

So my hope was big to be able to switch back to netfabb for everything but after updateing and some tests my disappointment is big :(

at the moment i'm not able to print anything... my ultimaker heats up, start moving to the right position, printing some seconds, then pulling back the filment veryfast and then.. nothing...

first i thought its maybe because of my custom material and printstyle settings so i made a backup and reseted everything... but without success...

anyone else is facing similar issues? i only saw some other issues on the retraction thread here...

i'm running the lastest marlin firmware from cura and also check for the right bautrate (250k), i'm also wondering why there is no documentation about this version / changes

Share this post


Link to post
Share on other sites

Hi Sonarok,

you are not the only one facing problems with new new 4.9.4 version!

This isn't the christmas present it was supposed to be.

It is producing really weird gcode concerning the E step calculation.

The E steps seem to be running to infinity!

Printing with this gcode leads to a massive extrusion of course!

Please help me! What am I doing wrong or is there a huge bug in 4.9.4 ??

Also the update was released without any documentation... This isn't very customer friendly!

Although I appreciate the effort to come up with a new version right before christmas...

But I am not able to print anymore with netfabb!!!

Here is my example of gcode:

M106

M109

G28

G92 X0.0000 Y0.0000 Z0.0000 E0.0000

G1 E0.0000

M107

M104 S193.0000

M104 S185.0000

G1 X-4.0000 Y-4.0000 Z0.5000 F480.0000 E28.3945

G1 X20.0000 Y-4.0000 Z0.5000 F480.0000 E176.7891

G1 X20.0000 Y20.0000 Z0.5000 F480.0000 E473.5782

G1 X-4.0000 Y20.0000 Z0.5000 F480.0000 E1067.1564

G1 X-4.0000 Y0.0000 Z0.5000 F480.0000 E2234.3127

M104 S193.0000

M140 S0

(begin layer 1 at 0.060)

M140 S0

G1 X1.5010 Y1.5010 Z0.0600 F10800.0000 E4468.6255

G1 X2.1026 Y0.9954 Z0.0600 F600.0000 E8937.3701

G1 X2.7801 Y0.6042 Z0.0600 F600.0000 E17874.8594

G1 X3.5326 Y0.3332 Z0.0600 F600.0000 E35749.8398

G1 X4.2898 Y0.2000 Z0.0600 F600.0000 E71499.7969

G1 X5.0740 Y0.2000 Z0.0600 F600.0000 E142999.7187

G1 X5.8480 Y0.3362 Z0.0600 F600.0000 E285999.5625

G1 X7.0221 Y0.8575 Z0.0600 F600.0000 E571999.3125

G1 X6.4350 Y1.4440 Z0.0600 F600.0000 E1143998.7500

G1 X5.6740 Y1.1100 Z0.0600 F600.0000 E2287997.5000

G1 X5.0260 Y0.9880 Z0.0600 F600.0000 E4575995.0000

G1 X3.7220 Y1.0990 Z0.0600 F600.0000 E9151990.0000

G1 X2.5550 Y1.6430 Z0.0600 F600.0000 E18303980.0000

G1 X1.6440 Y2.5550 Z0.0600 F600.0000 E36607960.0000

G1 X1.0990 Y3.7220 Z0.0600 F600.0000 E73215920.0000

G1 X0.9860 Y5.0050 Z0.0600 F600.0000 E146431840.0000

G1 X1.3200 Y6.2510 Z0.0600 F600.0000 E292863680.0000

G1 X2.0560 Y7.3040 Z0.0600 F600.0000 E585727360.0000

G1 X3.1140 Y8.0440 Z0.0600 F600.0000 E1171454720.0000

G1 X4.3240 Y8.3720 Z0.0600 F600.0000 E2342909440.0000

G1 X5.6760 Y8.2540 Z0.0600 F600.0000 E4685818880.0000

G1 X6.8360 Y7.6980 Z0.0600 F600.0000 E9371637760.0000

G1 X7.7200 Y6.8100 Z0.0600 F600.0000 E18743275520.0000

G1 X8.2540 Y5.6760 Z0.0600 F600.0000 E37486551040.0000

G1 X8.3760 Y4.3380 Z0.0600 F600.0000 E74973102080.0000

G1 X8.2560 Y3.6940 Z0.0600 F600.0000 E149946204160.0000

G1 X7.9198 Y2.9292 Z0.0600 F600.0000 E299892408320.0000

G1 X8.5071 Y2.3424 Z0.0600 F600.0000 E599784816640.0000

G1 X9.0278 Y3.5170 Z0.0600 F600.0000 E1199569633280.0000

G1 X9.1640 Y4.2902 Z0.0600 F600.0000 E2399139266560.0000

G1 X9.1640 Y5.0738 Z0.0600 F600.0000 E4798278533120.0000

G1 X9.0278 Y5.8480 Z0.0600 F600.0000 E9596557066240.0000

Share this post


Link to post
Share on other sites

Well I guess I'm officially done with Netfabb then. I mean seriously, they can't even implement something as basic as retraction properly? How bloody hard can it be? And it's not like they haven't had time to do it, it's been months. In hindsight I wish I hadn't wasted my money, I could've bought a lot of filament for that money...

Share this post


Link to post
Share on other sites

Hi almi,

I am really sorry to hear that this update has messed up your configuration. Have you tried to calibrate retraction in some older installed versions?

I think resetting your machine settings will solve all your problems. (Machine Tab/"Reset machine settings")

Actually, this release was really thought as christmas present and we wanted to get it out on this weekend. Documentation and Changelog will follow later today.

Best wishes,

Alexander

Share this post


Link to post
Share on other sites

Hi again,

first of all, happy xmas to all :)

@ alexander, its a nice idea to deliver something new for the holidays and i also thought thats great because i have a lot of time now to try out the new version with retraction etc.

but if you see my 1. post, i'm also not able to print anymore even with a reset, the printer starts to move to the right position printing for some seconds and then stops as soon as the filment is pulled back, i can see the xx % done number raising in netfabb but the printer isnt moving or extruding anymore...

would be great to get some more informations / help, or a updated documentation to understand the new settings better...

i ask myself if the reset really resets everything? not only style / material settings? does it reset the custom gcode header / footer too? maybe there is something wrong for the new version?

maybe i will give it another try and also switching between "Ultimaker" and "Ultimaker (volumentric)" for the maschin typ...

Share this post


Link to post
Share on other sites

Hi Sonarok,

Thank you very much for the feedback! Can you switch the machine type to "Ultimaker (volumetric)"? We have printed dozens of parts with a volumetric calibration, so this should really work well.

Non-volumetric calibration is kind of outdated and not recommended anymore. For a quick guide, the Howto of Paul

viewtopic.php?f=9&t=1009 is still up to date.

You can find a changelog of 4.9.4 on

http://wiki.netfabb.com/Version

A more detailed documentation is in the making, but we really wanted to bring out the version before christmas first.

Please feel free to give me more feedback about your findings, either here or as support ticket.

Best wishes and happy holidays,

Alexander

Share this post


Link to post
Share on other sites

Hi Alexander,

thanks for your hints! A reset of the machine settings made it work again! And retraction seems to work!

A few more questions:

The start sequence is a bit weird - the head moves to the very right X position, starting to draw Y lines. Does this

have to be necessariliy or what is the clue behind? Im asking because this movement leads to a endstop hit (at least I guess it does) and therefore the print starts at a complete different position than defined.

The other question is about temperature of the new material styles. They all run with higher temperatures than before (e.g. Ultra starting at 205°C, before at 190°C). Is this on purpose?

Thanks for your response!

cheers,

almi

Share this post


Link to post
Share on other sites

Hi Alexander,

On the changelog linked to above it says "released Linux version as Debian Package". How do I get that? I've been hoping for a Linux version of NetFabb forever and have not seen any indication that it is available. I currently run NetFabb inside a virtual machine on Linux and it is a serious pain. I want to remove that VM and run it natively. I cannot find any link to a linux version on either the NetFabb webpage or the Ultimaker webpage.

Thanks,

Troy.

Share this post


Link to post
Share on other sites

I've never used retraction with Cura before so I have no experience with it, but it seems to be working on this Netfab update. Before the head jumps the drive gear quickly jumps back about half a revolution then as quickly advances and continues printing. I'm a little concerned with using retraction as I've already experienced a few plugs with my printer even without using it but so far so good.

I had to adjust the M92 E value because I've got one of the first batch Ultimakers with the V1 drive bolt still...

I also went into the GCode Header and removed all of the junk that causes the lines to print on the right side - and also now causes the print to start off on the right side as opposed to where I placed it.

I haven't used Netfab in a long time because I've had nothing but problems recently (it used to work better on the first version). But so far so good on this update!

Dave

Share this post


Link to post
Share on other sites

I wouldn't wanna say that netfabb is bad. Quite the contrary, I am using netfabb for 90% of my prints. In my opinion it is outstanding when it comes to very detailed small prints in ultra quality. Cura isn't there yet.

The only ting i would like to claim is the customer support. It could be much better (Proactive information on updates, reaction time on requests,...)

Share this post


Link to post
Share on other sites

I do have to be honest, Netfabb is way better at slicing large complex objects! so I fully agree with Zungara.

Cura can't even slice them and Netfabb does it in a blink. Only thing is retraction. But I rather have strings and actually have a print... than no g-code at all...

I have some car prints that only Netfabb could print, in that way the money on netfabb is well spent.

I do hope that Cura will become even better, but everyone claiming that it's the best ehhh it does also have limitations!

I normally choose the slicer depending on pla sort (soft for instance is way better printable with netfabb, to my opinion)and complexity of the stl. So cura or Netfabb... as long as every once in a while a update comes along...

Share this post


Link to post
Share on other sites

I have yet to print a complex object successfully with netfabb. My success rate with netfabb is about 5%, while every(!) cura print comes out nicely.

Bottom line is: I really really want my money back for netfabb license. I was an idiot to buy netfabb. Sure, it's UI is nicer but what matters are the prints!

Share this post


Link to post
Share on other sites

For example: Yesterday I wanted to print a rather complex object with netfabb. I added a strong raft and fluff support. And what does the gcode of netfabb do? Albeit my piece has been centered, it tries to print at the end of my bed, hitting the endstop immediatelly. Note: Same gcode without raft and fluff would not print correctly at all, but at least started in the correct position. Cura never let me down.

Share this post


Link to post
Share on other sites

ok i got some time this weekend and i can confirm that this version works also with retraction and really nice printing results!

It seems like all issues that appear for the new version have something todo with the update itself and / or old settings.

My way to get it working:

- start netfabb as admin (using win7 64bit) to make sure it can write and change every setting you change

- reset all settings

- close netfabb to let it save all changes

- start it again as admin

- follow pauls howto on volumetric printing setup (viewtopic.php?f=9&t=1009)

- close it again

- start again as admin

- reset all settings again

- close it

- start it

- review your volumetric print settings and reconfig them if needed like in the howto from paul

i know that this looks really strange and i'm also not sure if all this start / close / reset steps are needed for everyone but since i did those steps everything runs great again.

I'm also a software developer (more in the direction of web / server) and i know how hard it can be to get software perfect running on a lot of devices with different specs... we should not blame the netfabb guys to much because from my point of view the software is working and since retraction is working i'm getting the best printing results ever even better then with cura (no gaps on big surface, extrem nice walls and top layers, etc.).

Anyhow... because it seems like all issues have their source in update / old settings here is a list of suggestions from my side to improve / avoid such issues in the feature:

1. mark the "default" / "none volumentric" maschine selection as depricated, old or whatever to let the user know they should not use it anymore

2. improve the export / import of settings by making it possible to export / import settings for the different sections

- this would help a lot if you could just import your material settings and / or print style settings etc.

3. QA the reset function!

- to me it seems like this one is not working correctly because some of the selection and settings remain and exactly this seems to lead to a lot of different issues...

those 3 points could make updates for the future a lot easier because you would just export want you want to keep, update, reset everything, import the old settings again => done!

Share this post


Link to post
Share on other sites

I need some help getting netfabb running.

I did reset netfabb 2-3 times, as suggested.

I edited my material styles and build-styles, based on experience from 12 months ago.

I removed the M92 E866 from the start.gcode (my FW takes care of that)

anything I slice, and attempt to print, moves the print head into places where it shouldn't be, and it end up pretty fast bumping against some of the end stops.

Gcode header, according to NF:

 

M104 S%maxtemp1M92 E866G21G91G1 X0.00 Y0.00 Z5.00 F500G90M109 S%maxtemp1G28G92 X0.00 Y0.00 Z0.00 E0.00G1 E0.00G1 X0.00 Y0.00 Z5.00 F600.00M106 S255G1 X205.00 Y200.00 Z5.00 F5000.00G1 X205.00 Y200.00 Z0.35 F5000.00G1 X205.00 Y100.00 Z0.35 F2500.00 E3.23G1 X204.00 Y100.00 Z0.35 F2500.00 E3.27G1 X204.00 Y200.00 Z0.35 F2500 E6.50G1 X203.00 Y200.00 Z0.35 F2500 E6.53G1 X203.00 Y100.00 Z0.35 F2500 E9.76G1 X202.00 Y100.00 Z0.35 F2500 E9.80G1 X202.00 Y200.00 Z0.35 F2500 E13.03G1 X201.00 Y200.00 Z0.35 F2500 E13.06G1 X201.00 Y100.00 Z0.35 F2500 E16.30G1 X202.00 Y100.00 Z0.35 F50000 E11.44G1 X0.00 Y200.00 Z0.00 F15000G92 E-4.85 

 

I am not sure what this 'draw a big box' business is supposed to do at the end of the startup gcode, so this is a candidate for elimination...

UPDATE: removing the garbage from the start.gcode did indeed help:

 

M104 S%maxtemp1G21G91G1 X0.00 Y0.00 Z5.00 F500G90M109 S%maxtemp1G28G92 X0.00 Y0.00 Z0.00 E0.00

 

The end.gcode was also somehow and updated to what Cura is doing.

PS2: retraction still doesn't work for me:

um2go-accessories.thumb.png.926174cb19d1447ec0720c9844603f3b.png

leaf1.keran.thumb.jpg.a51e349f6330e509710753935a0129ca.jpg

why? any ideas? It just clicks less than half a tooth backwards, and then continues as normal, leaving a nice string behind. the gcode also just shows a minimal retraction of 0.16mm:

 

G1 X87.6781 Y109.0073 Z0.0750 F3000.0000 E0.9815 G1 X87.9773 Y107.8389 Z0.0750 F3000.0000 E0.9986 G1 X88.4891 Y106.7495 Z0.0750 F3000.0000 E1.0155 G1 X89.4796 Y105.4711 Z0.0750 F3000.0000 E1.0383 (retract -0.16)G1 X89.4391 Y105.4307 Z0.0750 F15000.0000 E0.8784 G1 X79.4130 Y95.4150 Z0.0750 F15000.0000 E0.8784 (retract 0.16)G1 X79.4081 Y95.4253 Z0.0750 F3000.0000 E1.0385 G1 X79.3000 Y95.6500 Z0.0750 F3000.0000 E1.0420 G1 X79.3080 Y101.5670 Z0.0750 F3000.0000 E1.1255 

 

Share this post


Link to post
Share on other sites

I have several issues with Netfabb at the moment:

1. After slicing bigger files (last one was 15 mb) and hitting print Netfabb disconnects the Ultimaker thus interrupting the process. Why?

I have checked the connection and cables, I dont have any problem like this one with Cura.

There is also no visual information to know when the print is going to start and the time estimate for the print is always quite off its prediction, unlike the very simple print interface of Cura, where you can see what is happening and when will your print be ready (yes it is most of the time not very accurate with its print time prediction but it has at least a countup and a countdown so you know exactly how long you have been printing).

2. Another issue I have been experiencing with this iteration of Netfabb is that it seems to not be able of reading its own gcode. After I slice, which still works perfectly fine, I save the gcode. So far everything is ok, then issue 1 happens leaving me quite frustrated. I think to myself, you have the gcode, print it directly. Ok, I try to load it from netfabb using the gcode editor and the print gcode command and for my utter suprise It cannot read the gcode it outputted moments ago. Very frustrating.

Netfabb outputs the best results I have ever seen done with an Ultimaker, Cura is good, and it has awesome infill options but I have not achieved an overall quality that matches that of Netfabb. It is absolutely infuriating that you get hung up on tiny incomprehensible problems like the ones I have explained.

I will now try to print Netfabb gcode from pronterface. lets see how that goes.

Share this post


Link to post
Share on other sites
Any word on what updates are in 4.9.5? The changelog hasn't been updated yet.

It seems that they finally removed the ":" in the comments. This is good news to me as I print with pronterface which did not like the ":". So I had to remove them before printing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 0 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!