Jump to content
Ultimaker Community of 3D Printing Experts

Introducing Ultimaker Cura 3.6 | Beta


maht
 Share

Recommended Posts

Posted · Introducing Ultimaker Cura 3.6 | Beta
4 minutes ago, Smithy said:

Beside the bugs or fixed issues, I am asking me why we get so quick a new beta with version number 3.6 and not 3.5.2 and so on until everything works fine in the 3.5. branch?

 

Once a branch is made for a minor version (3.x), no new feature is allowed in that branch; in revision releaes (3.5.x) only fixes are allowed. The new beta contains new features, so a new minor version is needed.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    3 minutes ago, ahoeben said:

    Once a branch is made for a minor version (3.x), no new feature is allowed in that branch; in revision releaes (3.5.x) only fixes are allowed. The new beta contains new features, so a new minor version is needed.

     

    Thanks ahoeben for clarification, was just curious about it, but makes sense.

  • Link to post
    Share on other sites

    Posted (edited) · Introducing Ultimaker Cura 3.6 | Beta

    What about collecting new features a bit longer and bring new minor versions only twice a year? This would take some pressure from the poor IT guys who have to install a new Cura version every two months (in bigger companies).

    Edited by Dim3nsioneer
  • Link to post
    Share on other sites

    Posted (edited) · Introducing Ultimaker Cura 3.6 | Beta
    2 hours ago, Smithy said:

    I will do a test print with the new infill pattern as soon as a printer is free.

    Have one lined up and ready to go in 16 hrs and 46 minutes.

    Edited by kmanstudios
  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    So, I go to the market place to see what is there. It says I have generic PETG installed:

    InstalledNotification.thumb.jpg.840e80a2e0373976ce493e6403a43844.jpg

     

    And I go look for it....

    GenericListing1.jpg.ebbca623df23304739589d2b44d0a768.jpg

     

    Nope, not there...maybe here....

    GenericListing2.thumb.jpg.424dffad68d841e1e87023b3216ecb1c.jpg

     

    So, what is up with that?

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    And the memory leak goes back up again. Each screencap is about 1 minute apart from opening, to loading a generic 6 faced (12 triangles) box and then doing nothing more than positioning it at first.

    Open Memory:

    FirstOpen.thumb.jpg.285c7dbeda5038168b27b1859f650ace.jpg

     

    After Loading and positioning the box:

    LoadGeneric1KBSizedBox.thumb.jpg.c942a09cd3e889eaf6a14fd73f902fce.jpg

     

    One minute later:

    OneMinuteLater.thumb.jpg.a690185434b317822afb74e7f8e17aab.jpg

     

    One minute after that:

    OneminuteAfterThat.thumb.jpg.7d38c909f5ddfbafa0343a0ed6abf47e.jpg

     

    Hey! It went down:

    HeyItWentDown.thumb.jpg.31f55fda103768ddfa890344a4e16350.jpg

     

    Oops, got my hopes up:

    GoingBackUp1.thumb.jpg.c26fd0ef38193976f0b5b5303dd3096d.jpg

     

    And it keeps rising:

    GoingBackUp2.thumb.jpg.9e4f173b7db35f6232d4db89975c50de.jpg

     

    And, so on and so forth:

    GoingBackUp3.thumb.jpg.28cccaf3c1a93237ecaaa85688c1f374.jpg

    GoingBackUp4.thumb.jpg.d5aefd701d430f7de9e522333dd125b5.jpg

    GoingBackUp5.thumb.jpg.42218c1c0dcd84be9a6dbb30babb6697.jpg

     

    I closed it down after that. So, it is still growing in size, even though nothing is happening inside Cura. I am just going from screen capping the task manager to Photoshop.

     

    If I do not terminate Cura, it causes my machine to eventually crash. And, no other program I have does this.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    PETG and HIPS are not supported for the Ultimaker printers. You can download that profile, and it'll show up for some other printers, but we disabled it for the Ultimaker printers.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    If it is a generic profile, and people are printing PETG (Dunno about HIPS), then why is it not showing up as a generic?

     

    And, it says it is loaded, but nothing else, that is just odd. No disclaimer.....

     

    I only bring this up because it is a topic in another thread....The PETG, not anything else....

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    2 hours ago, ghostkeeper said:

    PETG and HIPS are not supported for the Ultimaker printers.

    Any reason why PETG or just not deeply tested?

    I mean PETG is like CPE and the generic CPE profiles works well with other PETG brands.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    The generic profiles are not that generic. They actually represent Ultimaker materials just without a color. So you will always find only Ultimaker materials for generic profiles for Ultimaker printers in Cura. But as @Smithy said, the CPE and CPE+ profiles might work for a relatively broad range of co-polyesters including PETG.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    just to mention that the Wanhao D4S profile is still a single extruder with no option to change.

     

    As of yet I haven't seen a Wanhao D4S with only one extruder.  only seen them with dual, so I don't know where on earth this current profile comes from.

     

    Bex

     

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    On 3.6 beta, my shadow, that lets me see the perimeters of objects, keeps disappearing if I move use any transform on the objects. If I key in a value, it comes back, but will disappear about 90% of the time making it difficult to precisely put my object in the buildplate.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    And more seird stuff:

     

    I named a file when saving and go to open it in the recent files:

    FileName.jpg.c0602864ec6f049b58d284b127db3c94.jpg

     

    And I get this, a double printer name:

    FileName3.jpg.ef1fefaec467a45cd73428ce0f0febdb.jpg

     

    I go to load it from the regular menu:

    FileName2.thumb.jpg.ec0d57b838cfd3f5fcd90e547fad1309.jpg

     

    And get this:

    FileName3.jpg.9dd0c5edab1c6d5104f4e44c80b79dbf.jpg

     

    So, I tire of fighting the name crap and go ahead and put my model together, merge it with all the parts getting their own settings and position it:

    ModelCorrectPosition.thumb.jpg.829194f74bc3c83452810e9047627cf6.jpg

     

    Then I notice an issue and reload the files and the entire model jumps around.

    AfterReloadingModels.thumb.jpg.5bcf6d6c69dbdb1d65a61de9f3987b48.jpg

     

    Which negates any careful positioning and, this is new behaviour. Even if I do nothing and just hit reload models, it will do the same thing.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    Can I install a newer version than my current (3.4.1) which would be fresh from any influence from previous installed versions?  Might be a good time to go back to default settings, attempt to apply the material templates as they are intended, and sort of purge all the settings changes that I have accumulated over the past couple years.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    @kmanstudios I have asked the Cura team to investigate your issues.

     

    6 hours ago, mastory said:

    Can I install a newer version than my current (3.4.1) which would be fresh from any influence from previous installed versions?  Might be a good time to go back to default settings, attempt to apply the material templates as they are intended, and sort of purge all the settings changes that I have accumulated over the past couple years.

     

    When a newer version of Cura doesn't find a settings directory for its version and finds an old settings directory, it will copy it and then convert it (when needed).

    So what you would need to do is to move your settings directory, start Cura 3.6.0-BETA, close it. And then copy back the settings of the Cura versions you still want to run. The settings can be found in (Windows) /Users/[username]/AppData/Roaming/cura

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    Here is an odd thing: As I was poking around and setting up a 0.8 core print I noticed the CC red is there. So I checked it out. It apparently is only "compatible" with certain materials, but not things like PLA, etc. Ummmm, why?

     

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

     

    7 minutes ago, kmanstudios said:

    Here is an odd thing: As I was poking around and setting up a 0.8 core print I noticed the CC red is there. So I checked it out. It apparently is only "compatible" with certain materials, but not things like PLA, etc. Ummmm, why?

     

     

    Because we didn't make profiles for it. You can use them, but the results will probably not bee that good.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    5 minutes ago, nallath said:

    Because we didn't make profiles for it. You can use them, but the results will probably not bee that good.

    That seems odd. If people are going to buy the CC Red, it seems they would want to use it for more than just a few select materials. Not everybody has a 0.8 core and would be looking to buy the CC Red to hit two things at once: Abrasive materials and large bore prints with other materials.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta

    Maybe it depends on the inner shape of this new CC core? I don't know, but the BB core has a different shape than the AA. So I guess, the CC is also different and therefore not so good for normal PLA prints.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    29 minutes ago, Smithy said:

    Maybe it depends on the inner shape of this new CC core? I don't know, but the BB core has a different shape than the AA. So I guess, the CC is also different and therefore not so good for normal PLA prints.

    Well, until we get something definitive other than "We don't make profiles for it." we will never know, yes? So, I do not gget into the maybes of the  issue. I just look at what it replied and question it if it makes no sense to me.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    1 hour ago, kmanstudios said:

    That seems odd. If people are going to buy the CC Red, it seems they would want to use it for more than just a few select materials. Not everybody has a 0.8 core and would be looking to buy the CC Red to hit two things at once: Abrasive materials and large bore prints with other materials.

    The behaviour of a nozzle is always different if you change anything (be it the material or the geometry) about it. So that's also the case here.

     

     

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    3 minutes ago, nallath said:

    The behaviour of a nozzle is always different if you change anything (be it the material or the geometry) about it. So that's also the case here.

    Yes, I understand that, but it does not answer why there would be no 'regular' profiles for it. As I said, if someone is looking to buy a large bore nozzle, they would want to be able to print something other than an abrasive material with it.

  • Link to post
    Share on other sites

    Posted · Introducing Ultimaker Cura 3.6 | Beta
    1 hour ago, kmanstudios said:

    Yes, I understand that, but it does not answer why there would be no 'regular' profiles for it. As I said, if someone is looking to buy a large bore nozzle, they would want to be able to print something other than an abrasive material with it.

    This is my “exact” intention otherwise the CC is an expensive specific use only Print Core.

     

    I too am very surprised.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share


    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
        • 11 replies
    ×
    ×
    • Create New...