Jump to content
ultradryan

UM3 NOZZLE 2 always leveled too close to bed after active leveling

Recommended Posts

Posted (edited) · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I was doing manual leveling and follow it with active leveling once a time every month, mostly.

 

No matter how i manual level the nozzles, whenever active leveling is done, the printer will always press nozzle 2 too close to buildplate once print is started. 

I can see the nozzle was so close that it got pushed back a bit upwards, so close that filament cannot print out of it.

 

Core 1 will always be fine and well calibrated, while Core 2 will always be too close to bed, after active leveling.

Either the active leveling is buggy, or the result of Z calibration between the 2 nozzles are not memorized by the machine.

 

Is there a fix to this? I am not sure why this is happening.

 

I suspect the distance between Nozzle 1 and Nozzle 2 somehow was wrong.

Now I have to set the machine never to do active leveling, and rely on manual leveling.

 

It will be great if there's a way to manually set the Z distance difference of the two cores in cases like this when the active leveling somehow failed?

 

 

Edited by ultradryan
  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I had just the same problem, after installing Z height plug in in Cura, which i gave 0.15mm my problem is solved.

 

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I have an idea about where the problem comes from. Do you people have set the Active Leveling frequency to 'never'?

Setting it to 'never' means that firmware 5.x will use the manual leveling settings. But when you insert an unknown print core I noticed some people use the Active Leveling to measure this print core.

 

My hunch is that there is a problem in this combination of Active Leveling and Manual Leveling where both methods use slightly different data.

Until we fix this the workaround would be to either:

- re-level with Manual Leveling

or

- Always use Active Leveling (don't set the frequency to 'never').

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I have exactly the same problem. I use frequency "weekly".

 

Now I did the manual leveling and set the frequency to "never". I think this issue started with the last Firmware-Update. Before I only did the manual leveling only once, when I unpacked my the Ultimaker 3 extended.

 

I print quite a lot and use since 2 years the same two extruder. Could it be a issue with the extruder?

The print bed level sensor reports "Signal good".

 

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

There's 2 ways to fix this.

 

One is to just turn off leveling.  It's really a waste of your time as manual leveling is so simple and easy and you only have to do it when you swap out cores and usually not even then.

 

If the nozzle levels too close usually it's because the spring in the core is weaker versus the spring in the bed.  You need the core spring stronger because the leveling doesn't know you've hit the bed until it starts moving so if the core moves first then there is a problem.

 

So loosen those 3 springs by turning the 3 knobs about 5 or 10 turns CCW (as seen from below).  That might be too loose to level but try that first and do a manual level (mandatory if you move those screws that much) and then see if auto level is better after that.  Don't loosen them too much.

 

Another solution is to remove the "bad" core.  Remove that one screw in the clear plastic part, take the spring out and stretch it such that it is about 5mm longer.  Put it all back together and it will work great for another few years.

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
On 9/27/2019 at 8:20 PM, gr5 said:

There's 2 ways to fix this.

 

One is to just turn off leveling.  It's really a waste of your time as manual leveling is so simple and easy and you only have to do it when you swap out cores and usually not even then.

 

If the nozzle levels too close usually it's because the spring in the core is weaker versus the spring in the bed.  You need the core spring stronger because the leveling doesn't know you've hit the bed until it starts moving so if the core moves first then there is a problem.

 

So loosen those 3 springs by turning the 3 knobs about 5 or 10 turns CCW (as seen from below).  That might be too loose to level but try that first and do a manual level (mandatory if you move those screws that much) and then see if auto level is better after that.  Don't loosen them too much.

 

Another solution is to remove the "bad" core.  Remove that one screw in the clear plastic part, take the spring out and stretch it such that it is about 5mm longer.  Put it all back together and it will work great for another few years.

 

 

I tried both methods: I turned the bed to a higher position and stretched the spring in my core. No change at all 😕


Further I changed cores right to left and left to right. The problem remains the same:  With auto-level the right core gets to low.

Could there be a problem with the firmware 5.2.11.20190503 on the Ultimaker 3 Extended?


Now I switched back to Manual Leveling.

One point can't be solved with manual leveling: During the XY calibration the right head prints hardly visible.

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I had a long look into this problem, but it is a difficult one to tackle since I can't reproduce it myself.

My feeling is that the problem is caused by a sequence of actions involving the combination of manual leveling and Active Leveling.

 

In the V5.0 release for the S5 we completely overhauled the Active Leveling software. Since the S5 build plate is larger than for the UM3 the undulations became too big to be solved with a simple 3-point leveling, that's why we introduced the grid based probing. The probing algorithm itself was also rewritten to be more accurate and faster.

 

The v5.2 release integrated the UM3 and S5 to be one software package again which for the UM3 has a lot of changes under the hood that you won't see but will be beneficial like:

- A year of software development, including lots of bug fixes.

- A new Linux version

- A new file system on the internal Flash memory for improved long term stability

- The overhauled Active Leveling

- A much improved version of Cura Connect, including Cloud connection

- etc

 

But.... for the users in this thread the v5.2 firmware breaks Active Leveling on the right print core. And I can't reproduce it which annoys me a lot after all the time I spent looking for the cause.

The problem seems to be caused by switching between manual and Active Leveling.

 

Could one (or more) of you please sent me the log files from your printer when it fails? Sent the files to me by private email (hover your mouse on my name avatar picture, a pop-up will show with email option). Add a short description of what you did and what you saw happen.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
I have the same problem on my UM3 Extended bought 3 days ago. I currently solved by installing the z offset plugin.
Can I send you the log files?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!