Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker Cura 4.12


fvrmr

Recommended Posts

Posted · Ultimaker Cura 4.12

Hi everyone,

 

Ultimaker Cura 4.12 is here!

We have improved our Ultimaker print profiles together with our material engineers, this will increase first-time-right results.

Here's how:
We’ve tweaked the Monotonic setting and made adjustments throughout print profiles. This removes occasional scarring on models and improves top surface quality by default. 

monotonic.thumb.png.72498e5c22246c69507fdf497f56f6be.png
We have also looked at horizontal print quality, processing several improvements. This results a reduction of ringing, improving resolution and overall print quality.   

0.thumb.png.4442ba22d7b60d681fb32f3fb8dcf8b7.png

 

Lightning infill
We have a new infill type called Lightning!

lightning.gif.19b7366f30809972b53f37bd88a04248.gif

This infill setting enables you to print high-quality top layers while using less material and increasing your production speed. It’s an ideal setting for visual models, as reduced material usage will result in a reduction part strength.

Lightning infill was a research project inside Ultimaker and is based on this paperThanks to rburema and BagelOrb!

 

App switcher:
The new app switcher provides a simpler way to navigate and use other Ultimaker applications, including Ultimaker Digital Factory, Ultimaker Marketplace, and Ultimaker 3D Printing Academy. Reporting bugs to Github is now just one click away, and it’s easier to find the application you need.

 

Bug fixes:

-        Fixed a bug with monotonic ironing that causes fan speed jump to 255 for ironing pass

-        Fixed an engine crash when using monotonic ordering with zigzag skin pattern

-        Fixed inconsistent material name in the header and material selection dropdown

-        Fixed a bug where a random zero was added in the g-code

 

For more information read our blog post, the full release notes or watch our video!

 

 

 

Download 4.12 now!!

 

And don’t forget to give us your feedback here in the comments or on Github.

  • Like 4
Link to post
Share on other sites

Posted · Ultimaker Cura 4.12
9 minutes ago, fvrmr said:

Reporting bugs to Github is now just one click away, and it’s easier to find the application you need

Two, actually; One to open the popup, one to push the appropriate button.

  • Like 3
Link to post
Share on other sites

Posted · Ultimaker Cura 4.12

Out of curiosity: How can a (any) slicer improve the horizontal print quality in the example? going slower around the corner? exclusively printing cw/ccw?

Is there more technical information about this? Thanks!

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    14 hours ago, Juenger said:

    Out of curiosity: How can a (any) slicer improve the horizontal print quality in the example? going slower around the corner? exclusively printing cw/ccw?

    Is there more technical information about this? Thanks!

    Tuning of the profiles! We've increased the jerk a bit so that it has less vibrations in the rest of the print. We are working on more improvements like this, so expect a lot better print quality for Ultimaker printers with the next few updates of Cura. I'm pretty excited about these changes, as it shows that combining the full process makes it possible to get the best end results.

    • Like 1
    Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.12

    Interesting, thanks. I've noticed that jerk in walls is increased with M205 from 10 to 20.  This seems counter intuitive (to me). My understanding was that higher acceleration / jerk would result in even higher forces and thus more vibrations. Could you explain this? 

     

    thanks for any more information on this.

    Code_WB96Io7Ge4.png

    Edited by Juenger
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    11 hours ago, Juenger said:

    Interesting, thanks. I've noticed that jerk in walls is increased with M205 from 10 to 20.  This seems counter intuitive (to me). My understanding was that higher acceleration / jerk would result in even higher forces and thus more vibrations. Could you explain this? 

     

    thanks for any more information on this.

    Code_WB96Io7Ge4.png

    I'm by no means a mechanical engineer (or a process engineer), so I'm not the best person to explain the nuances of this change.

     

    I was told that it has to do with the natural frequency. Certain types of vibrations / speeds / changes simply cause more issues. In those cases it's perhaps a bit counter intuitive, but it's better to then move faster (even though that would normally decrease the quality)

  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.12

    Whatever you did, jerky or jiggly or whatever... LOL. I LOVE the new surface. It absolutely does look better. Part of me wants to throw some curse words at you while I toast you with a beer. I am going to have to reprint a whole bunch of stuff that I want to look pretty. I really hate sanding so reprinting is now it.  So thanks a lot (both sincerely and a sarcastically in a good way)!

    Edited by kayakbabe
  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker Cura 4.12

    Issues I have:

    1. "Support Placement" is missing from Per Model Settings. This is bad.

    2. Colour scheme for preview is awful and confusing. One colour was enough for me to figure what was happening but I cannot tune this version to that.
    3. Icons for settings have changed. Why? Nothing was wrong with the old ones so this unnecessarily confuses things. Sure I'll learn them in a few weeks, but why do I have to, what is the improvement?

     

    Edited by SilverDynamic
  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    6 hours ago, SilverDynamic said:

    Colour scheme for preview is awful and confusing. One colour was enough for me to figure what was happening but I cannot tune this version to that.

    What exactly do you mean here? The choices for colour schemes in layer view have been basically the same for ages. Cura 4.12 on the left and 15.04.6 which came out about 5 years ago and they look very comparable.layers.thumb.PNG.e6d5728cce238308718e6b06c11aca0c.PNGs.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    20 hours ago, SilverDynamic said:

    Colour scheme for preview is awful and confusing.

    What was changed is the default setting of the color scheme. The color scheme now defaults to showing the types of lines, whereas in previous versions it was set to show one color per material by default. But you can change it back with the "color scheme" option in the top bar.

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    3 hours ago, ahoeben said:

    What was changed is the default setting of the color scheme. The color scheme now defaults to showing the types of lines, whereas in previous versions it was set to show one color per material by default. But you can change it back with the "color scheme" option in the top bar.

    Thanks for the constructive reply 😄

    I did look for an option to change but totally failed to find it! I upgraded from 4.8 ish and in all the previous 4 yrs of using  cura have never seen this multicolour version of preview as a default!

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    See this post:

    The "Line type" scheme was made the default up in Cura 4.9. Up until Cura 2.5, there was no other scheme than linetype, but between Cura 2.5 and 4.8 the material color was the default and line type was an option.

     

    Line type is a more informative scheme; of something is going wrong it often helps what parts of a layer is printed as what sort of line.

     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    nice update!
    but...  this versions "arrange" function doesnt work anymore.

    objects just stay were they were. 

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    I guess I am missing something obvious here, just upgraded from 4.7 and voids are being filled in?

     

    Untitled1.png

    Untitled2.png

    • Like 1
    Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    26 minutes ago, yzorg said:

    nice update!
    but...  this versions "arrange" function doesnt work anymore.

    objects just stay were they were. 

    https://github.com/Ultimaker/Cura/issues/10249

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    @andymharrison - Use the visibility dropdown tool (next to the settings search box) and then go to the Mesh Fixes section.  The only thing you might want checked in there is "union overlapping volumes".

    Sometimes "remove all holes" gets checked and sometimes "make overhangs printable" gets checked somehow.  Those are specialty settings that are for very specific situations that rarely come up.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    Looks like Ultimaker has made a BIG mistake with version 4.10, 11 and 12.  NONE of these versions work with the AMD processors.  I have proven this by installing ver 4.11 on my old HP Intel notebook.  But my AMD Ryzen 5 3600 crashes the newer versions when trying to load a file.

     

    This means anyone with AMD processers need to move to Prusa Slicers.  

     

    Looks like these versions were not tested on the AMD processors.

     

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    9 hours ago, ozhawk said:

    Looks like Ultimaker has made a BIG mistake with version 4.10, 11 and 12.  NONE of these versions work with the AMD processors.

     

    Hmm, seems to work fine for me, both on my first gen Ryzen desktop and my latest gen Ryzen laptop. Maybe uploading the logs can give the devs an idea on what's causing Cura to crash for you.cura_ryzen.thumb.png.d8c7b58275cffabcd5eaa46694e50f83.png

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    I just installed 4.12 and one issue I have is when I send a print to the printer, it displays a warning that for 'best results use Cura 4.4 or greater and I have to manually clear the warning before it will start preparing to print.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    On 11/22/2021 at 3:53 AM, ozhawk said:

    Looks like Ultimaker has made a BIG mistake with version 4.10, 11 and 12.  NONE of these versions work with the AMD processors.

    They are tested on AMD processors.

    On 11/22/2021 at 3:53 AM, ozhawk said:

    I have proven this by installing ver 4.11 on my old HP Intel notebook. 

    You have proven that it fails for a specific set of hardware 😉
     

    On 11/22/2021 at 3:53 AM, ozhawk said:

    But my AMD Ryzen 5 3600 crashes the newer versions when trying to load a file.

    Ah, there you have it. Ryzen has made a lot of mistakes with their drivers. Cura isn't the only application hit by this issue. Unfortunately, there is nothing we can do about this, as it's caused by an issue in drivers provided by AMD. You can find more information (and a work around) here: https://github.com/Ultimaker/Cura/issues/5265

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    14 hours ago, jsw said:

    I just installed 4.12 and one issue I have is when I send a print to the printer, it displays a warning that for 'best results use Cura 4.4 or greater and I have to manually clear the warning before it will start preparing to print.

    You need to upgrade your firmware.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    22 hours ago, IRobertI said:

    Hmm, seems to work fine for me, both on my first gen Ryzen desktop and my latest gen Ryzen laptop. Maybe uploading the logs can give the devs an idea on what's causing Cura to crash for you.cura_ryzen.thumb.png.d8c7b58275cffabcd5eaa46694e50f83.png

    That won't matter. It's a specific ryzen issue. Nothing that Cura does should be able to crash the entire machine. There are also other applications (games mostly) that suffer from the same issue. The GH link I posted has some workarounds for this issue.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12
    1 hour ago, nallath said:

    You need to upgrade your firmware.

     

    Is that safe to do now?  I recall a previous thread where at least one user 'bricked' the machine attempting to do this.

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    Thanks for your work.

    On my one model, I found multiple carriage movements when filling the first layer, wasn't it easier to fill in thin areas with less carriage movement?

    Screenshot 2021-11-23 at 15.52.24.png

  • Link to post
    Share on other sites

    Posted · Ultimaker Cura 4.12

    Here's another thing with the new Cura (4.12.1).

     

    This print ended up with quite a few artifacts in the form of little 1/8 inch or so 'streamers' growing out of some pieces of the model, most centered around one particular diagonal piece.

     

    It's nothing that can't be diked off and sanded, but it's definitely something unexpected.

     

    This is with the new Cura with default settings for generic PLA.  Rather than futz around trying things, does anyone have any specific reasons why this occurred?

     

    Is this maybe the way the new Cura handles things like retraction and/or combing?  Maybe something related to the way it's supposed to produce better surfaces?

     

    Any ideas?

     

    Thanks in advance.

     

    mloop1.jpg

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...