Jump to content
maht

Ultimaker Cura 4.0 | Stable available!

Recommended Posts

Posted · Ultimaker Cura 4.0 | Stable available!

After an extended beta period, we now present the stable release of Ultimaker Cura 4.0. A big thanks to our beta testers who gave us valuable information and suggestions during the beta phase.

 

Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration. Find the update blog here, and for more in-depth detail of what’s new, find the release notes here. 

Or just dive in and download it here.

 

As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.

 

recommended-mode-red.jpg

 

robot-fingers-cloud-popup.jpg

 

remote-printing-configurations.jpg

 

Please note: Most cloud features are fully functional, but we are making some final tweaks to the stable release of firmware 5.2 for the Ultimaker 3 and Ultimaker S5, which will become available in the next few days. This will enable remote printing with your Ultimaker account. 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Ha, I see what you did there with the blog post title...

  • Like 3

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Just updated and it won't finish slicing

image.thumb.png.6b7278649ac564108a9249978de37fbb.png

stuck there since five minutes.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
1 hour ago, MrAffiFPV said:

Just updated and it won't finish slicing

stuck there since five minutes.

What's the last couple of lines in the log file? (Help > Configuration folder > Cura.log)

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Will this step on my custom materials and printers defined in Beta 2?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Works now... Deleted everything in the config-folder (old versions too, since Cura 4 uses their configs).

Will try to replicate the error for log

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
55 minutes ago, bagel-orb said:

What's the last couple of lines in the log file? (Help > Configuration folder > Cura.log)

2019-03-19 18:49:22,014 - DEBUG - [Thread-13] UM.Backend.Backend._backendLog [101]: [Backend] [ERROR] Trying to retrieve setting with no value given: 'minimum_support_area'
2019-03-19 18:49:22,175 - DEBUG - [MainThread] UM.Backend.Backend._logSocketState [195]: Socket state changed to Closing
2019-03-19 18:49:22,179 - DEBUG - [MainThread] UM.Backend.Backend._onSocketError [217]: Socket debug: Arcus Error (13): Closing socket because other side requested close.
2019-03-19 18:49:22,181 - DEBUG - [MainThread] UM.Backend.Backend._logSocketState [197]: Socket state changed to Closed
2019-03-19 18:49:22,182 - DEBUG - [MainThread] CuraEngineBackend.CuraEngineBackend._onBackendQuit [811]: Backend quit with return code 2. Resetting process and socket.
2019-03-19 18:49:23,960 - INFO - [MainThread] cura.Machines.MachineErrorChecker._setResult [188]: Error check finished, result = False, time = 7.4s
2019-03-19 18:49:25,493 - DEBUG - [MainThread] cura.AutoSave._onTimeout [48]: Autosaving preferences, instances and profiles

Maybe the new setting  "minimum_support_area" causes the issue, but I can't find it in the settings menu (showng all settings).

And another mystery is that the progress bar reaches almost 50% when support is enabled but only about 30% when it isn't 🤔

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

That sounds like your CuraEngine is another version than the frontend of Cura. Perhaps something went wrong during your install which causes your Cura to use the another CuraEngine than the newly installed one.
Another e[explanation would be that the wrong version of CuraEngine is packed into the installer, but that would cause errors for everybody.

Whoch operating system are you using?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
15 hours ago, PaulK said:

Will this step on my custom materials and printers defined in Beta 2?

No it shouldn't. But to be sure you should make a backup of your configuration folder of 4.0. If there were some major changes since 4.0.0-beta2 then your profiles could potentially crash Cura.
Eitherway you should update to Cura 4.0.0; you cannot stay on 4.0.0-beta2 forever; problems in updating from beta2 to stable are probably caused by beta2, not by the stable version.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
16 hours ago, PaulK said:

Will this step on my custom materials and printers defined in Beta 2?

I had to change each of the variants, setting_version from 5 to 6.

Everything else worked just fine. 

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura 4.0 | Stable available!

Downloaded and installed without a hitch! I noticed two things immediately.

1. Opening a Cura Project 3mf file from <4.0 does not inherit any of the project's settings. I had to reinstall 3.6 to get a bunch of settings to show up that I had tweaked iteratively for a project.

2. I can't seem to slice... I've had errors like this before and typically changing the Prime Tower X and Y location fixes it. But the Extruder Prime X Position is not available for me to change/fix.I feel like this is buggy behavior, but please correct me if I'm wrong.

 

 

2019-03-20.png

 

2019-03-20.png

 

Edit: Well, I haven't come across the issues described above again, so I'll consider them flukes! I forgot about the setting to change how Cura Projects open underneath Preferences...

Edited by starbuck
  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

I don't like the new interface, for the same reasons I highlighted on my post in the beta thread. Thanks a lot to @ahoeben for the sidebar plugin! Now CURA becomes easy and simple to use again.

  • Like 3

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
On 3/20/2019 at 10:17 AM, bagel-orb said:

That sounds like your CuraEngine is another version than the frontend of Cura. Perhaps something went wrong during your install which causes your Cura to use the another CuraEngine than the newly installed one.
Another e[explanation would be that the wrong version of CuraEngine is packed into the installer, but that would cause errors for everybody.

Whoch operating system are you using?

Windows 10

I deinstalled all Cura versions and reinstalled 4.0, which works now. But how can I get my old printer profiles to run? I tried copying the user, machine_instances, extruders and material folders which did not work. Just copying everything just replicates my previous issue.

Which folders / files are needed to replicate a printer setup?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Most of my profiles from Cura 3.6.0 does not show up in 4.0

Is there a simple way to fix this or am I just to export-import them one by one?

Using a Mac.

 

The UI looks nice though, from what I've seen so far 🙂 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
On 3/20/2019 at 5:42 PM, Brulti said:

I don't like the new interface, for the same reasons I highlighted on my post in the beta thread. Thanks a lot to @ahoeben for the sidebar plugin! Now CURA becomes easy and simple to use again.

 

I almost would like to use stronger words, but yes, I also dislike the new interface and was close to throwing out v4 again after installing it yesterday, before I learned about the great plugin which restores the UI into a usable state again.

What I mostly disliked about the "new" look was the waste of space on the screen. Since the model space i centered on the screen even moving the build plate to the left side did not help much because then the mouse control gets weird with the center of rotation still stuck to the middle of the screen.

I still find that the fontsize in the settings is a bit on the small side and I wished that it and possibly even the font were configurable - please? There is a lot of unused empty space between the tiny lines of text on my screen...

Clip0003.jpg

Clip0013a.jpg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

The Marketplace isn't loading any packages for me sometimes.  I get a message flashing up for half a second when opening the marketplace popup that says cant get Cura packages database.

 

NoMarketPlace.PNG

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura 4.0 | Stable available!

Hey,

 

The update sure is looking fresh and promising, however: on Mac

 

  • In Monitor: Camera button isn't working
  • In Monitor: links such as "View Print History" and "Go to Cura Connect" not working.

 

Scratch That. just a minute ago everything seems to be working all of a sudden.. Thanks

Edited by Q8Khajah
Changes

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Hi there,

Few of the problems I faced before are solved in the new software version. Still, the following issues remain unsolved:

 

(1) if the object consists of the solid forms and surfaces AND the surface ends higher, the slicer slices the surface only to the level of the solid body top (see the pictures for sample screenshots)

 

(2) the infill failure - pictures attached shows the original object and the result. I can't find the way to slice the object without the "mesh" infill

1.thumb.jpg.bafcf5caebd8f333d5a3ddb32ec960a3.jpg

2.thumb.jpg.43d26a9b869d590efaf3d678c9f99cb1.jpg

111.thumb.jpg.e68f90ea0dfac549ce284f24f85cd108.jpg

111-2.thumb.jpg.7530f3460f63bb6173339b31059c9450.jpg

222.thumb.jpg.02a321c2111a25dfa5fbefecb73d9c56.jpg

222-2.jpg.7e51d425fa80f355856153597fb124da.jpg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

Just wondering if the mobile app will allow for connection when not using the same network? I just tried and it did not work? 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
On 3/22/2019 at 12:03 PM, greatg said:

Just wondering if the mobile app will allow for connection when not using the same network? I just tried and it did not work? 

 

The mobile app doest not support this yet, for now you can only use Cura 4.0 to remotely monitor and start prints.

Note that this is just the beginning for this type of functionality, much more will come. I expect a significant update coming with Cura 4.1 already.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!
On 3/22/2019 at 4:57 AM, NeonWave said:

The Marketplace isn't loading any packages for me sometimes.  I get a message flashing up for half a second when opening the marketplace popup that says cant get Cura packages database.

 

NoMarketPlace.PNG

Same problem here, market place is all blank.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

I can't get my Ultimaker 3 Extended to accurately us my Active Leveling feature since updating to 4.0

 

Suggestions welcome.  

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

@steelhorsemodels I found out that active leveling isn't really needed on UM3E. If you do a good job with a manual leveling, active leveling becomes useless and is just a waste of time at the start of a print. The leveling will need to be redone after a time, of course, but you're good for many prints before it becomes an issue if you did the manual leveling well the first time.

 

I would advise to not use the leveling card sent with the printer, but get something like this: https://www.makershop.fr/outils-et-accessoires/1476-cales-mecaniques-005mm-1mm.html

In my personal experience, I would often need to redo the manual leveling once or twice with the card before it was good. The card is soft, gets easily bent on the side if it hits the printhead when it is a bit too low, and the feeling for the kind of pressure there is is hard to tell. With those metal cards things (which I got by mistake, was a misclick that I didn't saw when I placed my order), I never had to redo the manual calibration, one time was enough, and the thing is hard and gives a much better feeling for the pressure coming from the printhead.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

OK so when I first install 4.0 it opens successfully. After closing and re-opening it, however, it opens with a basically blank GUI. This is before installing any plug ins.

Cura 4 issuejpg.jpg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura 4.0 | Stable available!

in preview, I can't find how to view just the infill or support

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 65 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!