Jump to content
Ultimaker Community of 3D Printing Experts
xeno

Auto slicing on / off PLEASE !!

Recommended Posts

My god Cura slices really fast, and works great....unless.... you have large files

it turns my super duper fast new iMac into a slow 1990s pc !

every - little - adjustment - I - make - I have to wait for the slicer to finish doing its thing,

-move the object to the center, wait......20sec.

-lay flat on surface............wait 20sec.

-rotate it to fit the platform, wait......20sec.

-scale to the right size, wait.......20sec.

-turn on support, wait......20sec.

and so on...

it takes 30 minutes just to load the object and have it placed and ready for printing, come on !

how come Daid never though about having an on / off switch ?

is there a reason why this is not switchable in the expert setting ?

I can understand to make an idiot proof program, but why make it more difficult for us, who use the expert settings.

I have to stick with the older version, I rather press "prepare" and get a coffee, then to have to click every 20seconds for half an hour

 

  • Like 1

Share this post


Link to post
Share on other sites

I have seen more people complaining about it than anything. Then again, when people are happy, they don't say anything, only when they are not.

But yeah I agree, even if it's separate process, it's a bit wasteful, and it's not like I'm going to forget to slice my model before quitting, that's kinda why I'm using cura after all.

I's not the first thing I want to see fixed (better support seems more important) but yeah, I would not mind seeing it go

 

Share this post


Link to post
Share on other sites

Are you guys using 13.06.03? 13.06.02 causes those exact symptoms for me when autodetecting an SD card, not so much autoslicing. Daid seems to have fixed that in 13.06.03. If you insist on 02 you can turn the auto detect memory card option in the preferences and see if it fixes it.

 

Share this post


Link to post
Share on other sites

Are you guys using 13.06.03? 13.06.02 causes those exact symptoms for me when autodetecting an SD card, not so much autoslicing. Daid seems to have fixed that in 13.06.03. If you insist on 02 you can turn the auto detect memory card option in the preferences and see if it fixes it.

as long as Daid doesn't repair the download link for OSX, I don't know what version I have

it says 13.06.02 in the header, but after installing the 13.06.03, it stil says 13.06.02 !!

 

Share this post


Link to post
Share on other sites

as long as Daid doesn't repair the download link for OSX, I don't know what version I have

it says 13.06.02 in the header, but after installing the 13.06.03, it stil says 13.06.02 !!

 

Something went wrong with the 13.06.3 build for Mac. I will fix it tomorrow.

 

Share this post


Link to post
Share on other sites

Strange, have a new iMac too, 10.8.4, 2.9 GHz I5 / 16Gb.

But i have no idea what is causing your problem. I can handle, add, multiply, split and move anything i want; the slicer will start in the background (which is nice, it is anticipating on my future actions....) and i can do whatever i want while it is doing so.

My iMac is running 4 desktops, one with email and chrome, one with Cura, one with Eclipse including 2 emaulators (which is quite heavy) and one with 2 flash-games (yeah, i know...).

So, i can not confirm your experience.

 

Share this post


Link to post
Share on other sites

Don't get me wrong, I love AutoSlicing, but the 20sec stuttering delay when making adjustments is just silly,

 

Discard my vote above!

I just began to like the buttonless real-time feature:

http://www.youtube.com/watch?v=JMAJYALHQcI

 

that is a great example how AutoSlicing COULD work, but try that same trick with a 100MB file, and you won't be so happy :)

I really hope this is just related to the wrong version in the OSX download, and that the latest version works better, or else I will be sticking to the old version :cool:

 

Share this post


Link to post
Share on other sites

I did. I tried it with a file large enough to blow memory. Actually you can just slice a simple object with .000001 mm layers and that will do the trick.

Anyway the 5 second delay happens with a simple cube sliced with .2mm layers also - it's a bug that very very few people experience. There are at least 2 potential causes - both of which were fixed but only the Windows people got it so just wait a bit more.

One of the bugs had to do with the SD card and unchecking that fixes the problem. The other bug also has a workaround - I forget what it is but it's somewhere in these forums. OH! I remember - it was kaspersky virus scanner - it was keeping the process called "steamEngine.exe" from launching without scanning it first. The scanning takes 5 to 10 seconds and so the whole thing locks up during the kaspersky scan. Two people reported this workaround fix. The new cura will work fine with Kaspersky when the mac version is built and released to the server.

Daid would have found neither of these bugs if it wasn't a problem for a few rare users (like yourself).

For me I can do anything while slicing - I can change parameters every second or every 2 seconds or evey .1 seconds and it just stops slicing and starts over. No problem.

 

Share this post


Link to post
Share on other sites

that is a great example how AutoSlicing COULD work, but try that same trick with a 100MB file, and you won't be so happy :)

 

I tested it with a 160MB file.

It took less than 30s for a complete slice, but all of this happened in the background and I did not experience the slightest performance issues.

Rotating, moving or scaling the object, changing input field values or opening the menus did work as usual.

It rocks 8)

 

Share this post


Link to post
Share on other sites

On this issue.

NO I WON'T REMOVE THE AUTO SLICING OR MAKE IT CONFIGURABLE. Asking for it nicely, crying, or even coming over to my house with pitchforks and torches won't help (But you will get an odd look from me for doing that). You can use 13.04 if you are not happy about the 13.06 release right now. But this won't help in getting the real issues fixed.

First off, there where some issues with performance. Thanks to a few testers I managed to find and fix performance issues, only 1 was related to the actual slicing, which had to do with an interaction how the slicer was started and a virus scanner. And the SD card detection was giving some fuzz. This is solved in the .3 release, this mostly effected windows. but also made the Mac version act a bit better, however, due to a mistake I uploaded the wrong file and thus the .3 only went live this morning for Mac.

Now, I just did a lot of tests today on MacOS. (as almost all "boohoo, auto slicing bad!" users are MacOS users now) And the slicing on MacOS is fine, it doesn't do anything to the performance. HOWEVER. There seems to be an issue with the 3D view drawing on MacOS, this is much slower then it used to be. I'm checking this, because it's odd (The 3D view is actually fasted then in older releases on Windows)

I'll keep you posted.

 

Share this post


Link to post
Share on other sites

"NO I WON'T REMOVE THE AUTO SLICING OR MAKE IT CONFIGURABLE. Asking for it nicely, crying, or even coming over to my house with pitchforks and torches won't help (But you will get an odd look from me for doing that). You can use 13.04 if you are not happy about the 13.06 release right now. But this won't help in getting the real issues fixed."

Perhaps a 'little short trough the corner' :lol: ...

One of the benefits of free software is to use the version you want!

Keep the printer busy and in the meantime, wait for things to come..

 

Share this post


Link to post
Share on other sites

I've found the problem for the Mac rendering speed. Might also effect some windows drivers, but not 100% sure.

I'm also checking out the plugin problem on Mac, I haven't found the proper solution for that one yet, but I will ;-)

I've also made a small update on the slicer. Right now it retracts on the outside if it's printing a part without a infill (because the final resting position of the head is on the perimeter), in my development version it moves the head inside the part so it does not have to retract on the perimeter, but is inside the part. This gives less scaring of the outside, and thus an improved quality.

 

Share this post


Link to post
Share on other sites

very clever update, thanks for that, that was a pain sometimes.

can you please comment on any possibility of item name poping up somewhere upon focusing on item or something like this,

would be really useful in case of sevaral parts loaded.

Thank you, Daid.

We truly appreciate your hard work.

Regards,

 

Share this post


Link to post
Share on other sites

ahaha

My Anti-Autoslicing brethren, gather and lets go over to Daids house with pitchforks and torches, now.

atleast i want his "odd look" to be satified over the loss of the button!

just kidding :)

I just have to severely adapt myself to it. i like the new split and combine functions and the zoom pan settings.

but its still very strange for me not to click a button to have something sliced.

 

Share this post


Link to post
Share on other sites

I just have to severely adapt myself to it. i like the new split and combine functions and the zoom pan settings.

but its still very strange for me not to click a button to have something sliced.

 

I have to admit, it takes a while to get used to it. But after that it's all awesome-sauce from there.

I did have a good laugh at a colleague today, we checked out some difference between the 13.04 and 13.06 release, and he spend a good minute trying to delete the object from the platform in 13.04 :-)

 

Share this post


Link to post
Share on other sites

There were 3 problems I think they were all fixed and all also had workarounds:

1) In Files Preferences turn off the auto SD card detect - this was causing lots of slowdown issues.

2) Disable any virus scanners or even better, tell them not to worry about steamEngine.exe.

3) Was there a third problem? I forget now. I think there were some Mac only bugs so you should get the latest version.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Introducing Ultimaker Cura 3.6 | Beta
      Ultimaker Cura 3.6 | Beta is available. It comes with new features, bug fixes, and UX improvements. We would really like to have your feedback on it to make our stable release as good as it can be. As always, you can download the beta for free from our website, for Windows, MacOS, and Linux.
        • Like
      • 74 replies
    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
        • Like
      • 24 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!