Jump to content
Ultimaker Community of 3D Printing Experts

Introducing Ultimaker Cura 3.3 | Beta


Recommended Posts

Posted · Introducing Ultimaker Cura 3.3 | Beta

Things I very much like:

  1. Input fields are unified and behave as input fields in other programs and that means no longer having to remember what program I am in. I can usually have at least 3 programs open at any given time depending on what I am modding or making.
  2. Input fields tab into the next field selecting the input values and ready to be overwritten.
  3. Input fields require an 'enter' to accept the input as a value. This is nice as it keeps fat fingering issues down when making changes.....says the guy who fat fingers everything....you should see how much I have to go back and edit my posts after typing.....this helps with that.
  4. Like the idea of the Support blocker, but wonder if it should be a mesh object as well as a generic box....but it is a good step in the right direction. I can see much use for this.
  • Link to post
    Share on other sites
    • Replies 168
    • Created
    • Last Reply

    Top Posters In This Topic

    Top Posters In This Topic

    Popular Posts

    After another period of continuous research and development, we're proud to share the latest Ultimaker Cura Beta with you. We're excited to hear what you think of the new and improved features. With y

    Drawing a polyline on a mesh inside Cura to create new geometry would be quite computationally expensive (to the point of not being feasible for now).   The “christmass may come early” plugi

    Thanks for the mention @SandervG, I will put together a topic that describes the new bridging features and the associated settings.

    Posted Images

    Posted · Introducing Ultimaker Cura 3.3 | Beta
    2 hours ago, kmanstudios said:

    Input fields require an 'enter' to accept the input as a value. This is nice as it keeps fat fingering issues down when making changes.....

     

    I am not sure if that was an intended change.

     

    2 hours ago, kmanstudios said:

    Like the idea of the Support blocker, but wonder if it should be a mesh object as well as a generic box....

     

    Could you elaborate on that? I am not sure I understand.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    3 minutes ago, ahoeben said:

    I am not sure if that was an intended change.

     

    I have the same problem with CURA 3.2.1 and CURA 3.3 : I have to type number after number gently otherwise the default value will reappear.

    I think the value entered is immediately used to calculate the values that it depends on, which causes a delay.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    It does not run on my MacBook Retina with MacOS High Sierra 10.13.3

     

    When I try to start it, I can see the splash screen until "...loadind scenes", then it opens some confirmation page and immediately exits without trace.

     

    Can I help with some logfiles? Where to find?

     

    Cheers from GY, -pl

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 hour ago, ahoeben said:

     

    I am not sure if that was an intended change.

     

     

    Could you elaborate on that? I am not sure I understand.

    Give me time today as it is 5AM here and I just got up to change filament and start a new print. Then it is off to a full day of stuff, but I have an example I can whip up to demonstrate.

     

    As for the intended change or not, I do like the way the input fields are working.....soothing to me wee little soul and keeps a behaviour across multiple programs in line. Hard enough to navigate the multitude of mouse choices. LOL

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 hour ago, ahoeben said:

     

    I am not sure if that was an intended change.

     

     

    Could you elaborate on that? I am not sure I understand.

     

    I think works great but also I would love to have 3 shapes to choose. Like a brush. Different shapes to paint the unsupported areas?  Or maybe just a slider to change the box size? Like a brush slider to make bigger/smaller unsupported areas

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    This update is amazing!  The bridging settings are really useful and the support blocker is invaluable.  Great work Cura team!

     

    Has anyone been able to get the Octoprint plugin working?  I can install it from the manager, but the 'Print with Octoprint' button doesn't do anything.  I believe this problem happened when Cura 3.2 was released as well, and manually copying the Octoprint files from github worked.  Unfortunately, that doesn't seem to work with 3.3.  I also tried to copy over the working plugin files from 3.2 to 3.3, but when I do this I get a Python error and Cura 3.3 won't start.  I can delete the plugin and Cura will start again, but then the plugin doesn't work.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    The update from the plugin browser should work, maybe @ahoeben can help?

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    2 hours ago, AirBronto said:

    Has anyone been able to get the Octoprint plugin working?  I can install it from the manager, but the 'Print with Octoprint' button doesn't do anything. 

     

    I need logs to see what is going wrong. Go to help->show configuration folder, and locate cura.log. Please post that file somewhere and share a link.

     

    Network printing (to UM3) has been totally rewritten in Cura 3.3, and as a result the OctoPrint plugin also needed a fairly major rewrite. The 3.2 version of the plugin will not work with Cura 3.3, and vice versa. The new version has not had as much testing as I would have liked, but I was busy with the setting visibility presets and the support blocker... Testing is much appreciated.

  • Link to post
    Share on other sites
    Posted (edited) · Introducing Ultimaker Cura 3.3 | Beta
    12 hours ago, ahoeben said:

     

    I am not sure if that was an intended change.

     

     

    Could you elaborate on that? I am not sure I understand.

    I do believe I figured a better work around than trying to code something like this. As it is, it does exactly what it was designed to do. If I am right on the work around, it will get published once the Noobian Knave gets around to putting some things together for another Clumsy Noobverse post.

    Edited by kmanstudios
    Severe Typelexia
  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    4 hours ago, ahoeben said:

     

    I need logs to see what is going wrong. Go to help->show configuration folder, and locate cura.log. Please post that file somewhere and share a link.

     

    Network printing (to UM3) has been totally rewritten in Cura 3.3, and as a result the OctoPrint plugin also needed a fairly major rewrite. The 3.2 version of the plugin will not work with Cura 3.3, and vice versa. The new version has not had as much testing as I would have liked, but I was busy with the setting visibility presets and the support blocker... Testing is much appreciated.

     

    These are the lines that get generated when I print to OctoPrint that seem to include the error.  I can try to post the entire log file but it's pretty big:

     

    2018-03-28 17:22:41,306 - DEBUG - [MainThread] UFPWriter.UFPWriter._createSnapshot [25]: Creating thumbnail image...
    2018-03-28 17:22:41,306 - INFO - [Thread-8] SliceInfoPlugin.SliceInfoJob.run [29]: Sending anonymous slice info to [https://stats.ultimaker.com/api/cura]...
    2018-03-28 17:22:41,309 - DEBUG - [MainThread] UM.View.GL.ShaderProgram.load [55]: Loading shader file [C:\Program Files\Ultimaker Cura 3.3\resources\shaders\overhang.shader]...
    2018-03-28 17:22:41,890 - DEBUG - [Thread-5] USBPrinting.AutoDetectBaudJob.run [37]: Checking COM5 if baud rate 38400 works
    2018-03-28 17:22:42,705 - ERROR - [MainThread] UM.Logger.logException [81]: Exception: Unable to write to file CFDMP_Turntable_Top_v2: 'BuildPlateModel' object has no attribute 'activeBuildPlate'
    2018-03-28 17:22:42,706 - ERROR - [MainThread] UM.Logger.logException [85]: Traceback (most recent call last):
    2018-03-28 17:22:42,707 - ERROR - [MainThread] UM.Logger.logException [85]:   File "X:\3.3\build\inst\lib\python3.5\site-packages\UM\Qt\Bindings\OutputDeviceManagerProxy.py", line 122, in _writeToDevice
    2018-03-28 17:22:42,708 - ERROR - [MainThread] UM.Logger.logException [85]:   File "C:\Users\Chris\AppData\Roaming\cura\3.3\plugins\OctoPrintPlugin\OctoPrintPlugin\OctoPrintOutputDevice.py", line 302, in requestWrite
    2018-03-28 17:22:42,709 - ERROR - [MainThread] UM.Logger.logException [85]:     active_build_plate = Application.getInstance().getBuildPlateModel().activeBuildPlate
    2018-03-28 17:22:42,710 - ERROR - [MainThread] UM.Logger.logException [85]: AttributeError: 'BuildPlateModel' object has no attribute 'activeBuildPlate'
    2018-03-28 17:22:42,993 - INFO - [Thread-8] SliceInfoPlugin.SliceInfoJob.run [33]: Sent anonymous slice info.

    It looks like the Application.getInstance().getbuildPlateModel().activateBuildPlace function is looking for an attribute that doesn't exist.  This is with a brand new version of Cura 3.3 with a brand new version of the Octoprint plugin installed through the plugin manager.

     

    Let me know if you need more information.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    Hello,

     

    Creality CR-10 here.

    Have 3.2.1 installed without problems.

     

    Beta 3.3 crashed instant with my configuration.
    With blank config it will start, selecting CR-10 and Add Printer it will crash :(

    Next start the wizard is back, nothing configured.

     

    If I choose for example Ultimaker 2 it works.

    If i try to add the cr-10 later, it will instant crash again.

    Seems it don't like my cr-10 anymore :(

    Link to cura.log
    https://www.dropbox.com/s/caqdrq9e1eoqszr/cura.log?dl=0

     

     

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    9 hours ago, papavomsee said:

    Hello,

     

    Creality CR-10 here.

    Have 3.2.1 installed without problems.

     

    Beta 3.3 crashed instant with my configuration.
    With blank config it will start, selecting CR-10 and Add Printer it will crash :(

    Next start the wizard is back, nothing configured.

     

    If I choose for example Ultimaker 2 it works.

    If i try to add the cr-10 later, it will instant crash again.

    Seems it don't like my cr-10 anymore :(

    Link to cura.log
    https://www.dropbox.com/s/caqdrq9e1eoqszr/cura.log?dl=0

     

     

    Are you using custom profiles/materials? With a clean install of 3.3 I can add a CR-10 without any problems.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    10 hours ago, AirBronto said:

     

    These are the lines that get generated when I print to OctoPrint that seem to include the error.  I can try to post the entire log file but it's pretty big:

     

     

    Thanks for looking in to it. Could you try http://files.fieldofview.com/temp/OctoPrintPlugin.curaplugin ?

     

    You can safely remove the log file every now and then, otherwise it will just keep growing and growing.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 hour ago, Msuurmond said:

    Are you using custom profiles/materials? With a clean install of 3.3 I can add a CR-10 without any problems.

     

    Hm that is strange.
    Sure I have custom profiles with my settings.

    But after the crash he ziped my settings and gave me a fresh start.

    This is why the printer wizard comes up.

     

    What else can I do?

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    10 hours ago, papavomsee said:

    Hello,

     

    Creality CR-10 here.

    Have 3.2.1 installed without problems.

     

    Beta 3.3 crashed instant with my configuration.
    With blank config it will start, selecting CR-10 and Add Printer it will crash :(

    Next start the wizard is back, nothing configured.

     

    If I choose for example Ultimaker 2 it works.

    If i try to add the cr-10 later, it will instant crash again.

    Seems it don't like my cr-10 anymore :(

    Link to cura.log
    https://www.dropbox.com/s/caqdrq9e1eoqszr/cura.log?dl=0

     

     

    We now have a "fix" that'll likely be included with 3.3 stable that causes Cura to no longer crash on this but instead deactivate the printer and display a message.

    As for the actual bug though, it looks like someone renamed the "low" quality profile to "fast". I'll implement a version upgrade routine to fix that for other people, but for you your configuration will stay broken because your files have already been upgraded to 3.3.

     

    Thanks for testing and helping us debug your bug :)

     

    On 28/03/2018 at 9:44 AM, ahoeben said:

    I am not sure if that was an intended change.

    I don't think it was, actually. You like it better?

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    image.png.9de7522a0e19147a1132fe0d26666905.pngInstall error

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    1 hour ago, ghostkeeper said:

    I don't think it was, actually. You like it better?

     

    I don't. @kmanstudios does, apparently.

     

    workflow.png

    • Like 2
    Link to post
    Share on other sites
    Posted (edited) · Introducing Ultimaker Cura 3.3 | Beta
    16 minutes ago, ahoeben said:

     

    I don't. @kmanstudios does, apparently.

     

    workflow.png

    I do not believe I am a metric for anything being better ;)

     

    I like fishsticks and custard :)

    Edited by kmanstudios
    • Like 1
    Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    4 hours ago, ahoeben said:

     

    Thanks for looking in to it. Could you try http://files.fieldofview.com/temp/OctoPrintPlugin.curaplugin ?

     

    You can safely remove the log file every now and then, otherwise it will just keep growing and growing.

     

    Absolutely!  Thanks for the quick response.  I'll test it when I get home from work and I'll let you know the outcome.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    CIRCULAR PRIME TOWERS! ... Hum, sorry...

     

    Although, I think if we want to have really stable prime towers and eliminate almost completely the chance that they get toppled over for some reason, especially on tall prints, we'd need to have the prime towers be wider at the base than at the top, like a pyramid or something alike. I've no idea how hard or easy it would be to encode that though. And to have the Prime Tower menu allow us to define 'Tower Base Thickness' and 'Tower Top Thickness', with a check in CURA making sure that the base is wider than the top, and that the top isn't just a single pixel in width.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    17 minutes ago, Brulti said:

    CIRCULAR PRIME TOWERS! ... Hum, sorry...

     

    Although, I think if we want to have really stable prime towers and eliminate almost completely the chance that they get toppled over for some reason, especially on tall prints, we'd need to have the prime towers be wider at the base than at the top, like a pyramid or something alike. I've no idea how hard or easy it would be to encode that though. And to have the Prime Tower menu allow us to define 'Tower Base Thickness' and 'Tower Top Thickness', with a check in CURA making sure that the base is wider than the top, and that the top isn't just a single pixel in width.

    That by itself is easy to implement. It's probably harder to then predict beforehand how wide the prime tower is going to be to determine where the user is allowed to place objects before slicing.

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta
    Just now, ghostkeeper said:

    That by itself is easy to implement. It's probably harder to then predict beforehand how wide the prime tower is going to be to determine where the user is allowed to place objects before slicing.

     

    Since the base will always be wider than the top, why not use the 'Tower Base Thickness' to create the 'print shadow' thingie and determine the volume of space that the prime tower will occupy, thus the volume of space unavailable for other objects to be printed? It's not like we're going to be printing over the prime tower anyway, so the 'shadow' can keep a constant width, when it comes to determining free space to print, even if the real prime tower doesn't.

     

    If I'm not mistaken, the 'shadow' of the prime tower is determined by the 'Prime Tower Size' parameter. The bigger it is, the more space the tower occupies, the less space I have to print. So, if my idea is implemented, you'd just replace 'Prime Tower Size' by 'Tower Base Thickness' to calculate the shadow. So, basically, keep it the way it is now, just change the number used as a reference?

  • Link to post
    Share on other sites
    Posted · Introducing Ultimaker Cura 3.3 | Beta

    I deinstalled 3.3, deleted all folders in programfiles and user profile.
    Reinstalled 3.3 and now I am able to add the CR-10 :)

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...